GSM application (R&S FSW-K10)
Contents
  • Welcome to the GSM Application
  • About the Measurement
  • Measurements and Result Displays
  • Basics on GSM Measurements
  • Configuration
  • Analysis
  • I/Q Data Import and Export
  • How to Perform Measurements in the GSM Application
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands to Perform GSM Measurements
  • List of Commands
Top


Welcome to the GSM Application

GSM application (R&S FSW-K10) > Welcome to the GSM Application
Welcome to the GSM Application

The R&S FSW-K10 is a firmware application that adds functionality to perform GSM measurements to the R&S FSW.

The R&S FSW-K10 features:

  • Measurements on downlink or uplink signals according to the Third Generation Partnership Project (3GPP) standards for GSM/EDGE, EDGE Evolution (EGPRS2) and Voice services over Adaptive Multi-user Channels on One Slot (VAMOS)
  • Measurement in time, frequency or I/Q domains
  • Measurements of mobiel devices (MS), single carrier and multicarrier base transceiver stations (BTS)
  • Measurement of signals ith GMSK, AQPSK, QPSK, 8PSK, 16QAM and 32QAM modulation, normal or higher symbol rate
  • Measurement of signals using different Tx filters (e.g. narrow and wide pulse)
  • Measurements for Power vs Time, Modulation Accuracy and Modulation and Transient Spectrum as required in the standard
  • Measurements of wideband noise in multicarrier operation (as defined in 3GPP TS 51.021, chapter 6.12)

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the GSM Application
  • Understanding the Display Information


Starting the GSM Application

GSM application (R&S FSW-K10) > Welcome to the GSM Application > Starting the GSM Application
Starting the GSM Application

GSM measurements are performed in a separate application on the R&S FSW.

To activate the GSM application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "GSM" item.

    The R&S FSW opens a new measurement channel for the GSM application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the GSM "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Remote command:

INSTrument[:​SELect]

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement channel can be active at any time. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

When the Sequencer is activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

See also the note on using the Sequencer function in MSRA operating mode in "GSM in MSRA Operating Mode".

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

GSM application (R&S FSW-K10) > Welcome to the GSM Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information, depending on measurement
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA operating mode

In MSRA operating mode, additional tabs and elements are available. An orange background behind the measurement channel tabs indicates that you are in MSRA operating mode.

For details on the MSRA operating mode see "GSM in MSRA Operating Mode" and "Applications and Operating Modes" .

Channel bar information

In the GSM application, the R&S FSW shows the following settings for the default I/Q measurement:

Information displayed in the channel bar in the GSM application for the default I/Q measurement
Ref Level | Reference level
(m.+el.) Att | Mechanical and electronic RF attenuation
Offset | Reference level offset (if available)
Freq / ARFCN | Center frequency for the GSM signal / Absolute Radio Frequency Channel Number (if available)
Device / Band | Device type and frequency band used by the DUT as defined in the "Signal Description" settings
Slot Scope | Minimized visualization of the frame configuration and slots to be measured (see "Defining the Scope of the Measurement")
SGL | The sweep is set to single sweep mode.
Count | Number of frames already evaluated / Total number of frames required for statistical evaluation ("Statistic Count") (For "Statistic Count" > 1)
TRG | Trigger source (if not "Free Run") and used trigger bandwidth (for IF, RF, IP power triggers) or trigger offset (for external triggers)
MCWN measurement

For the MCWN measurement, the R&S FSW shows the following settings:

Information displayed in the channel bar in the GSM application for the MCWN measurement
Ref Level | Reference level
(m.+el.) Att | Mechanical and electronic RF attenuation
Offset | Reference level offset (if available)
Carriers | Number of active carriers
Device / Band | Device type and frequency band used by the DUT as defined in the "Signal Description" settings
Ref Meas | Carrier used for reference measurement (if enabled)
SGL | The sweep is set to single sweep mode
Count | Value of the current average count / Total average count for noise measurement ("Noise Average Count")
TRG | Trigger source (if not "Free Run") and used trigger bandwidth (for IF, RF, IP power triggers) or trigger offset (for external triggers)

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer settings). This information is displayed only when applicable for the current application. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the Pulse application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
6 = Trace mode
Diagram footer information

The diagram footer (beneath the diagram) contains the start and stop values for the displayed time, frequency or symbol range.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


About the Measurement

GSM application (R&S FSW-K10) > About the Measurement
About the Measurement

A basic GSM measurement in the R&S FSW GSM application includes a power vs time and a spectrum measurement, as well as modulation accuracy (e.g. EVM, phase error) for a GSM signal as defined by the relevant 3GPP standards. The I/Q data from the GSM signal applied to the RF input of the R&S FSW is captured for a specified measurement time. This data is demodulated and synchronized with a reference signal to identify the individual frames and slots. The slots of interest are then analyzed in order to display the spectral and power results either graphically or numerically, and to calculate the modulation parameters.

The standard distinguishes between single-slot and multi-slot measurements. Single-slot measurements analyze one slot - referred to as the "Slot to measure" - within the GSM frame (which consists of 8 slots in total). Modulation-specific parameters such as the phase error, EVM, or spectrum due to modulation are determined on a per-slot basis. Multi-slot measurements, on the other hand, analyze a slot scope of up to 8 consecutive slots, each of which has different burst modulation characteristics. Power vs time limit checks and the transient spectrum measurements, for example, are determined for multiple slots.

Statistical evaluation of several measurements is also possible. Finally, the GSM measurement results can be exported to other applications.


Measurements and Result Displays

GSM application (R&S FSW-K10) > Measurements and Result Displays
Measurements and Result Displays

The R&S FSW GSM application provides two different measurements in order to determine the parameters described by the GSM specifications.

The default GSM I/Q measurement captures the I/Q data from the GSM signal. The I/Q data includes magnitude and phase information, which allows the R&S FSW GSM application to demodulate signals and determine various characteristic signal parameters such as the modulation accuracy, power vs time, modulation and transient spectrum in just one measurement.

For multicarrier measurements, some parameters required by the GSM standard require a frequency sweep with varying resolution bandwidths. Thus, a new separate measurement is provided by the R&S FSW GSM application to determine the wideband noise in multicarrier measurement setups.

For details on selecting measurements see "Selecting the measurement type".

Contents
  • GSM I/Q (Modulation Accuracy, etc.) Measurement Results
  • Multicarrier Wideband Noise Measurements


GSM I/Q (Modulation Accuracy, etc.) Measurement Results

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results
GSM I/Q (Modulation Accuracy, etc.) Measurement Results

The I/Q data that was captured by the default GSM (Modulation Accuracy, etc.) measurement can be evaluated using different methods. All evaluation methods available for the GSM measurements are displayed in the selection bar in SmartGrid mode.

To activate SmartGrid mode, do one of the following:

  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.
  • Press the MEAS key.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

By default, the GSM measurement results for I/Q measurements are displayed in the following windows:

  • "Magnitude Capture"
  • "PvT Full Burst"
  • "Modulation Accuracy"
  • "Power vs Slot"

The following evaluation methods are available for GSM I/Q measurements:

└ Constellation
└ EVM
└ Magnitude Capture
└ Magnitude Error
└ Marker Table
└ Modulation Accuracy
└ Modulation Spectrum Graph
└ Modulation Spectrum Table
└ Phase Error
└ Power vs Slot
└ PvT Full Burst
└ Transient Spectrum Graph
└ Transient Spectrum Table
└ Trigger to Sync Graph
└ Trigger to Sync Table


Constellation

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Constellation
Constellation

The complex source signal is displayed as an X/Y diagram. The application analyzes the specified slot over the specified number of bursts.

Remote command:

LAY:ADD? '1',RIGH,CONS, see LAYout:​ADD[:​WINDow]?


EVM

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > EVM
EVM

Displays the error vector magnitude over time for the "Slot to Measure".

Remote command:

LAY:ADD:WIND '2',RIGH,ETIMe see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Magnitude Capture

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Magnitude Capture
Magnitude Capture

Displays the power vs. time trace of the captured I/Q data.

Pre-trigger samples are not displayed.

The analyzed slot scopes (1 to 8 slots of a single GSM frame) are indicated by a green bar, the "Slot to Measure" in each frame by a blue bar at the bottom of the diagram.

For details see "Defining the Scope of the Measurement".

For negative trigger offsets, the trigger is displayed as a vertical red line labeled "TRG".

Remote command:

LAY:ADD:WIND '2',RIGH,MCAP see LAYout:​ADD[:​WINDow]?

Results:

FETCh:​MCAPture:​SLOTs:​SCOPe?

FETCh:​MCAPture:​SLOTs:​MEASure?

TRACe<n>[:​DATA]?


Magnitude Error

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Magnitude Error
Magnitude Error

Displays the magnitude error over time for the "Slot to Measure".

Remote command:

LAY:ADD:WIND '2',RIGH,MERR see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Marker Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Modulation Accuracy

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Modulation Accuracy
Modulation Accuracy

Displays the numeric values of the fundamental modulation characteristics of the signal to be analyzed in the vector (I/Q) domain: error vector magnitude (EVM), magnitude and phase error, IQ imbalance, etc.

The following modulation parameters are determined:

Modulation accuracy parameters
Parameter | Description | SCPI query for result value
EVM | Error vector magnitude for the "Slot to Measure" RMS and peak error values for the current frame, in percent 95%ile: error value (in percent) below which 95% of all EVM results for all frames in entire measurement fall | READ:BURSt[:MACCuracy][:EVM]:PEAK:<Resulttype>? READ:BURSt[:MACCuracy][:EVM]:RMS:<Resulttype>? READ:BURSt[:MACCuracy]PERCentile:EVM?
Mag Error | Magnitude error for the "Slot to Measure" RMS and peak error values for the current frame, in percent 95%ile: error value (in percent) below which 95% of all Magnitude Error results for all frames in entire measurement fall | READ:BURSt[:MACCuracy]:MERRor:PEAK:<Resulttype>? READ:BURSt[:MACCuracy]:MERRor:RMS:<Resulttype>? READ:BURSt[:MACCuracy]PERCentile:MERRor?
Phase Error | Phase error for the "Slot to Measure" RMS and peak error values for the current frame, in percent 95%ile: error value (in percent) below which 95% of all Phase Error results for all frames in entire measurement fall | READ:BURSt[:MACCuracy]:PERRor:PEAK:<Resulttype>? READ:BURSt[:MACCuracy]:PERRor:RMS:<Resulttype>? READ:BURSt[:MACCuracy]PERCentile:PERRor?
Origin Offset Suppression [dB] | Origin offset suppression for the demodulated signal in the "Slot to Measure"; Indicates the suppression of the DC carrier; the higher the suppression, the better the DUT | READ:BURSt[:MACCuracy]:OSUPpress:<Resulttype>?
I/Q Offset [%] | I/Q offset for the demodulated signal in the "Slot to Measure" | READ:BURSt[:MACCuracy]:IQOFfset:<Resulttype>?
I/Q Imbalance [%] | A measure for gain imbalances and quadrature errors between the inplace and quadrature components of the signal. | READ:BURSt[:MACCuracy]:IQIMbalance:<Resulttype>?
Frequency Error [Hz] | Frequency error of the center frequency currently measured in the "Slot to Measure" | READ:BURSt[:MACCuracy]:FERRor:<Resulttype>?
Burst Power [dBm] | Average power measured in the slot | READ:BURSt[:MACCuracy]:BPOWer:<Resulttype>?
Amplitude Droop [dB] | Indicates how much the amplitude decreases over a measured slot | READ:BURSt[:MACCuracy]:ADRoop:<Resulttype>?

The R&S FSW GSM application also performs statistical evaluation over a specified number of results (see "Statistic Count"). To do so, the same slot is evaluated in multiple frames, namely in the number specified by the "Statistic Count". The default value is 200 in accordance with the GSM standard.

For each parameter, the following results are displayed:

Calculated summary results
Result type | Description | SCPI query for result value
Current | Value for currently measured frame only | READ:BURSt[:MACCuracy]:<Parameter>:CURRent?
Average | Linear average value of "Current" results from the specified number of frames Exception: The average of the "Origin Offset Suppression" is the linear average of the power ratio, converted to dBm subsequently | READ:BURSt[:MACCuracy]:<Parameter>:AVERage?
Peak | Maximum value of "Current" results from specified number of frames Exception: The peak of the "Origin Offset Suppression" is the minimum value, as this represents the worst case, which needs to be detected | READ:BURSt[:MACCuracy]:<Parameter>:MAXimum?
Std Dev | Standard deviation of "Current" results for specified number of frames | READ:BURSt[:MACCuracy]:<Parameter>:SDEViation?
Remote command:

LAY:ADD:WIND '2',RIGH,MACC see LAYout:​ADD[:​WINDow]?

Results:

READ:​BURSt[:​MACCuracy]:​ALL

"Modulation Accuracy Results"


Modulation Spectrum Graph

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Modulation Spectrum Graph
Modulation Spectrum Graph

The modulation spectrum evaluates the power vs frequency trace of a certain part of the burst (50 to 90 % of the useful part, excluding the training sequence TSC) by measuring the average power in this part over several frames at certain fixed frequency offsets.

The "Modulation Spectrum Graph" displays the measured power levels as a trace against the frequencies.

The measured values can be checked against defined limits; the limit lines are indicated as red lines in the diagram. The result of the limit check ("PASS"/"FAIL") are shown at the top of the diagram.

Note: The GSM standards define both absolute and relative limits for the spectrum. The limit check is considered to fail if both limits are exceeded.

Note: The graphical results only provide an overview of the spectrum. For a detailed conformance check of the DUT to the GSM standard, use the "Modulation Spectrum Table" evaluation, which uses the 5-pole filter required by the 3GPP standard.
The numeric results of the modulation spectrum evaluation are displayed in the "Modulation Spectrum Table".

The following default settings are used for a "Modulation Spectrum" evaluation.

Default settings for a "Modulation Spectrum" evaluation
Setting | Default
Measurement Scope | The slot selected as "Slot to Measure"
Averaging Configuration | Number of bursts as selected in "Statistic Count"
Limit Check | According to standard: Limit check of average (Avg) trace See "Limit Check for Modulation Spectrum"

Note: Modulation RBW at 1800 kHz. For the "Modulation Spectrum Graph" both the RBW and VBW are set to 30 kHz.

Remote command:

LAY:ADD:WIND '2',RIGH,MSFD see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?

CALCulate<n>:​LIMit<k>:​FAIL?

CALCulate<n>:​LIMit<k>:​UPPer[:​DATA]?

CALCulate<n>:​LIMit<k>:​CONTrol:​DATA?


Modulation Spectrum Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Modulation Spectrum Table
Modulation Spectrum Table

The modulation spectrum evaluates the power vs frequency trace of a certain part of the burst (50 to 90 % of the useful part, excluding the training sequence TSC) by measuring the average power in this part over several frames.

The "Modulation Spectrum Table" displays the measured power levels and their offset to the limits defined by the standard as numeric results.

Note: The GSM standards define both absolute and relative limits for the spectrum. The limit check is considered to fail if both limits are exceeded.
Values that exceed both limits are indicated by red characters and an asterisk (*) next to the value, and a negative "Δ to Limit" value.

Note: The graphical results of the modulation spectrum evaluation are displayed in the "Modulation Spectrum Graph".

The following values are displayed:

Modulation spectrum results
Result | Description
Offset [kHz] | Fixed frequency offsets (from the center frequency) at which power is measured
Power Negative Offsets | Power at the frequency offset to the left of the center frequency Levels are provided as: [dB]: relative power level [dBm]: absolute power level Δ to Limit: power difference to limit defined in standard; negative values indicate the power exceeds at least one of the limits
Power Positive Offsets | Power at the frequency offset to the right of the center frequency Levels are provided as: [dB]: relative power level [dBm]: absolute power level Δ to Limit: power difference to limit defined in standard; negative values indicate the power exceeds at least one of the limits
Frequencies and filter bandwidths in modulation spectrum measurements
Offset Frequency (kHz) | RBW (kHz) | VBW (kHz)
± 100 | 30 | 30
± 200 | 30 | 30
± 250 | 30 | 30
± 400 | 30 | 30
± 600 | 30 | 30
± 800 | 30 | 30
± 1000 | 30 | 30
± 1200 | 30 | 30
± 1400 | 30 | 30
± 1600 | 30 | 30
± 1800 | 30 (single-carrier BTS); 100 (multi-carrier BTS); | 30 (single-carrier BTS); 100 (multi-carrier BTS);

Note: "Normal" vs "Wide" Modulation Spectrum measurements. In previous R&S signal and spectrum analyzers, both a "normal" and a "wide" modulation spectrum were available for GSM measurements. In the R&S FSW GSM application, only one evaluation is provided. The frequency range of the frequency list, however, can be configured to be "wider" or "narrower" (see "Modulation Spectrum Table: Frequency List"). The RBW and VBW are then adapted accordingly.

Note: RBW at 1800 kHz. As opposed to previous R&S signal and spectrum analyzers, in which the RBW at 1800 kHz was configurable, the R&S FSW configures the RBW (and VBW) internally according to the selected frequency list (see "Modulation Spectrum Table: Frequency List"). For the "Modulation Spectrum Graph" both the RBW and VBW are set to 30 kHz. For the "Modulation Spectrum Table", they are set according to table "RBW settings for Modulation Spectrum Table measurements according to standard", depending on the measured "Device Type" and the number of active carriers as defined in the "Signal Description" settings.

RBW settings for Modulation Spectrum Table measurements according to standard
Offset | Single-carrier BTS | Multicarrier BTS (N=1) | Multicarrier BTS (N>1) | MS mode
< 1.8 MHz | 30 kHz 1) | 30 kHz 3) | 30 kHz 2) | 30 kHz 4)
1.8 MHz | 30 kHz 1) | 100 kHz 3) | 100 kHz 2) | 100 kHz 5)
> 1.8 MHz | 100 kHz 3) | 100 kHz 3) | 100 kHz 2) | 100 kHz 5)
1) See 3GPP TS 51.021 § 6.5.1.2 c) d) 2) See 3GPP TS 51.021 § 6.12.2 3) See 3GPP TS 51.021 § 6.5.1.2 f) 4) See 3GPP TS 51.010-1 § 13.4.4.2 f) and 3GPP TS45.005 § 4.2.1.3, table a1-c4 5) See 3GPP TS 51.010-1 § 13.4.4.2 d) and 3GPP TS 45.005 § 4.2.1.3
Remote command:

LAY:ADD:WIND '2',RIGH,MST see LAYout:​ADD[:​WINDow]?

Results:

READ:​SPECtrum:​MODulation[:​ALL]?

READ:​SPECtrum:​MODulation:​REFerence[:​IMMediate]?


Phase Error

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Phase Error
Phase Error

Displays the phase error over time.

The following default settings are used for a "Phase Error vs Time" measurement.

Setting | Default
Measurement Scope | The slot selected as "Slot to Measure"
Averaging Configuration | Number of frames as selected in "Statistic Count"
Limit Check | None
Remote command:

LAY:ADD:WIND '2',RIGH,PERR see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?


Power vs Slot

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Power vs Slot
Power vs Slot

Displays the power per slot in the current frame and over all frames. The result of the (Power vs Time) limit check is also indicated.

Note: The power is measured for inactive slots, but not for slots outside the slot scope (see "Defining the Scope of the Measurement").

The following power values are determined:

Measured power values for Power vs Slot results
Value | Description | SCPI query for result value
Slot | Analyzed slot number in frame(s) [0..7] |
PvT Limit | Power vs Time limit for the power vs time trace of the slot, defined by the standard | READ:​BURSt:​SPOWer:​SLOT<Slot>:​LIMit:​FAIL?
Delta to Sync [NSP] | The distance between the mid of the TSC and the TSC of the "Slot to Measure" NSP stands for Normal Symbol Period, i.e. the duration of one symbol using a normal symbol rate (approx. 3.69μs). The measured "Delta to Sync" value has a resolution of 0.02 NSP. For details see "Delta to Sync Values". | READ:​BURSt:​SPOWer:​SLOT<Slot>:​DELTatosync?
Power Avg [dBm] | Average power in slot in current or all frames | READ:​BURSt:​SPOWer:​SLOT<Slot>:​CURRent:​AVERage? READ:​BURSt:​SPOWer:​SLOT<Slot>:​ALL:​AVERage?
Power Peak [dBm] | Maximum power in slot in current or all frames | READ:​BURSt:​SPOWer:​SLOT<Slot>:​CURRent:​MAXimum? READ:​BURSt:​SPOWer:​SLOT<Slot>:​ALL:​MAXimum?
Crest [dB] | Crest factor in slot in current or all frames, i.e. Power Peak / Power Avg | READ:​BURSt:​SPOWer:​SLOT<Slot>:​CURRent:​CRESt? READ:​BURSt:​SPOWer:​SLOT<Slot>:​ALL:​CRESt?
Remote command:

LAY:ADD:WIND '2',RIGH,PST see LAYout:​ADD[:​WINDow]?

Results:

"Power vs Slot Results"


PvT Full Burst

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > PvT Full Burst
PvT Full Burst

The Power vs Time evaluation determines the power of all slots (bursts) in the selected slot scope and performs a limit check of the power vs time trace against the specified PvT mask.

The "PvT Full Burst" result display shows the power vs time trace, where the time axis corresponds to the selected slot scope. The PvT mask is indicated by red lines, and the overall result of the limit check is shown at the top of the diagram.

Note: The result of the Power vs Time limit check for individual slots is indicated in the "Power vs Slot" evaluation.

Note: Full burst refers to the fact that the entire burst is displayed, including the rising and falling edges and the burst top. However, you can easily analyze the edges in more detail using the zoom functions (see "Zoom Functions").

The following default settings are used for a "Power vs Time" evaluation.

Default settings for a "Power vs Time" evaluation

Setting

Default

Measurement Scope

The slot scope defined by "First Slot to measure" and "Number of Slots to measure"

Averaging Configuration

Number of bursts as selected in "Statistic Count"

Limit Check

According to standard:

  • The maximum (Max) trace is checked agains the upper limit.
  • The minimum (Min) trace is checked against the lower limit.

See "Limit Check for Power vs Time Results"

Remote command:

LAY:ADD:WIND '2',RIGH,PTF see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?

TRACe<n>[:​DATA]:​X?

CALCulate<n>:​LIMit<k>:​FAIL?

CALCulate<n>:​LIMit<k>:​UPPer[:​DATA]?

CALCulate<n>:​LIMit<k>:​CONTrol:​DATA?


Transient Spectrum Graph

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Transient Spectrum Graph
Transient Spectrum Graph

The transient spectrum is very similar to the modulation spectrum evaluation; it evaluates the power vs frequency trace by measuring the power over several frames. However, as opposed to the modulation spectrum evaluation, the entire slot scope (defined by the "Number of Slots to measure" and the "First Slot to measure") is evaluated in each frame, including the rising and falling burst edges, not just the useful part in the "Slot to Measure".

Furthermore, the number of fixed frequency offsets is lower, and the peak power is evaluated rather than the average power, as this measurement is used to determine irregularities.

The "Transient Spectrum Graph" displays the measured power levels as a trace against the frequencies for the specified slots.

The measured values can be checked against defined limits; the limit lines are indicated as red lines in the diagram. The result of the limit check ("PASS"/"FAIL") is shown at the top of the diagram.

Note: The GSM standards define both absolute and relative limits for the spectrum. The limit check is considered to fail if both limits are exceeded.

Note: The graphical results only provide an overview of the spectrum. For a detailed conformance check of the DUT to the GSM standard, use the "Transient Spectrum Table" evaluation, which uses the 5-pole filter required by the 3GPP standard.
The numeric results of the modulation spectrum evaluation are displayed in the "Modulation Spectrum Table".

The following default settings are used for "Transient Spectrum" measurements.

Setting | Default
Measurement Scope | The slot scope defined by "Number of Slots to measure" and the "First Slot to measure" in the "Demodulation Settings" (see "Slot Scope").
Averaging Configuration | Number of frames as selected in "Statistic Count"
Limit Check | Limit check of maximum (Max) trace See "Limit Check for Transient Spectrum"
Remote command:

LAY:ADD:WIND '2',RIGH,TSFD see LAYout:​ADD[:​WINDow]?

Results:

TRACe<n>[:​DATA]?

CALCulate<n>:​LIMit<k>:​FAIL?


Transient Spectrum Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Transient Spectrum Table
Transient Spectrum Table

The transient spectrum evaluates the power vs frequency trace of the slot scope by measuring the power in these slots over several frames.

For details see "Transient Spectrum Graph".

The "Transient Spectrum Table" displays the measured power levels and their offset to the limits defined by the standard as numeric results.

Note: The GSM standards define both absolute and relative limits for the spectrum. The limit check is considered to fail if both limits are exceeded.
Values that exceed both limits are indicated by red characters and an asterisk (*) next to the value, and a negative "Δ to Limit" value.

Note: The graphical results of the transient spectrum evaluation are displayed in the "Transient Spectrum Graph".

The following values are displayed:

Modulation spectrum results
Result | Description
Offset [kHz] | Fixed frequency offsets (from the center frequency) at which power is measured
Power Negative Offsets | Power at the frequency offset to the left of the center frequency Levels are provided as: [dB]: relative power level [dBm]: absolute power level Δ to Limit: power difference to limit defined in standard; negative values indicate the power exceeds at least one of the limits
Power Positive Offsets | Power at the frequency offset to the right of the center frequency Levels are provided as: [dB]: relative power level [dBm]: absolute power level Δ to Limit: power difference to limit defined in standard; negative values indicate the power exceeds at least one of the limits
Remote command:

LAY:ADD:WIND '2',RIGH,TST see LAYout:​ADD[:​WINDow]?

Results:

READ:​SPECtrum:​SWITching[:​ALL]?

READ:​SPECtrum:​SWITching:​REFerence[:​IMMediate]


Trigger to Sync Graph

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Trigger to Sync Graph
Trigger to Sync Graph

The Trigger to Sync measurement determines the time between an external trigger event and the start of the first symbol of the TSC. The start of the first symbol of the TSC corresponds to the time 0 of the symbol period (see "Definition of the Symbol Period").

Only one result per data capture is provided. Therefore, it is useful to perform several data captures and average the results to obtain an accurate value (see "Statistic Count").

Both graphical and numeric (table) results are available. While the graphical results are mainly used to determine the required measurement settings, the numeric results provide the actual trigger to sync value, including statistical evaluation (see "Trigger to Sync Table").

The Trigger to Sync diagram shows two traces:

  • Trace1: a histogram shows the probability density function (PDF) of all measured Trigger to Sync values. Obviously, the histogram can only provide reasonable results if several I/Q captures are performed and considered. In an ideal case (assuming no noise), the histogram would be a rectangle over the sampling time.
    The histogram is helpful to determine the number of Trigger to Sync values to be averaged ("Statistic Count") in order to obtain the required time resolution of the averaged Trigger to Sync value. The higher the statistic count, the more the graph becomes rectangular, and the higher the resolution of the averaged Trigger to Sync value becomes.
  • Trace2: the second trace is superimposed on the histogram and visualizes the probability density function (PDF) of the average Trigger to Sync value and the standard deviation as provided in the Trigger to Sync table. This trace helps you judge the reliability of the averaged values in the table. The narrower this trace, the less the individual values deviate from the averaged result. if this trace is too wide, increase the "Statistic Count".

Note: The x-axis of the histogram indicates the individual Trigger to Sync values. Thus, the scaling must be very small, in the range of ns. However, since the value range, in particular the start value, of the possible results is not known, the x-axis must be adapted to the actual values after a number of measurements have taken place. This is done using the adaptive data size setting (see "Adaptive Data Size"). This setting defines how many measurements are performed before the x-axis is adapted to the measured values, and then fixed to that range.

Remote command:

LAY:ADD? '1',RIGH,TGSG, see LAYout:​ADD[:​WINDow]?

DISPlay:WINDow:TRACe1:MODE WRITe (for Histogram, see DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE )

DISPlay:WINDow:TRACe2:MODE PDFavg (for PDF of average, see DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE)

Results:

TRACe<n>[:​DATA]?

TRACe<n>[:​DATA]:​X?


Trigger to Sync Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > GSM I/Q (Modulation Accuracy, etc.) Measurement Results > Trigger to Sync Table
Trigger to Sync Table

The Trigger to Sync measurement determines the time between an external trigger event and the start of the first symbol of the TSC. The start of the first symbol of the TSC corresponds to the time 0 of the symbol period (see "Definition of the Symbol Period").

Only one result per data capture is provided. Therefore, it is useful to perform several data captures and average the results to obtain an accurate value (see "Statistic Count").

Both graphical and numeric (table) results are available. While the graphical results are mainly used to determine the required measurement settings (see "Trigger to Sync Graph"), the numeric results provide the actual trigger to sync value, including statistical evaluation.

The Trigger to Sync table shows the following values:

Value | Description
Current | Trigger to Sync value for current measurement in μs
Average | Trigger to Sync value averaged over the "Statistic Count" number of measurements
Min | Minimum Trigger to Sync value in the previous "Statistic Count" number of measurements
Max | Maximum Trigger to Sync value in the previous "Statistic Count" number of measurements
Std Dev | Standard deviation of the individual Trigger to Sync values to the average value
Remote command:

LAY:ADD? '1',RIGH,TGST, see LAYout:​ADD[:​WINDow]?

Results:

"Trigger to Sync Results"


Multicarrier Wideband Noise Measurements

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements
Multicarrier Wideband Noise Measurements

The I/Q data captured by the default GSM I/Q measurement includes magnitude and phase information, which allows the R&S FSW GSM application to demodulate signals and determine various characteristic signal parameters such as the modulation accuracy, modulation or transient spectrum in just one measurement.

As the result of a swept measurement, on the other hand, the signal cannot be demodulated based on the power vs. frequency trace data. Frequency sweep measurements can tune on a constant frequency ("Zero span measurement") or sweep a frequency range ("Frequency sweep measurement").

For multicarrier measurements, the GSM standard defines limits for some parameters concerning noise and intermodulation products. Thus, a new separate measurement is provided by the R&S FSW GSM application: the Multicarrier Wideband Noise Measurement (MCWN). This measurement comprises:

  • I/Q based measurements on the carriers to determine their power levels and reference powers
  • Frequency sweeps with RBWs of 100 kHz (to measure wideband noise) and 300 kHz (to measure intermodulation products)
MCWN measurements and MSRA mode

MCWN measurements are only available in Signal and Spectrum Analyzer operating mode, not in MSRA mode (see "GSM in MSRA Operating Mode").

For more information on MCWN measurements see also "Multicarrier and Wideband Noise".

Contents
  • Multicarrier Evaluation Methods


Multicarrier Evaluation Methods

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements > Multicarrier Evaluation Methods
Multicarrier Evaluation Methods

The GSM multicarrier wideband noise measurement can be evaluated using different methods. All evaluation methods available for the measurement are displayed in the selection bar in SmartGrid mode.

To activate SmartGrid mode, do one of the following:
  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.
  • Press the MEAS key.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

By default, the MWCN measurement results are displayed in the following windows:

  • "Spectrum Graph"
  • "Carrier Power Table"

The following evaluation methods are available for GSM MCWN measurements:

└ Spectrum Graph
└ Carrier Power Table
└ Outer IM Table
└ Inner IM Table


Spectrum Graph

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements > Multicarrier Evaluation Methods > Spectrum Graph
Spectrum Graph

Displays the level results for the frequencies in the defined frequency span (typically the Tx band).

The trace is calculated from a frequency sweep with a 100 kHz RBW and one sweep with a 300 kHz RBW. The displayed trace is averaged over the "Noise Average Count" number of noise measurements.

The results of the limit check are also indicated in the diagram (see also "Limit Check for MCWN Results"):

Limit line checks
Label | Possible values | Description / Limit line suffix (<k>)
Limit check | PASS | FAIL | Overall limit check for all limit lines
Wideband Noise (<current> exceptions) | PASS | FAIL | Limit check for wideband noise (trace) (Number of detected exceptions; provided only if exceptions are enabled) <k> = 1
IM 100 kHz | PASS | FAIL | Limit check for intermodulation at 100 kHz (Number of detected exceptions; provided only if exceptions are enabled) <k> = 2
IM 300 kHz | PASS | FAIL | Limit check for intermodulation at 300 kHz <k> = 3
Exceptions: <current> < <maximum> | PASS | FAIL | Number of bands with exceptions in range A (currently detected vs. maximum allowed); provided only if exceptions are enabled <k> = 5
Exceptions: <current> < <maximum> | PASS | FAIL | Number of bands with exceptions in range B (currently detected vs. maximum allowed); provided only if exceptions are enabled <k> = 6
Remote command:

LAY:ADD? '1',RIGH,WSFDomain, see LAYout:​ADD[:​WINDow]?

Results:

TRACe:DATA? TRACe1, see TRACe<n>[:​DATA]?

Limit results:

FETCh:​SPECtrum:​MODulation:​LIMit:​FAIL?

CALCulate<n>:​LIMit<k>:​FAIL?

CALCulate<n>:​LIMit<k>:​CONTrol:​DATA?

CALCulate<n>:​LIMit<k>:​UPPer[:​DATA]?

CALCulate<n>:​LIMit<k>:​EXCeption:​COUNt:​CURR?

CALCulate<n>:​LIMit<k>:​EXCeption:​COUNt:​MAX?


Carrier Power Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements > Multicarrier Evaluation Methods > Carrier Power Table
Carrier Power Table

Displays the measured power levels and reference powers of all active carriers.

The following parameters are shown:

Carrier power measurement results

Parameter

Description

Carrier No.

Active carrier number (as defined in "Carrier Settings").

Additional labels:

  • "max": the carrier with the highest power level
    (If the reference power is determined by a reference measurement (see "Enabling a reference power measurement ( Measure )"), and automatic carrier selection is active, see "Carrier Selection / Carrier".)
  • "ref": selected carrier for reference power
    (If the reference power is determined by a reference measurement (see "Enabling a reference power measurement ( Measure )"), but the carrier is selected manually, see "Carrier Selection / Carrier".)
  • "man": manually defined reference powers (see "Defining Reference Powers Manually")

Carrier frequency

Frequency of the carrier at which power was measured

Power level

Measured power level in dBm

Reference power with RBW 300 kHz

Reference power for measurement with 300 kHz RBW (or manually defined reference value)

Reference power with RBW 100 kHz

Reference power for measurement with 100 kHz RBW (or manually defined reference value)

Reference power with RBW 30 kHz

Reference power for measurement with 30 kHz RBW (or manually defined reference value)

Remote command:

LAY:ADD? '1',RIGH,WSRP, see LAYout:​ADD[:​WINDow]?

Results:

FETCh:​WSPectrum:​REFerence:​POWer[:​ALL]?


Outer IM Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements > Multicarrier Evaluation Methods > Outer IM Table
Outer IM Table

Displays the measured intermodulation products (up to the order specified in "Intermodulation") for the frequencies outside of the sub-blocks (but not in the gap).

For each of the following regions the parameters described in table "Intermodulation results" are shown:
  • frequencies to the left of the lowermost carrier
  • frequencies to the right of the uppermost carrier

The rows are sorted in ascending order of the absolute IM frequency.

The frequency offsets are defined as offsets from the closest carrier, i.e. the lowermost carrier of the lower sub-block and the uppermost carrier of the upper sub-block.

Inner and outer intermodulation

The following parameters are shown:

Intermodulation results
Result | Description
Offset [MHz] | Frequency offsets (from the closest carrier) at which intermodulation power is measured
Freq [MHz] | Absolute frequency of intermodulation product
Order | Order of intermodulation product
RBW [kHz] | Resolution bandwidth used for measurement
dB | relative power level (to reference power) measured at IM frequency
dBm | absolute power level measured at IM frequency
Δ to Limit: | power difference to limit defined in standard (negative values indicate: limit check failed)

If "Intermodulation" is "off", this table is empty.

Remote command:

LAY:ADD? '1',RIGH,OIMP, see LAYout:​ADD[:​WINDow]?

Results:

FETCh:​WSPectrum:​IMPRoducts:​OUTer[:​ALL]?


Inner IM Table

GSM application (R&S FSW-K10) > Measurements and Result Displays > Multicarrier Wideband Noise Measurements > Multicarrier Evaluation Methods > Inner IM Table
Inner IM Table

Similar to the "Outer IM Table", but the measured intermodulation products (up to the order specified in "Intermodulation") for the frequencies in the gap between the GSM carrier blocks for non-contiguous carrier allocation are displayed. The frequency offsets are defined as offsets from the closest carrier, i.e. the uppermost carrier of the lower sub-block and the lowermost carrier of the upper sub-block.

Inner and outer intermodulation

The rows are sorted in ascending order of the absolute IM frequency.

For contiguous carrier allocation or if "Intermodulation" is "off", this table is empty.

Remote command:

LAY:ADD? '1',RIGH,IIMP, see LAYout:​ADD[:​WINDow]?

Results:

FETCh:​WSPectrum:​IMPRoducts:​INNer[:​ALL]?


Basics on GSM Measurements

GSM application (R&S FSW-K10) > Basics on GSM Measurements
Basics on GSM Measurements

Some background knowledge on basic terms and principles used in GSM measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Relevant Digital Standards
  • Short introduction to GSM (GMSK, EDGE and EDGE Evolution)
  • Short Introduction to VAMOS
  • AQPSK Modulation
  • Trigger settings
  • Defining the Scope of the Measurement
  • Overview of filters in the R&S FSW GSM application
  • Dependency of Slot Parameters
  • Definition of the Symbol Period
  • Synchronization
  • Timeslot Alignment
  • Delta to Sync Values
  • Limit Checks
  • Impact of the "Statistic Count"
  • Multicarrier and Wideband Noise
  • Automatic Carrier Detection
  • GSM in MSRA Operating Mode


Relevant Digital Standards

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Relevant Digital Standards
Relevant Digital Standards

The measurements and the physical layer – the layer of the GSM network on which modulation, transmission of RF signals, reception of RF signals, and demodulation take place – is defined in the standards:

GSM standards
  • 3GPP TS 45.004

Details on Modulation

  • 3GPP TS 45.005

General measurement specifications and limit values

  • 3GPP TS 45.010

Details on Synchronization and Timing

  • 3GPP TS 51.010

Detailed measurement specifications and limit values for mobile stations (MS)

  • 3GPP TS 51.021

Detailed measurement specifications and limit values for base transceiver stations (BTS)


Short introduction to GSM (GMSK, EDGE and EDGE Evolution)

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Short introduction to GSM (GMSK, EDGE and EDGE Evolution)
Short introduction to GSM (GMSK, EDGE and EDGE Evolution)

The GSM (Global System for Mobile Communication) standard describes the GSM mobile radio network that is in widespread use today. In a first step to enhance this network, 8PSK modulation has been defined in addition to the existing GMSK (Gaussian Minimum Shift Keying) modulation. With 8PSK, the mobile or base station operates in the EDGE mode. While the 8PSK modulation transmits 3 bits within a symbol, GMSK can only transmit 1 bit within a symbol.

In a second step to enhance this network, higher symbol rate (HSR), QPSK, 16QAM, and 32QAM modulation, narrow and wide pulse shapes for the Tx filter have been defined. Here, EDGE Evolution and EGPRS2 are synonyms for this second enhancement.

This means that GSM includes different modes: GMSK, EDGE and EDGE Evolution. The terms EDGE and EDGE Evolution are used here only when there are significant differences between the modes. In all other cases, the term GSM is used.

Time domain vs frequency domain

A TDMA (Time Division Multiple Access) and FDMA (Frequency Division Multiple Access) scheme is used to transfer data in the GSM network. This means that the digital information is transmitted discretely in the time domain (mainly used to distinguish between different users) as well as in the frequency domain (mainly used to distinguish between BTS).

Slots and frames

The time domain is divided into slots with a duration of 576.923 µs (exactly: 3/5200 s). 8 slots (numbered 0 to 7) are combined into 1 frame with a duration of approximately 4.6154 ms (exactly: 3/650 s).

Multiframes and superframes

Frames can be grouped into a multiframe consisting of either 26 (for support traffic and associated control channels) or 51 (for all other purposes) frames. Multiframes can be grouped to superframes consisting of either 51 26-frame or 26 51-frame multiframes.

Multiframes and superframes are not of relevance for the physical measurements on the GSM system and thus not discussed in detail here.

A mobile phone, therefore, does not communicate continuously with the base station; instead, it communicates discretely in individual slots assigned by the base station during connection and call establishment. In the simplest case, 8 mobiles share the 8 slots of a frame (TDMA).

Frequency bands and channels

The frequency range assigned to GSM is divided into frequency bands, and each band, in turn, is subdivided into channels.

Each frequency channel is identified by its center frequency and a number, known as the ARFCN (Absolute Radio Frequency Channel Number), which identifies the frequency channel within the specific frequency band. The GSM channel spacing is 200 kHz.

Communication between a mobile and a base station can be either frequency-continuous or frequency-discrete – distributed across various frequency channels (FDMA). In the standard, the abbreviation "SFH" (slow frequency hopping) is used to designate the latter mode of communication.

Uplink and downlink

Base stations and mobiles communicate in different frequency ranges; the mobile sends in the "uplink" (UL), and the base station in the "downlink" (DL).

The frequencies specified in the standard plus their channel numbers (ARFCN) are shown in the figure and table below.

The frequencies specified in the GSM standard
Frequencies and channel numbers (ARFCN) in the GSM standard
Band Class | UL [MHz] | Frequency | DL [MHz] | Frequency | Frequency Middle | Band | UL-DL Shift | ARFCN
 | Low. | Up. | Low. | Up. | UL | DL |  | Range 1 | Range 2
T-GSM 380 | 380.2 | 389.8 | 390.2 | 399.8 | 385.0 | 395.0 | 10 MHz | 0 … 48 1) | –
T-GSM 410 | 410.2 | 419.8 | 420.2 | 429.8 | 415.0 | 425.0 | 10 MHz | 0 … 48 1) | –
GSM 450 | 450.4 | 457.6 | 460.4 | 467.6 | 454.0 | 464.0 | 10 MHz | 259 … 293 | –
GSM 480 | 478.8 | 486.0 | 488.8 | 496.0 | 482.4 | 492.4 | 10 MHz | 306 … 340 | –
GSM 710 | 698.0 | 716.0 | 728.0 | 746.0 | 707.0 | 737.0 | 30 MHz | 0 … 90 1) | –
GSM 750 | 747.0 | 762.0 | 777.0 | 792.0 | 754.5 | 784.5 | 30 MHz | 438 … 511 | –
T-GSM 810 | 806.0 | 821.0 | 851.0 | 866.0 | 813.5 | 858.5 | 45 MHz | 0 … 75 1) | –
GSM 850 | 824.0 | 849.0 | 869.0 | 894.0 | 836.5 | 881.5 | 45 MHz | 128 … 251 | –
P-GSM 900 | 890.0 | 915.0 | 935.0 | 960.0 | 902.5 | 947.5 | 45 MHz | 1 … 124 | –
E-GSM 900 | 880.0 | 915.0 | 925.0 | 960.0 | 897.5 | 942.5 | 45 MHz | 0 … 124 | 975 … 1023
R-GSM 900 | 876.0 | 915.0 | 921.0 | 960.0 | 895.5 | 940.5 | 45 MHz | 0 … 124 | 955 … 1023
T-GSM 900 | 870.4 | 876.0 | 915.4 | 921.0 | 873.2 | 918.2 | 45 MHz | 0 … 28 1) | –
DCS 1800 | 1710.0 | 1785.0 | 1805.0 | 1880.0 | 1747.5 | 1842.5 | 95 MHz | 512 … 885 | –
PCS 1900 | 1850.0 | 1910.0 | 1930.0 | 1990.0 | 1880.0 | 1960.0 | 80 MHz | 512 … 810 | –
1) For these frequency bands, there is no fixed ARFCN to frequency assignment, instead it is calculated with a formula taking an OFFSET parameter which is signaled by a higher layer of the network. The given ARFCNs assume an OFFSET value of 0.
Modulation modes

Different modulation modes are used in the GSM mobile radio network. The original GSM modulation is GMSK, with the normal symbol rate (NSR) of approximately 270.833 ksymb/s (exactly: 1625/6 ksymb/s). This corresponds to a bit rate of 270.833 kbit/s. The details are specified in chapter 2 of "3GPP TS 45.004" (see table "GSM standards").

The 8PSK (Phase Shift Keying) modulation, which is used within EDGE, was introduced to increase the data rate on the physical link. It uses the same symbol rate (the normal symbol rate) as GMSK (270.833 ksymb/s), but has a bit rate of 3 × 270.833 kbit/s (exactly: 812.5 kbit/s).

In this method, three bits represent a symbol. The details are specified in chapter 3 "3GPP TS 45.004" (see table "GSM standards").

The 16QAM and 32QAM (Quadrature Amplitude Modulation) modulation, which are used in EDGE Evolution, were introduced to further increase the data rate on the physical link. They use the normal symbol rate (270.833 ksymb/s), but have bit rates of 4 × 270.833 kbit/s or 5 × 270.833 kbit/s, respectively. The details are specified in chapter 4 "3GPP TS 45.004" (see table "GSM standards").

The QPSK, 16QAM and 32QAM modulation with a higher symbol rate, which are used in EDGE Evolution, were introduced to further increase the data rate on the physical link. They use a higher symbol rate (325 ksymb/s), but have bit rates of 2 × 325 kbit/s, 4 × 325 kbit/s or 5 × 325 kbit/s, respectively. The details are specified in chapter 5 "3GPP TS 45.004" (see table "GSM standards").

The figure below shows the modulation spectrum for both GMSK and 8PSK.

GMSK and 8PSK modulation spectrum
Increasing the bandwidth - multiple slots (GPRS, HSCSD)

The customers’ demand for higher telecommunication speeds increases the demand for bandwidth. Therefore, the GSM standard has to evolve constantly. An example of this development is the introduction of the EDGE/EDGE Evolution specification and the GPRS/EGPRS2 and HSCSD modes.

Until now, each mobile could use only one slot per frame, but the new HSCSD (High Speed Circuit Switched Data) and GPRS (General Packet Radio Service) methods will allow permanent assignment of more than one slot per mobile, plus dynamic utilization of multiple slots.

The concept behind GPRS is dynamic assignment of up to 8 slots to each mobile for data transmission, depending on demand (and availability in the network).

HSCSD allows permanent assignment of up to 4 slots to a mobile.

Normal and higher symbol rates

The modulation modes GMSK, QPSK, 8PSK, 16QAM and 32QAM can be used with either normal or higher symbol rate and different Tx filters.

What is significant for the R&S FSW GSM application in this respect is that the mobile can send power on a frequency in more than one slot.


Short Introduction to VAMOS

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Short Introduction to VAMOS
Short Introduction to VAMOS

The "Voice services over Adaptive Multi-user Channels on One Slot" (VAMOS) extension to the GSM standard allows transmission of two GMSK users simultaneously within a single time slot.

Subchannels

The standard specifies the downlink signal using Adaptive QPSK (AQPSK) modulation (see 3GPP TS 45.004), where two "subchannel" binary sequences are multiplexed to form a single QPSK sequence. The ratio of powers for the subchannels is referred to as the "Subchannel Power Imbalance Ratio" (SCPIR). One of the subchannels is interpreted as interference. The value of SCPIR affects the shape of the AQPSK constellation. For an SCPIR of 0dB the constellation is square (as in "normal" QSPK), while for other values of the SCPIR the constellation becomes rectangular.

Training sequences (TSCs)

A new set of training sequences (TSCs) has also been proposed (see 3GPP TS 45.002) for GMSK signals. The previous TSCs for GMSK bursts are listed as "Set 1", while the new TSCs are listed as "Set 2". AQPSK signals can be formed using TSCs from Set 1 on the first subchannel and TSCs from either Set 1 or Set 2 on the second subchannel. In case a TSC from Set 2 is used, it should match the TSC from Set 1, i.e. TSC<n> from Set 1 on subchannel 1 should match TSC<n> from Set 2 on subchannel 2, for n = 0..7.

TSC vs "Midamble"

The terms TSC and Midamble are used synonymously in the standard. In this documentation, we use the term TSC to refer to the known symbol sequence in the middle of the slot.

The R&S FSW GSM application supports measurement of the following signals:

  • GMSK bursts using the TSCs from Set 1 or Set 2
  • AQPSK bursts with combinations of TSCs from Set 1 and 2 on the subchannels
  • AQPSK bursts with a user-specified SCPIR

The following measurements of the above signals are supported:

  • Power vs Time
  • Demod (Modulation Accuracy, EVM vs Time, Phase Error vs Time, Magnitude Error vs Time, Constellation)
  • Spectrum (modulation, transient) including limit check
  • Automatic trigger offset detection
Restriction for auto frame configuration

Auto Frame configuration only detects AQPSK normal bursts where the subchannels have a TSC according to table "Required subchannel - TSC assignment for AQPSK auto frame configuration". The SCPIR value is detected with a resolution of 1 dB. To obtain reliable measurement results on AQPSK normal bursts, compare the auto-detected slot settings with the settings of your device under test.

Required subchannel - TSC assignment for AQPSK auto frame configuration
AQPSK |  |  | Subchannel 2
 |  |  | TSC j (Set 1) |  |  |  |  |  |  |  | TSC j (Set 2)
 |  |  | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
Subchannel1 | TSC i (Set 1) | 0 |  |  | x | x |  |  |  | x | x |  |  |  |  |  |  |
 |  | 1 |  |  | x | x |  |  |  | x |  | x |  |  |  |  |  |
 |  | 2 | x | x |  |  |  | x |  |  |  |  | x |  |  |  |  |
 |  | 3 | x | x |  |  | x |  |  |  |  |  |  | x |  |  |  |
 |  | 4 |  |  |  | x |  |  | x |  |  |  |  |  | x |  |  |
 |  | 5 |  |  | x |  |  |  | x |  |  |  |  |  |  | x |  |
 |  | 6 |  |  |  |  | x | x |  |  |  |  |  |  |  |  | x |
 |  | 7 | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  | x


AQPSK Modulation

GSM application (R&S FSW-K10) > Basics on GSM Measurements > AQPSK Modulation
AQPSK Modulation

The AQPSK modulation scheme as proposed for use in GSM systems is illustrated in figure "AQPSK modulation scheme for GSM systems". First, the bits from two users (subchannels 1 and 2) are interleaved. The combined bit sequence is then mapped to an AQPSK constellation which depends on the SCPIR value. The AQPSK symbols are then modulated using the linearized GMSK pulse (see 3GPP TS 45.004).

AQPSK modulation scheme for GSM systems

The proposed AQPSK mapping (as assumed in the R&S FSW GSM application) is given in table "AQPSK symbol mappings [reproduced from 3GPP TS 45.004]" and illustrated in figure "AQPSK constellation [reproduced from 3GPP TS 45.004].", where the first (leftmost) bit corresponds to subchannel 1 and the second (rightmost) bit corresponds to subchannel 2.

AQPSK symbol mappings [reproduced from 3GPP TS 45.004]
Modulating bits for ai, bi | AQPSK symbol in polar notation si
(0,0) | ejα
(0,1) | e-jα
(1,0) | -e-jα
(1,1) | -ejα

The AQPSK modulation constellation diagram is shown in figure "AQPSK constellation [reproduced from 3GPP TS 45.004].", where the value α is an angle related to the SCPIR as follows:

SCPIRdB = 20*log10[tan(α) ] dB

AQPSK constellation [reproduced from 3GPP TS 45.004].


Trigger settings

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Trigger settings
Trigger settings

The GSM measurements can be performed in "Free Run" (untriggered) mode; however, an external trigger or a power trigger can speed up measurements. To perform measurements the R&S FSW GSM application needs the frame start as a time reference. The R&S FSW GSM application searches for a frame start after every I/Q data acquisition. The required search effort depends on the trigger mode.

Consider the following trigger mode settings:

  • In "Free Run" mode, i.e. without any trigger, the GSM application totally relies on the frame/slot configuration to find the frame start. The start of a measurement is not triggered. Once a measurement is completed, another is started immediately. For an unambiguous frame configuration, the GSM application searches for the frame start inside the captured I/Q data. This is the slowest frame search mode.
  • With a "Power Trigger", the measurement is triggered by the power ramp of the received GSM bursts. Nevertheless the GSM application still relies on the frame/slot configuration to find the frame start inside the captured I/Q data. Once a measurement is completed, the GSM application waits for the next trigger event to start the next measurement. The search for the frame start is as in "Free Run" mode, except that the I/Q data capture is triggered.
  • With the "External Trigger", the measurement is triggered by an external signal (connected to the "EXT TRIGGER" input of the R&S FSW). The GSM application assumes that the frame start (i.e. the "active part" in slot 0) directly follows the trigger event. An external trigger requires a correct setting of the trigger offset. The search is faster compared to the free run and power trigger modes. Use an external trigger to maximize the measurement speed or if the frame configuration is ambiguous (i.e. if the slot properties are cyclic with a cycle less than the frame duration).
Trigger source for MSRA Master

Any trigger source other than "Free Run" defined for the MSRA Master is ignored when determining the frame start in the R&S FSW GSM application. For this purpose, the trigger is considered to be in "Free Run" mode.

Refer to "Trigger Settings" to learn more about appropriate trigger settings and to "Signal Description" for information on the frame/slot configuration.

Refer to "Automatic Trigger Offset" to learn more about setting the trigger offset automatically.


Defining the Scope of the Measurement

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Defining the Scope of the Measurement
Defining the Scope of the Measurement

The R&S FSW GSM application is slot-based. It can measure up to 8 consecutive GSM slots (1 frame) and store the power results for all slots ("Power vs Time" and "Power vs Slot" measurements, see "PvT Full Burst" and "Power vs Slot").

In previous R&S signal and spectrum analyzers, the term "burst" was used synonymously for "slot". In this documentation, we use the term "burst" when the signal behaves like a pulse, i.e. power is ramped up and down. The up ramp is referred to as the rising edge, the down ramp as the falling edge. A burst may occur within one or more slots, which is a measure of time in the captured signal. Thus, a burst may coincide with a slot, but it must not necessarily do so.

Usually only slots in which a burst is expected are of interest. Such slots are defined as active slots in the signal description.

Within this slot scope (defined by "First Slot to measure" and "Number of Slots to measure"), a single slot ( "Slot to Measure") is selected for a more detailed analysis (e.g. "Modulation Accuracy" measurement, see "Modulation Accuracy"). The "Slot to Measure" is required for the following reasons:

  • To provide the reference power and time reference for the "Power vs Time" measurement (see "PvT Full Burst"). Typically, the masks for all slots are time-aligned according to the timing of the "Slot to Measure" (see "Limit Line Time Alignment").
  • All "Modulation Spectrum" results are based on the "Slot to Measure" (see "Modulation Spectrum Graph"). (The results of all "Transient Spectrum" diagrams are based on the slot scope, i.e. on the interval defined by the "First Slot to measure" and the "Number of Slots to measure", see "Transient Spectrum Graph").
  • All results that require demodulation of one slot and statistical analysis (e.g. "Modulation Accuracy", "Phase Error", and "EVM") are based on the "Slot to Measure".

The slot scope is defined in the "Demodulation Settings" (see "Slot Scope"), and it is indicated by a filled green box in the "Frame Configuration" (see figure "Frame configuration in "Slot Scope" settings"). The "Slot to Measure" is indicated by a filled blue box.

Frame configuration and slot scope in the channel bar

In the channel bar of the R&S FSW GSM application, as well as in the configuration "Overview", the current frame configuration and slot scope are visualized in a miniature graphic. Furthermore, the burst type and modulation of the "Slot to Measure" are indicated.

Frame configuration in GSM application channel bar

The graphic can be interpreted as follows:

Shape/Color | Meaning
 | Each slot is represented by a small box
 | Active slots are indicated by polygonal symbols
 | Slots within the defined slot scope are highlighted green
 | The defined "Slot to Measure" is highlighted blue; the burst type and modulation defined for this slot are indicated to the right of the graphic
Frame configuration in the Frame and Slot Scope dialog boxes

The same graphic is displayed in the "Frame Configuration" of the "Frame" dialog box (see "Frame Configuration: Select Slot to Configure") and in the "Slot Scope" tab of the "Demodulation" dialog box (see "Slot Scope").

Frame configuration in "Slot Scope" settings

This graphic can be interpreted as follows:

  • Each slot is represented by its number (0 to 7).
  • Slot numbers within the defined slot scope are highlighted green.
  • The number of the defined "Slot to Measure" is highlighted blue.
  • Active slots are indicated by polygonal symbols above the number which contain the following information:
    – The burst type, e.g. "Norm" for a normal burst
    – The modulation, e.g. GMSK
    – The training sequence TSC (and Set) or Sync (for access bursts)


Overview of filters in the R&S FSW GSM application

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Overview of filters in the R&S FSW GSM application
Overview of filters in the R&S FSW GSM application

The R&S FSW GSM application requires a number of filters for different stages of signal processing. These include the "Multicarrier" filter (for multicarrier base station measurements only), the "Power vs Time" filter and the "Measurement" filter. A signal flow diagram is shown in figure "Signal flow diagram highlighting filtering operations" to illustrate where the different filters are used.

Signal flow diagram highlighting filtering operations
Contents
  • Power vs Time Filter
  • Multicarrier Filter
  • Measurement Filter


Power vs Time Filter

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Overview of filters in the R&S FSW GSM application > Power vs Time Filter
Power vs Time Filter

The "Power vs Time" filter is used to suppress out-of-band interference in the Power vs Time measurement (see "PvT Full Burst").

The following filters are available:

Single-carrier filters:
  • 1 MHz Gauss
  • 500 kHz Gauss
  • 600 kHz
Multicarrier filters:
  • 400 kHz MC
  • 300 kHz MC

The magnitude and step responses of the different "Power vs Time" filters are shown in figure "Magnitude Response of the Power vs Time Filters " and figure "Step Response of the Power vs Time Filters", respectively. In general, the smaller the filter bandwidth, the worse the step response becomes (in terms of "ringing" effects) and the better the suppression of interference at higher frequencies. Gaussian type filters are especially useful for signals with "sharp" edges as the step response does not exhibit overshoot.

Magnitude Response of the Power vs Time Filters
Step Response of the Power vs Time Filters


Multicarrier Filter

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Overview of filters in the R&S FSW GSM application > Multicarrier Filter
Multicarrier Filter

The "Multicarrier" filter is a special PVT filter that is applied to the captured data if the device is defined as a multicarrier type . This filter is used to suppress neighboring channels which may disturb measurement of the channel of interest. The output from the "Multicarrier" filter is used to perform synchronization and demodulation. The frequency response of the "Multicarrier" filter is shown in figure "Frequency Response of the Multicarrier Filter".

Frequency Response of the Multicarrier Filter


Measurement Filter

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Overview of filters in the R&S FSW GSM application > Measurement Filter
Measurement Filter

The "Measurement" filter is used to limit the bandwidth of the demodulation measurements and is described in the 3GPP standard document TS 45.005 for QPSK, 8PSK, 16QAM and 32QAM as follows:

  • a raised-cosine filter with roll-off 0.25 and single side-band 6 dB bandwidth 90 kHz for normal symbol rate and for higher symbol-rate using narrow bandwidth pulse-shaping filter
  • a raised-cosine filter with roll-off 0.25 and single side-band 6 dB bandwidth 108 kHz for higher symbol-rate using wide bandwidth pulse-shaping filter

In addition to these filters, a "Measurement" filter for GMSK is used in the R&S FSW GSM application to limit the effects of out-of-band interference due to the high sampling rate of 6.5 MHz which is used. The magnitude responses of all the "Measurement" filters are shown in figure "Magnitude Responses of Measurement Filters for Demodulation Measurements".

Magnitude Responses of Measurement Filters for Demodulation Measurements


Dependency of Slot Parameters

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Dependency of Slot Parameters
Dependency of Slot Parameters

The parameters that define a slot used for a GSM measurement are dependant on each other, and only the following combinations of these parameters are available in the R&S FSW GSM application (see "Slot Settings").

Dependency of slot parameters
Burst Type | Modulation | Filter | TSC
AB | GMSK | GMSK Pulse | TS 0, TS 1, TS 2
 |  |  | User
HSR | QPSK, 16QAM, 32QAM | Narrow Pulse, Wide Pulse | TSC 0, …, TSC 7
 |  |  | User
NB | 8PSK, 16QAM, 32QAM | Linearised GMSK Pulse | TSC 0, …, TSC 7
 |  |  | User
 | AQPSK | Linearised GMSK Pulse | Subchannel 1: TSC 0 (Set 1), …, TSC 7 (Set 1) Subchannel 2: TSC 0 (Set 1), …, TSC 7 (Set 1), TSC 0 (Set 2), …, TSC 7 (Set 2)
 |  |  | Subchannel 1: User Subchannel 2: User
 | GMSK | GMSK Pulse | TSC 0 (Set 1), …, TSC 7 (Set 1), TSC 0 (Set 2), …, TSC 7 (Set 2)
 |  |  | User


Definition of the Symbol Period

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Definition of the Symbol Period
Definition of the Symbol Period

The following sections define the symbol period for various modulation types.

Contents
  • GMSK Modulation (Normal Symbol Rate)
  • 8PSK, 16QAM, 32QAM, AQPSK Modulation (Normal Symbol Rate)
  • QPSK, 16QAM and 32QAM Modulation (Higher Symbol Rate)


GMSK Modulation (Normal Symbol Rate)

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Definition of the Symbol Period > GMSK Modulation (Normal Symbol Rate)
GMSK Modulation (Normal Symbol Rate)

The GMSK frequency pulse is defined in the standard document "3GPP TS 45.004" as a Gaussian pulse convolved with a rectangular pulse, as illustrated at the top of figure "GMSK Frequency Pulse (top) and phase of the first tail symbol (bottom)". The phase of a GMSK signal due to a sequence of symbols {α} is defined in the standard as:

Phase of a GMSK signal due to a sequence of symbols

where:

  • g(t): the frequency pulse
  • T: the normal symbol period

The modulating index is chosen such that the maximum phase change of π/2 radians per data interval is achieved.

Note that the standard 3GPP TS 45.004 specifies in chapter "2.5 Output phase" for Normal Burst GMSK:

"The time reference t' = 0 is the start of the active part of the burst as shown in figure 1. This is also the start of the bit period of bit number 0 (the first tail bit) as defined in 3GPP TS 45.002."

The phase change due to the first tail symbol is illustrated at the bottom of figure "GMSK Frequency Pulse (top) and phase of the first tail symbol (bottom)", where you can see that the "decision instant" corresponding to the center of the frequency pulse occurs at the beginning of the first symbol period, i.e. at t' = 0."

GMSK Frequency Pulse (top) and phase of the first tail symbol (bottom)


8PSK, 16QAM, 32QAM, AQPSK Modulation (Normal Symbol Rate)

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Definition of the Symbol Period > 8PSK, 16QAM, 32QAM, AQPSK Modulation (Normal Symbol Rate)
8PSK, 16QAM, 32QAM, AQPSK Modulation (Normal Symbol Rate)

The EDGE transmit pulse is defined in the standard document "3GPP TS 45.004" as a linearised GMSK pulse, as illustrated at the top of figure "EDGE transmit pulse (top) and the first transmitted symbol (bottom)". Note that according to the definition in the standard, the center of the pulse occurs at 2.5 T, where T is the normal symbol period (NSP). The baseband signal due to a sequence of symbols { [image]} is defined in the standard as:

Baseband signal due to a sequence of symbols

where:

c0(t): the transmit pulse

Note that the standard 3GPP TS 45.004 specifies in chapter "3.5 Pulse shaping" for normal burst 8PSK, 16QAM and 32QAM:

"The time reference t' = 0 is the start of the active part of the burst as shown in figure 3. This is also the start of the symbol period of symbol number 0 (containing the first tail bit) as defined in 3GPP TS 45.002."

For normal burst AQPSK, the standard 3GPP TS 45.004 specifies in chapter "6.5 Pulse shaping":

"The time reference t' = 0 is the start of the active part of the burst as shown in figure 6. This is also the start of the symbol period of symbol number 0 (containing the first tail bit) as defined in 3GPP TS 45.002."

The transmitted pulse for the first tail symbol is illustrated in the lower part of figure "EDGE transmit pulse (top) and the first transmitted symbol (bottom)", where it can be seen that the "decision instant" corresponding to the center of the transmit pulse occurs in the center of the first symbol period, i.e. at t'=0.5T.

EDGE transmit pulse (top) and the first transmitted symbol (bottom)

The description above also applies to the 16QAM and 32QAM modulations defined for EDGE Evolution, using the "normal" symbol rate.


QPSK, 16QAM and 32QAM Modulation (Higher Symbol Rate)

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Definition of the Symbol Period > QPSK, 16QAM and 32QAM Modulation (Higher Symbol Rate)
QPSK, 16QAM and 32QAM Modulation (Higher Symbol Rate)

For the newer "reduced" symbol period (higher symbol rate) the standard document "3GPP TS 45.004" defines two transmit pulse shapes; the so-called "narrow" and "wide" pulses. The narrow pulse is the same linearised GMSK pulse as described in "8PSK, 16QAM, 32QAM, AQPSK Modulation (Normal Symbol Rate)", while the wide pulse was designed based on a numerically optimized set of discrete filter coefficients. Both narrow and wide pulse shapes are illustrated at the top of figure "EDGE Evolution transmit pulses (top) and the first transmitted symbols (bottom)", where you can see that the center of the pulse occurs at 3T, with T being the reduced symbol period. For a sequence of symbols { [image]}, the transmitted signal is defined in the standard as:

The transmitted signal for a sequence of symbols

where:

c(t): the transmit pulse(which may be either the narrow or wide pulse)

Note that the standard 3GPP TS 45.004 specifies in chapter "5.5 Pulse shaping" for higher symbol rate burst QPSK, 16QAM and 32QAM:

"The time reference t' = 0 is the start of the active part of the burst as shown in figure 3. This is also the start of the symbol period of symbol number 0 (containing the first tail bit) as defined in 3GPP TS 45.002."

The transmitted pulse for the first tail symbol is illustrated at the bottom of figure "EDGE Evolution transmit pulses (top) and the first transmitted symbols (bottom)", where you can see that the "decision instant" corresponding to the center of the transmit pulse occurs in the center of the first symbol period, i.e. at t'=0.5T.

EDGE Evolution transmit pulses (top) and the first transmitted symbols (bottom)


Synchronization

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Synchronization
Synchronization

In order to detect and distinguish the individual slots and frames in the measured signal, the known signal sequence (Sync or TSC) must be found in each frame.

The synchronization process in the R&S FSW GSM application depends on how or if the measurement is triggered.

Power trigger or Free run mode
Synchronization process

If a power trigger or no trigger is used (free run mode), the synchronization process consists of the following steps:

  1. Beginning at the start of a capture, the application searches for the synchronization pattern (or TSC) of the "Slot to Measure" within one GSM frame length. This search must be performed over the entire area, as the time of occurrance of the TSC within the signal is not known. Thus, it is referred to as a "wide" search.

  2. Once the synchronization point has been found, the application checks whether enough samples remain in the capture buffer in order to analyze another frame. If so, the process continues with the next step.

    Otherwise, a new capture is started and the process begins with step 1 again.

  3. Assuming the signal is periodic, the synchronization point in the signal is moved by exactly one GSM frame length. From there, a "narrow" search for the next TSC is performed within only a small search area.

    Thus, the remaining frames in the capture buffer can be synchronized quickly after the initial "wide" search.

    Steps 2 and 3 are repeated until all frames have been detected.

Synchronization using "wide" and "narrow" searches
Synchronization errors

The process described above assumes the GSM frame length in the signal is periodic (within a given tolerance: "frame length error"). If this is not the case, however, for example if a frame is too short, the application cannot synchronize to further frames after the initial search.

Frequency hopping can lead to the same problem, as successive frames may not be detected on the measured frequency channel.

Failed synchronization due to frame length error and resulting false search area

A special "Measure only on sync" option ensures that only those sections of the captured signal are processed further for which synchronization was possible, thus improving performance.

For frequency-hopping signals, it is recommended that you use a power trigger to ensure capture starts with an active frame.

External trigger

When using an external trigger source, the application assumes that the trigger offset is set such that the GSM frame start is aligned with the start of a capture. Therefore only "narrow" searches are performed from the beginning of the "Synchronization process".


Timeslot Alignment

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Timeslot Alignment
Timeslot Alignment
Reference Time

The definition of a "reference time" is necessary for the following description of timeslot alignment. In the standard document "3GPP TS 45.010", in Section 5.7 it is stated that:

"Irrespective of the symbol duration used, the center of the training sequence shall occur at the same point in time. "

This is illustrated in Figure 5.7.3 of the standard document "3GPP TS 45.010" which is reproduced below for convenience (figure "Timing alignment between normal symbol period and reduced symbol period bursts"). Due to this requirement, the "middle of TSC" or "center of Active Part" shall be used as the reference time when specifying timeslot alignment. Additionally, the "middle of TSC" is used for the alignment of the Power vs Time limit masks (see also "Limit Line Time Alignment").

Timing alignment between normal symbol period and reduced symbol period bursts

As described in "Definition of the Symbol Period", the middle of TSC can be defined with respect to symbol periods and symbol decision instants. This is illustrated in figure "Middle of TSC for normal and reduced symbol period bursts.". You can see that for normal symbol period bursts (Normal bursts), the middle of TSC for GMSK occurs exactly at the decision instant of symbol 74. However, for EDGE it occurs between the decision instants of symbols 73 and 74, while for reduced symbol period bursts (Higher Symbol Rate bursts), it occurs exactly at the decision instant of symbol 88.

Middle of TSC for normal and reduced symbol period bursts.
Timeslot alignment within the frame

The standard document "3GPP TS 45.010" provides details on the alignment of slots within the GSM frame:

"Optionally, the BTS may use a timeslot length of 157 normal symbol periods on timeslots with TN = 0 and 4, and 156 normal symbol periods on timeslots with TN = 1, 2, 3, 5, 6, 7, rather than 156.25 normal symbol periods on all timeslots"

The alignment of slots therefore falls under the "Not Equal Timeslot Length" (Equal Timeslot Length = off) or the "Equal Timeslot Length" (Equal Timeslot Length = on) criterion (see also "Equal Timeslot Length"), which are illustrated in figure " "Not equal"(top) and "equal" (bottom) timeslot length criteria".

"Not equal"(top) and "equal" (bottom) timeslot length criteria

Note that, since the reference point at the "middle of TSC" of each slot must coincide, the length of the guard interval between successive bursts will depend on both the timeslot length and the symbol rate of bursts in successive slots. As stated in the standard "3GPP TS 45.010", for the "Equal Timeslot Length" case:

"… if there is a pair of different symbol period bursts on adjacent timeslots, then the guard period between the two bursts shall be 8.5 normal symbol periods which equals 10.2 reduced symbol periods."

For the "Not Equal Timeslot Length" case, deriving the guard period length is somewhat more complicated, and the possible values are summarized in Table 5.7.2 of "3GPP TS 45.010", reproduced below as table "Guard period lengths between different timeslots", for convenience:

Guard period lengths between different timeslots
Burst Transition | Guard Period Between Timeslots (In terms of normal symbol periods) |  | Guard Period Between Timeslots (In terms of reduced symbol periods)
 | TS0 and TS1 or TS4 and TS5 | Any other timeslot pair | TS0 and TS1 or TS4 and TS5 | Any other timeslot pair
normal symbol period to normal symbol period | 9 | 8 | 10.8 | 9.6
normal symbol period to reduced symbol period | 9.25 | 8.25 | 11.1 | 9.9
reduced symbol period to normal symbol period | 9.25 | 8.25 | 11.1 | 9.9
reduced symbol period to reduced symbol period | 9.5 | 8.5 | 11.4 | 10.2


Delta to Sync Values

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Delta to Sync Values
Delta to Sync Values

The "Delta to Sync" value is defined as the distance between the mid of the TSC and the TSC of the "Slot to Measure".

The results are provided in the unit NSP, which stands for Normal Symbol Period, i.e. the duration of one symbol using a normal symbol rate (approx. 3.69μs). The measured "Delta to Sync" values have a resolution of 0.02 NSP.

These values are either assumed to be constant (according to the 3GPP standard) or measured, depending on the setting of the "Limit Line Time Alignment" parameter ("Slot to measure" or "Per Slot").

According to the standard (see "Timeslot length" in 3GPP TS 45.010), there are either eight slots of equal length (156.25 NSP), or slot 0 and slot 4 have a length of 157 NSP while all other slots have a length of 156 NSP. For details see "Timeslot Alignment".

The timeslot length is defined as the distance between the centers of the TSCs in successive slots. By setting the "Limit Time Alignment" parameter to "Per Slot", the "Delta to Sync" values can be measured and used in order to verify the timeslot lenghts.

Setting the "Limit Line Time Alignment" to "Slot to measure" displays the expected values (according to the standard and depending on the value of "Equal Timeslot Length"). These values are summarized in table "Expected "Delta to Sync" values in normal symbol periods " (Slot to measure = 0, No. of slots = 8 and First slot to measure = 0).

Expected "Delta to Sync" values in normal symbol periods
Slot Number | 0 = Slot to measure | 1 | 2 | 3 | 4 | 5 | 6 | 7
Equal Timeslot Length = On | 0 | 156.25 | 312.50 | 468.75 | 625.00 | 781.25 | 937.50 | 1093.75
Equal Timeslot Length = Off | 0 | 157 | 313 | 469 | 625 | 782 | 938 | 1094


Limit Checks

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Limit Checks
Limit Checks
Contents
  • Limit Check for Modulation Spectrum
  • Limit Check for Transient Spectrum
  • Limit Check for Power vs Time Results


Limit Check for Modulation Spectrum

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Limit Checks > Limit Check for Modulation Spectrum
Limit Check for Modulation Spectrum

The determined "Modulation Spectrum" values in the average (Avg) trace can be checked against limits defined by the standard; the limit lines and the result of the limit check are indicated in the "Modulation Spectrum" diagram (see "Modulation Spectrum Graph").

The GSM standards define both absolute and relative limits for the spectrum. The limit check is considered to fail if both limits are exceeded.

The limits depend on the following parameters:

  • Frequency band
  • Device Type (only BTS type, not MS type)
  • Burst Type / Modulation / Filter - limits are different for Higher Symbol Rate and Wide Pulse Filter (case 2) and others (case 1), see 3GPP TS 45.005, chapter 4.2.1.3
  • The measured reference power (30 kHz bandwidth)
  • The measured burst power (power level)
  • Number of active carriers for multicarrier BTS. The limit is relaxed by 10*log10(N) dB for offset frequencies ≥1.8 MHz, see 3GPP TS 45.005 chapter 4.2.1.2


Limit Check for Transient Spectrum

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Limit Checks > Limit Check for Transient Spectrum
Limit Check for Transient Spectrum

The determined "Transient Spectrum Accuracy" values can be checked against limits defined by the standard; the limit lines and the result of the limit check are indicated in the "Transient Spectrum" diagram (see "Transient Spectrum Graph").

The limits depend on the following parameters:

  • Graph: Limit check of maximum (Max) trace
  • Table: Limit check of absolute and relative scalar values
  • The limit masks are generated adaptively from the measured signal.
  • The limits depend on the following parameters:
    – Frequency band (not for MS)
    – Burst Type / Modulation / Filter (not for MS)
    – The measured reference (slot) power


Limit Check for Power vs Time Results

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Limit Checks > Limit Check for Power vs Time Results
Limit Check for Power vs Time Results

The determined "Power vs Time" values can be checked against limits defined by the standard; the limit lines and the result of the limit check are indicated in the "Power vs Time" diagram (see "PvT Full Burst") and in the "Power vs Slot" table (see "Power vs Slot").

The limits depend on the following parameters:

  • The maximum (Max) trace is checked agains the upper limit.
  • The minimum (Min) trace is checked against the lower limit.
  • The limit masks are generated adaptively from the measured signal according to the following parameters:
    – Frequency band (special masks for PCS1900 and DCS1800 BTS with GMSK)
    – Burst type
    – Modulation
    – Filter
    – The reference burst power is measured and the "0 dB line" of the limit mask is assigned to it.
    – For MS, the "-6 dB line" of the limit mask depends on the PCL. The PCL is derived from the measured burst power.


Impact of the "Statistic Count"

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Impact of the "Statistic Count"
Impact of the "Statistic Count"

Generally, the "Statistic Count" defines how many measurements (or: analysis steps) are performed - equivalent to the "Sweep Count" in applications that perform sweeps.

In particular, the "Statistic Count" defines the number of frames to be included in statistical evaluations. For measurements on the "Slot to Measure", the same slot is evaluated in multiple frames, namely in the number specified by the "Statistic Count", for statistical evaluations.

For Trigger to Sync measurements, where only one result is calculated per data acquisition, the "Statistic Count" determines how many values are considered for averaging.

Statistic count for Trigger to Sync vs other measurements

As mentioned above, the "Statistic Count" for Trigger to Sync measurements refers to the number of data acquisitions, whereas for all other measurements, the value refers to the number of frames. Since usually more than one frame is captured per data acquisition, the number of data acquisitions required to obtain the required number of results (the "Statistic Count") may vary considerably. If both Trigger to Sync and other result types are active at the same time, the latter are finished first and the traces (in particular the current measurement trace) remains unchanged until the Trigger to Sync measurement has also finished. The counter in the channel bar counts the "slower" of the two events, i.e. the number of measurements if a Trigger to Sync result display is active.

In MSRA mode, only a single data acquisition is performed (by the MSRA Master) and the R&S FSW GSM application analyzes this data repeatedly. Thus, the Trigger to Sync measurement will only count one data acquisition and can never reach a larger "Statistic Count" value.

Tip: You can query the current value of the counter for both Trigger to Sync and other measurements in remote control, as well. See "Configuring and Performing Sweeps".

Obviously, the "Statistic Count" has an impact on all results and values that are re-calculated after each measurement. The higher the count, the more values are taken into consideration, and the more likely the result of the calculation will converge to a stable value. On the other hand, the fewer measurements are considered, the higher the variance of the individual results, and the less reliable the calculation result will be.

For instance, if the "Statistic Count" is set to values smaller than 5, the measured reference power for Modulation Spectrum Table (see "Modulation Spectrum Table") and Transient Spectrum Table (see "Transient Spectrum Table") measurements increases. This leads to a higher variance of the measured relative powers at the offset frequencies, and thus to a reduced measurement dynamic.

For the Power vs Time (see "PvT Full Burst") and Power vs Slot (see "Power vs Slot") measurements, a small "Statistic Count" increases the variance of the measured slot powers. The slot power is required to calculate the PVT limit lines.


Multicarrier and Wideband Noise

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise
Multicarrier and Wideband Noise

For multicarrier measurements, the GSM standard defines limits for some parameters concerning noise and intermodulation products. Thus, a new separate measurement is provided by the R&S FSW GSM application: the Multicarrier Wideband Noise Measurement (MCWN). This measurement comprises:

  • I/Q based measurements on the carriers to determine their power levels and reference powers
  • Frequency sweeps with RBWs of 100 kHz (to measure wideband noise) and 300 kHz (to measure intermodulation products)
Contents
  • MCWN Measurement Process
  • Contiguous vs Non-Contiguous Multicarrier Allocation
  • Manual Reference Power Definition for MCWN Measurements
  • Limit Check for MCWN Results
  • Intermodulation Calculation


MCWN Measurement Process

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise > MCWN Measurement Process
MCWN Measurement Process

The MCWN measurement consists of several sub-measurements, and may include averaging processes.

Reference measurement

Optionally, a reference measurement is carried out to obtain suitable reference power values for the actual noise measurement. The reference measurement can determine the reference powers of the active carrier with the maximum power level, or optionally, measure just one selected carrier. Several reference measurements can be performed subsequently to calculate an average, thus ensuring stable reference values. Usually, a small average count (10-12) is sufficient to obtain suitable results for the reference measurement.

If this reference measurement is disabled, user-defined reference values are used for relative results in the final measurement.

Wideband noise and intermodulation sweeps

After the narrowband noise measurement, if either wideband noise or intermodulation, or both, are enabled, frequency sweeps are performed in the defined span. Since the standard requires different RBWs depending on the distance from the outermost carriers, several sweeps are required to obtain results for the complete span. The first sweep measurement is performed using an RBW of 100 kHz. The second sweep measurement is performed using an RBW of 300 kHz.

For more details on how intermodulation is calculated see "Intermodulation Calculation".

Evaluating the results for display

After all the reference and noise measurements have been performed, the measured data is evaluated for the result display. This includes the following procedures:

  • Averaging the results from several measurements
  • Putting the results in relation to the reference power values
  • Merging the traces according to the distance from the carriers and the position of the intermodulation products
  • Performing limit checks (see "Limit Check for MCWN Results")

(The details of evaluation are described for the individual evaluation methods in "Multicarrier Evaluation Methods".)

Continuous measurement mode

If continuous sweep mode is selected, the measurement process described above is repeated continuously, i.e. after the average count number of noise measurements, the results are evaluated and displayed, a new reference sub-measurement is performed, the noise measurements are repeated, and so on.


Contiguous vs Non-Contiguous Multicarrier Allocation

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise > Contiguous vs Non-Contiguous Multicarrier Allocation
Contiguous vs Non-Contiguous Multicarrier Allocation

In a standard GSM measurement scenario, multiple carriers are positioned with a fixed spacing in one block. This setup is referred to as contiguous carrier allocation.

Carrier frequencies are allocated in a grid with a spacing of 200 kHz. The minimum carrier spacing is 600 kHz.

Multi-standard radio (MSR) signals

Modern base stations may process multiple signals for different communication standards, for example two GSM subblocks with an LTE subblock inbetween. In this case, if you consider only the GSM carriers, the carriers are spaced regularly within the GSM subblocks, but there is a gap between the two subblocks. Such a carrier setup is referred to as non-contiguous carrier allocation.

According to the 3GPP standard TS 51.021, a subblock is defined as "one contiguous allocated block of spectrum for use by the same base station. There may be multiple instances of subblocks within an RF bandwidth".

A gap is defined as "A frequency gap between two consecutive sub-blocks within an RF bandwidth, where the RF requirements in the gap are based on co-existence for un-coordinated operation."

Non-contiguous carrier allocation
Non-contiguous carrier allocation

The R&S FSW GSM application now allows you to measure such non-contiguous carrier setups containing up to 16 carriers and a single gap (two subblocks). The position of the individual carriers is defined as absolute frequency values. In addition, the position of the gap between the GSM subblocks is defined explicitely by the number of the carrier after which it begins. The burst type and modulation can be defined individually for each carrier to reflect different GSM configurations.

Limit checks for non-contiguous carrier allocation

In order to perform useful limit checks for such non-contiguous carrier allocation, the limit lines are automatically adapted to the gap, so that other signals do not distort the GSM limit check.


Manual Reference Power Definition for MCWN Measurements

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise > Manual Reference Power Definition for MCWN Measurements
Manual Reference Power Definition for MCWN Measurements

For MCWN measurements, reference powers are required to calculate relative results in the final measurement. These power levels can either be determined by a reference measurement or they can be defined manually by the user. In the latter case, a power level is defined, as well as three reference power levels for an RBW of 30 kHz, 100 kHz, and 300 kHz.

The reference powers depend on the modulation characterists. Some typical values for various modulation types are provided in table "Reference powers relative to power level for various modulation types". The table indicates the reference powers for the three RBWs, relative to a defined power level. Since all reference powers are measured with a smaller bandwidth than the power level, all values are negative.

To define reference powers manually, define a power level and then subtract the values indicated in table "Reference powers relative to power level for various modulation types" for the used modulation to determine the reference power levels.

Reference powers relative to power level for various modulation types
Modulation | RBW = 300 kHz | RBW = 100 kHz | RBW = 30 kHz
NB GMSK | -0.3 dB | -2.2 dB | -7.8 dB
NB 8PSK | -1.7 dB | -3.8 dB | -7.7 dB
NB 16QAM | -2.8 dB | -4.5 dB | -8.6 dB
NB 32QAM | -2.9 dB | -5.0 dB | -9.3 dB
NB AQPSK (SCPIR = 0 dB) | -2.5 dB | -4.0 dB | -8.5 dB
HSR-N QPSK | -1.9 dB | -3.9 dB | -8.2 dB
HSR-N 16QAM | -3.0 dB | -4.7 dB | -8.7 dB
HSR-N 32QAM | -3.5 dB | -5.5 dB | -10.0 dB
HSR-W QPSK | -1.6 dB | -5.0 dB | -10.0 dB
HSR-W 16QAM | -3.1 dB | -5.5 dB | -10.3 dB
HSR-W 32QAM | -3.1 dB | -6.1 dB | -11.3 dB
Example:

For a normal burst 8PSK signal, for example, and a power level of 35 dBm, the reference values according to table "Reference powers relative to power level for various modulation types" would be:

RBW | Reference power
300 kHz | 35 dBm - 1.7 dB = 33.3 dBm
100 kHz | 35 dBm - 3.8 dB = 31.2 dBm
30 kHz | 35 dBm - 7.7 dB = 27.3 dBm


Limit Check for MCWN Results

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise > Limit Check for MCWN Results
Limit Check for MCWN Results
For MCWN measurements, various limit lines are calculated:
  • Wideband noise limits
  • Limits for intermodulation products that have to be measured with an RBW of 100 kHz
  • Limits for intermodulation products that have to be measured with an RBW of 300 kHz

For each of these limit lines, a limit check is performed and the results can be queried. They are also indicated in the Spectrum Graph display (see "Spectrum Graph".

Exceptions

For measurements using an RBW of 100 kHz (wideband noise, certain intermodulation products), the standard allows for the signal to exceed the specified limits in exceptional cases. Thus, you can define whether the limit check for MCWN measurements considers these exceptions or not.

If exceptions are considered, the R&S FSW GSM application divides the measurement range into 200 kHz bands. If the limit line in one of these bands is exceeded, a new, higher limit line (with an exceptional level) is applied to the band. Only if this exceptional limit line is also exceeded, the limit check fails.

Maximum number of exceptions

The number of bands for which exceptional limits may be applied is restricted by the standard (3GPP TS 45.005 (chapter 6.2.1.4.1) for single carrier, 3GPP 51.021 (chapter 6.12.3) for multicarrier BTS devices). Thus, the maximum number of bands that may use exceptional limits is indicated for each measurement, as well as the number of bands for which exceptions actually were used. The limit check compares the number of employed exceptions with the number of maximum allowed exceptions.

Note that the maximum number of exceptional bands is based on the total number of bands included in the following "Exception ranges".

However, if the defined measurement span does not comprise all the bands in these ranges, the maximum is not valid. In this case, the measurement may pass the limit check although too many exceptions occurred for the restricted span.

To ensure the correct span is used, select "FREQ > Frequency Config > TX band" (see "Setting the Span to Specific Values Automatically").

Exception ranges

Exceptions are defined for two frequency ranges:

Exception ranges for multicarrier BTS limit checks
Range A
  • For multicarrier BTS device types:
    Bands with an offset of 0 Hz to 2 MHz from the Tx band edges are counted. Bands containing third order IM products and adjacent bands are ignored. For the exact details see 3GPP TS 51.021, chapter 6.12.3.
  • For other device types
    Bands in a distance of 600 kHz to 6 MHz above and below the outermost carrier are counted. For the exact details see 3GPP TS 45.005, chapter 6.2.1.4.1.

The suffix required to query the number of exceptions in range A using remote commands (<k>) is 5.

Range B
  • For multicarrier BTS device types:
    Bands inside the Tx band +/- 10 MHz are counted. Bands containing third order IM products and adjacent bands are ignored. These are the (only) exceptions allowed by the standard. Note that this range includes range A. The number of exceptions thus includes the results from range A.
    For the exact details see 3GPP TS 51.021, chapter 6.12.3.
  • For other device types
    Bands in a distance over 6 MHz from the outermost carriers are counted. For the exact details see 3GPP TS 45.005, chapter 6.2.1.4.1.

The suffix required to query the number of exceptions in range B using remote commands (<k>) is 6.


Intermodulation Calculation

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Multicarrier and Wideband Noise > Intermodulation Calculation
Intermodulation Calculation

If intermodulation measurement is activated, the following calculations are performed.

If there are N active carriers with frequencies f1, f2, f3, ... fN, find all possible combinations of integer coefficients c1, c2, c3, ... cN for which the following equation is true:

with M = intermodulation order

Use all those combinations of coefficients ck to calculate all possible intermodulation frequencies of the given order M:

Example: Calculating intermodulation

For 3 carriers and IM order 3 these are all the theoretical combinations of ck:

Intermodulation coefficients depending on number of carriers involved
1 carrier | 2 carriers |  |  |  | 3 carriers
0 0 3 0 3 0 3 0 0 0 0 -3 0 -3 0 -3 0 0 | 0 1 2 1 2 0 0 1 -2 1 -2 0 0 -1 2 -1 2 0 0 -1 -2 -1 -2 0 | 0 2 1 2 1 0 0 2 -1 2 -1 0 *) 0 -2 1 -2 1 0 0 -2 -1 -2 -1 0 | 1 0 2 1 0 -2 -1 0 2 -1 0 -2 | 2 0 1 -2 0 1 2 0 -1 -2 0 -1 | 1 1 1 1 1 -1 1 -1 1 -1 1 1 1 -1 -1 -1 -1 1 -1 -1 -1
*) critical intermodulation
Critical intermodulations

For critical intermodulations, the sum of all ck equals 1. For example 2*f1 – 1*f2, indicated in table "Intermodulation coefficients depending on number of carriers involved". They are critical because they are close to active carriers.

Note that for some combinations the following may apply:
  • Results are much too far away from the active carriers to be of relevance
  • Results are negative
  • Results have an identical IM frequency
Therefore the R&S FSW GSM application always checks the list of theoretical IM frequencies for the following aspects:
  • Intermodulation frequencies are ignored if they are outside the set frequency span or the range defined by the standard (typically the Tx band +/- 2 MHz or 10 MHz).
  • For some measurements the GSM standard distinguishes how many carriers were involved in generating the intermodulation. This means checking how many ck≠0.
Overlapping intermodulation limit lines

Intermodulations with different orders (for example 3 and 5) might fall on the exact same frequency or so close that the corresponding limit line ranges overlap. In this case, the R&S FSW GSM application checks which IM’s limit value or relaxation value applies according to the GSM standard.

The following cases may occur:
  • The overlapping limit lines have the same level.

    In this case, the point in the middle of both IM frequencies is determined and each limit line is restricted to the area up to or starting from this point.
  • The limit lines have different values and overlap over the entire span

    The less stringent limit line is applied.
  • The limit lines have different values and overlap over a partial span

    The less stringent limit line is applied in the overlapping area; the distinct limit lines are reduced to the remaining area(s).


Automatic Carrier Detection

GSM application (R&S FSW-K10) > Basics on GSM Measurements > Automatic Carrier Detection
Automatic Carrier Detection

An automatic carrier detection function is now available ("Adjusting the Center Frequency Automatically (Auto Freq)"). For multi-carrier measurements this function detects the available carriers in the input signal within a frequency range of approximately 25 MHz to 2 GHz.

The "Auto Frequency" function is sensitive to overload conditions. Thus, before using this function, make sure the reference level is not lower than the input signal's peak power. On the other hand, avoid reference level settings that are much too high, as they make very low carriers (approx. 50 dB under the reference level) disappear in the noise floor and they will not be detected.

Optionally, use the "Setting the Reference Level Automatically (Auto Level)" function to finetune the attenuators and the pre-amplifier AFTER the correct carrier frequencies have been determined.

For MCWN measurements, make sure all detected carriers are in the measurement span, for example using the "Carriers +/- 1.8 MHz" or "Carriers +/- 6 MHz" settings (see "Setting the Span to Specific Values Automatically").


GSM in MSRA Operating Mode

GSM application (R&S FSW-K10) > Basics on GSM Measurements > GSM in MSRA Operating Mode
GSM in MSRA Operating Mode

The GSM application can also be used to analyze data in MSRA operating mode. In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. For the R&S FSW GSM application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode (see "Capture Time"). In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for GSM measurements. The "Magnitude Capture" display shows the application data of the R&S FSW GSM application in MSRA mode.

MCWN measurements and MSRA mode

Only the default GSM I/Q measurement (Modulation Accuracy...) is available in MSRA mode, not the new MCWN measurement (see "Multicarrier Wideband Noise Measurements").

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard (for GSM: 200 kHz), by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the R&S FSW GSM application the analysis interval is automatically determined according to the basis of evaluation, for example the "Slot to Measure" or the slot scope. The currently used analysis interval (in seconds, related to capture buffer start) is indicated in the window header for each result display.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval
Trigger source for MSRA Master

Any trigger source other than "Free Run" defined for the MSRA Master is ignored when determining the frame start in the R&S FSW GSM application (see "Trigger settings").

In the default state in MSRA operating mode, the Sequencer is active in continuous mode. Thus, the MSRA Master performs a data acquisition and then the active applications evaluate the data in turn, after which the MSRA Master performs a data acquisition and so on. As opposed to some other R&S FSW applications in MSRA mode, statistical evaluation of the traces (averaging, MinHold, MaxHold) is not reset after each evaluation in the R&S FSW GSM application.

You can take advantage of this feature in the R&S FSW GSM application by performing continuous data acquisition in MSRA operating mode over a longer period (e.g. over night), and then checking the average or MinHold/MaxHold trace to detect any irregularities in the captured data.

For details on the MSRA operating mode see "Applications and Operating Modes" .


Configuration

GSM application (R&S FSW-K10) > Configuration
Configuration

The default GSM I/Q measurement captures the I/Q data from the GSM signal and determines various characteristic signal parameters such as the modulation accuracy, transient spectrum, trigger to sync, etc. in just one measurement (see "GSM I/Q (Modulation Accuracy, etc.) Measurement Results").

For multicarrier wideband noise (MCWN) measurements, a different configuration is required (see "Multicarrier Wideband Noise (MCWN) Measurements").

The settings required to configure each of these measurements are described here.

Selecting the measurement type
►

To select a different measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.
Remote command:

CONFigure:​MEASurement

Contents
  • Multiple Measurement Channels and Sequencer Function
  • Display Configuration
  • Modulation Accuracy Measurement Configuration
  • Multicarrier Wideband Noise (MCWN) Measurements


Multiple Measurement Channels and Sequencer Function

GSM application (R&S FSW-K10) > Configuration > Multiple Measurement Channels and Sequencer Function
Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. These settings include the input source, the type of data to be processed (I/Q or RF data), frequency and level settings, measurement functions etc. If you want to perform the same measurement but with different center frequencies, for instance, or process the same input data with different measurement functions, there are two ways to do so:

  • Change the settings in the measurement channel for each measurement scenario.
    In this case the results of each measurement are updated each time you change the settings and you cannot compare them or analyze them together without storing them on an external medium.
  • Activate a new measurement channel for the same application.
    In the latter case, the two measurement scenarios with their different settings are displayed simultaneously in separate tabs, and you can switch between the tabs to compare the results.
    For example, you can activate one GSM measurement channel to perform a GSM modulation accuracy measurement for an unknown signal, and a second channel to perform a multicarrier measurement using the same GSM input source. Then you can monitor all results at the same time in the "MultiView" tab.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed on the R&S FSW at any time. If one measurement is running and you start another, or switch to another channel, the first measurement is stopped. In order to perform the different measurements you configured in multiple channels, you must switch from one tab to another.

However, you can enable a Sequencer function that automatically calls up each activated measurement channel in turn. This means the measurements configured in the channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the corresponding tab (as well as the "MultiView") as the measurements are performed. Sequencer operation is independent of the currently displayed tab; for example, you can analyze the SEM measurement while the modulation accuracy measurement is being performed by the Sequencer.

For details on the Sequencer function see "Running a Sequence of Measurements" .

The Sequencer functions are only available in the "MultiView" tab.

└ Sequencer State
└ Sequencer Mode


Sequencer State

GSM application (R&S FSW-K10) > Configuration > Multiple Measurement Channels and Sequencer Function > Sequencer State
Sequencer State

Activates or deactivates the Sequencer. If activated, sequential operation according to the selected Sequencer mode is started immediately.

For details on sequential operation see "The Sequencer Concept" .

Remote command:

SYSTem:​SEQuencer

INITiate:​SEQuencer:​IMMediate

INITiate:​SEQuencer:​ABORt


Sequencer Mode

GSM application (R&S FSW-K10) > Configuration > Multiple Measurement Channels and Sequencer Function > Sequencer Mode
Sequencer Mode

Defines how often which measurements are performed. The currently selected mode softkey is highlighted blue. During an active Sequencer process, the selected mode softkey is highlighted orange.

For details on sequential operation see "Sequencer modes" .

"Single Sequence" | Each measurement is performed once, until all measurements in all active channels have been performed.
"Continuous Sequence" | The measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped. This is the default Sequencer mode.
Remote command:

INITiate:​SEQuencer:​MODE


Display Configuration

GSM application (R&S FSW-K10) > Configuration > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the selected measurement are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any GSM menu.

Up to 16 evaluation methods can be displayed simultaneously in separate windows. The GSM evaluation methods are described in "GSM I/Q (Modulation Accuracy, etc.) Measurement Results" and "Multicarrier Evaluation Methods".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Modulation Accuracy Measurement Configuration

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration
Modulation Accuracy Measurement Configuration

GSM measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you switch a measurement channel to the GSM application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for GSM Modulation Accuracy Measurements"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a measurement channel in the GSM application, a GSM modulation accuracy measurement for the input signal is started automatically with the default configuration. The "GSM" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Slot to Measure"
  • "Slot Scope"
  • "Measurement Settings"
  • "Data Acquisition"
  • "Result Configuration"
  • "Display Configuration"
  • "Configuration Overview"

The MARKER FUNCT and LINES menus are currently not used.

Importing and Exporting I/Q Data

The I/Q data to be evaluated in the GSM application (Modulation Accuracy measurement only) can not only be captured by the GSM application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the GSM application can be exported for further analysis in external applications.

The import and export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on importing and exporting I/Q data see "Import/Export Functions" .

Contents
  • Default Settings for GSM Modulation Accuracy Measurements
  • Configuration Overview
  • Signal Description
  • Input and Frontend Settings
  • Trigger Settings
  • Data Acquisition
  • Demodulation
  • Measurement Settings
  • Adjusting Settings Automatically
  • Marker Function and Lines Menus


Default Settings for GSM Modulation Accuracy Measurements

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Default Settings for GSM Modulation Accuracy Measurements
Default Settings for GSM Modulation Accuracy Measurements

When you switch a measurement channel to the GSM application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • preamplification
  • signal source
  • input coupling

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to the GSM application, or after a "Preset Channel":

Default settings for GSM channels
Parameter | Value
Measurement type | Modulation accuracy
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Device type | BTS Normal
Power class | 1
Frequency band | E-GSM 900
Modulation | NB GMSK
YIG-Preselector | Off
Capture time | 100.0 ms
Swap I/Q | Off
Statistic count | 200
Slot to Measure | 0
No. slots to measure | 1
First slot to measure | 0
Synchronization | Burst + TSC
TSC | TSC 0 (Set 1)
Measure only on sync | Off
Evaluations | Window 1: Magnitude Capture Window 2: PvT Full Burst Window 3: Modulation Accuracy Window 4: Power vs Slot
Default traces depending on result display
Result display | Trace 1 | Trace 2 | Trace 3 | Trace 4
Magnitude Capture | Clear Write | - | - | -
Power vs Time EVM vs Time Phase Error vs Time Magnitude Error vs Time | Average | Max Hold | Min Hold | Clear Write
Constellation: Graph | Clear Write | - | - | -
Modulation Spectrum Graph | Average | Clear Write | - | -
Transient Spectrum Graph | Max Hold | Clear Write | - | -
Trigger to Sync: Graph | Histogram | PDF of Average | - | -


Configuration Overview

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

Note that the configuration "Overview" depends on the selected measurement type. Configuration for multicarrier measurements is described in "Multicarrier Wideband Noise (MCWN) Measurements".

Configuration "Overview" for Modulation Accuracy measurement

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Signal Description"

  2. Input and Frontend Settings

    See "Input and Frontend Settings"

  3. Triggering

    See "Trigger Settings"

  4. Data Acquisition

    See "Data Acquisition"

  5. Demodulation Settings

    See "Demodulation"

  6. Measurement Settings

    See "Measurement Settings"

  7. Result Configuration

    See "Result Configuration"

  8. Display Configuration

    See "Display Configuration"

To configure settings
►

Select any button to open the corresponding dialog box. The corresponding dialog box is opened with the focus on the selected setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for GSM Modulation Accuracy Measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Configuration Overview > Select Measurement
Select Measurement

Selects a measurement to be performed.

See "Selecting the measurement type".


Specifics for

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes frame detection and measurement.

The "Signal Description" settings are available from the configuration "Overview".

Contents
  • Device Under Test Settings
  • Frame
  • Slot Settings
  • Carrier Settings


Device Under Test Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Device Under Test Settings
Device Under Test Settings

The type of device to be tested provides additional information on the signal to be expected.

The device settings are available when you do one of the following:
  • In the "Overview", select the "Signal Description" button, then switch to the "Device" tab.
└ Device Type
└ Frequency Band
└ Power Class
└ Maximum Output Power per Carrier (multicarrier measurements only)


Device Type

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Device Under Test Settings > Device Type
Device Type

Defines the type of device under test (DUT). The following types are available:

  • BTS Normal
  • BTS Micro
  • BTS Pico
  • MS Normal
  • MS Small
  • Multicarrier BTS Wide Area
  • Multicarrier BTS Medium Range
  • Multicarrier BTS Local Area

The default device type is "BTS Normal".

Remote command:

CONFigure[:​MS]:​DEVice:​TYPE


Frequency Band

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Device Under Test Settings > Frequency Band
Frequency Band

The frequency band defines the frequency range used to transmit the signal.

For details see "Frequency bands and channels".

The following frequency bands are supported:

  • T-GSM 380
  • T-GSM 410
  • GSM 450
  • GSM 480
  • GSM 710
  • GSM 750
  • T-GSM 810
  • GSM 850
  • P-GSM 900
  • E-GSM 900
  • R-GSM 900
  • T-GSM 900
  • DCS 1800
  • PCS 1900

The default frequency band is "E-GSM 900".

Remote command:

CONFigure[:​MS]:​NETWork[:​TYPE]

CONFigure[:​MS]:​NETWork:​FREQuency:​BAND


Power Class

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Device Under Test Settings > Power Class
Power Class

The following power classes are supported:

(For MCWN measurements no power class is used: "NONE".)

  • 1, …, 8 (BTS)
  • 1, …,5 (MS: GMSK)
  • E1, E2, E3 (MS: all except GMSK)
  • M1, M2, M3 (Micro BTS)
  • P1 (Pico BTS)

The default power class is 2.

Remote command:

CONFigure[:​MS]:​POWer:​CLASs


Maximum Output Power per Carrier (multicarrier measurements only)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Device Under Test Settings > Maximum Output Power per Carrier (multicarrier measurements only)
Maximum Output Power per Carrier (multicarrier measurements only)

Defines the maximum output power per carrier, which determines the limit lines for the modulation spectrum (I/Q measurements) and MCWN measurement.

In "Auto" mode, the maximum measured power level for the carriers is used.

This setting is only available for multicarrier measurements.

Remote command:

CONFigure[:​MS]:​POWer:​PCARrier:​AUTO?

CONFigure[:​MS]:​POWer:​PCARrier?


Frame

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Frame
Frame

Frame settings determine the frame configuration used by the device under test.

The "Frame" settings are available when you do one of the following:
  • In the "Overview", select the "Signal Description" or "Demodulation" button, then switch to the "Frames" tab.
└ Device Type
└ Frequency Band
└ Power Class
└ Equal Timeslot Length
└ Frame Configuration: Select Slot to Configure


Equal Timeslot Length

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Frame > Equal Timeslot Length
Equal Timeslot Length

This parameter is only taken into account if "Limit Time Alignment" is set to "Slot to measure" (see "Limit Line Time Alignment").

If activated, all slots of a frame are considered to have the same length (8 x 156.26 normal symbol periods).

In this case, the limit line for each slot (required for the "Power vs Time" spectrum masks) is aligned by measuring the TSC of the "Slot to Measure" only, and using this value to align the limit line for all slots in the frame (see also "PvT Full Burst").

If deactivated, slots number 0 and 4 of a frame have a longer duration, all others have a shorter duration compared to the "Equal Timeslot Length" (157, 156, 156, 156, 157, 156, 156, 156 normal symbol periods).

See GPP TS 51.021 and 3GPP TS 45.010 chapter "6.7 Timeslot length" for further details.

Remote command:

CONFigure[:​MS]:​CHANnel:​FRAMe:​EQUal


Frame Configuration: Select Slot to Configure

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Frame > Frame Configuration: Select Slot to Configure
Frame Configuration: Select Slot to Configure

This area shows a graphical representation of the configuration of each slot. Select a slot to display its "Slot" dialog box (see "Slot Settings").

For active slots the following information is shown:

  • The burst type, e.g. "Normal (NB)" for a normal burst.
  • The modulation, e.g. GMSK.
  • The training sequence TSC (and Set)

For details on how to interpret the graphic, see "Frame configuration and slot scope in the channel bar".


Slot Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings
Slot Settings
The "Slot" settings are available when you do one of the following:
  • In the "Overview", select the "Signal Description" or "Demodulation" button, then switch to the "Slot" tab.
  • Press the MEAS CONFIG key, then the "Slot to Measure" softkey.

The individual slots are configured on separate tabs. The dialog box for the selected slot is displayed directly when you select a slot in the "Frame Configuration" graphic on the "Frame" tab (see "Frame Configuration: Select Slot to Configure").

To configure a different slot, select the corresponding vertical tab in the "Slot" tab.

Slot structure display

The basic slot structure according to the selected "Frequency Band" and "Power Class" is displayed graphically for reference.

White fields indicate unknown data; colored fields indicate known symbol sequences.

The slot settings vary slightly for different burst types.

The "Slot" settings are dependant on each other, and only specific combinations of these parameters are available in this dialog box (see "Dependency of Slot Parameters").

└ Slot State (On/Off)
└ Burst Type
└ Modulation
└ SCPIR
└ Filter
└ Timing Advance (Access Burst only)
└ Training Sequence TSC / Sync
└ User TSC / User Sync


Slot State (On/Off)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Slot State (On/Off)
Slot State (On/Off)

Activates or deactivates the selected slot. The R&S FSW GSM application expects an input signal within the active slots only.

At least the "Slot to Measure" must be active in order to evaluate it.

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<Number>[:​STATe]


Burst Type

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Burst Type
Burst Type

Assigns a burst type to the selected slot.

The following burst types are supported:
  • Normal (NB)
  • Higher Symbol Rate (HB)
  • Access (AB)

The graphical slot structure is adapted according to the selected burst type.

Note: The "Slot" settings are dependant on each other, and only specific combinations of these parameters are available in this dialog box (see "Dependency of Slot Parameters").

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<Number>:​TYPE


Modulation

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Modulation
Modulation

Defines the modulation used in the slot.

The possible modulations depend on the set burst type (see "Dependency of Slot Parameters").

The graphical slot structure is adapted according to the selected modulation.

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<Number>:​MTYPe


SCPIR

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > SCPIR
SCPIR

This parameter is only available for AQPSK modulation.

It specifies the Subchannel Power Imbalance Ratio (SCPIR). The value of SCPIR affects the shape of the AQPSK constellation (see "AQPSK Modulation"). For an SCPIR of 0 dB the constellation is square (as in "normal" QPSK), while for other values of SCPIR the constellation becomes rectangular.

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<s>:​SCPir


Filter

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Filter
Filter

Specifies the pulse shape of the modulator on the DUT and thus the measurement filter in the R&S FSW GSM application.

(For details see "Measurement Filter").

The following filter types are supported for normal and higher symbol rate bursts:
  • GMSK Pulse
  • Linearised GMSK Pulse
  • Narrow Pulse
  • Wide Pulse

For access bursts, only a GMSK Pulse filter is supported.

Note: The "Slot" settings are dependant on each other, and only specific combinations of these parameters are available in this dialog box (see "Dependency of Slot Parameters").

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<Number>:​FILTer


Timing Advance (Access Burst only)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Timing Advance (Access Burst only)
Timing Advance (Access Burst only)

Specifies the position of an access burst within a single slot as an offset in symbols from the slot start.

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<Number>:​TADVance


Training Sequence TSC / Sync

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > Training Sequence TSC / Sync
Training Sequence TSC / Sync

(Note: for Access bursts, this setting is labelled "Sync", but the functionality is the same.)

The Training Sequence TSC or Sync values are known symbol sequences used to synchronize the measured signal with the expected input signal in a single slot.

The available values depend on the modulation as indicated in the table below.

For user-defined TSCs, select "User" and define the training sequence in the "User TSC / User Sync" table.

Note: The "Slot" settings are dependant on each other, and only specific combinations of these parameters are available in this dialog box (see "Dependency of Slot Parameters").

For more information on TSCs see "Training sequences (TSCs)".

Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC

AQPSK:

CONFigure[:​MS]:​CHANnel:​SLOT<s>:​SUBChannel<ch>:​TSC


User TSC / User Sync

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Slot Settings > User TSC / User Sync
User TSC / User Sync

(Note: for Access bursts, this setting is labelled "User Sync", but the functionality is the same.)

Defines the bits of the user-defined TSC or Sync. The number of bits depend on the burst type and the modulation and is indicated in table "Number of TSC bits depending on burst type and modulation".

For AQPSK modulation, the training sequence is defined for each subchannel, see "AQPSK Modulation".

Note: As the "User TSC" table in the dialog box only displays 25 bits at a time, a scrollbar beneath the table allows you to display the remaining bits. The currently selected bit number is indicated in the center of the scrollbar.

Number of TSC bits depending on burst type and modulation
Burst Type | Modulation | Number of Bits
Normal | GMSK | 26
Normal | 8PSK | 78
Normal | 16QAM | 104
Normal | 32QAM | 130
Higher Symbol Rate | QPSK | 62
Higher Symbol Rate | 16QAM | 124
Higher Symbol Rate | 32QAM | 155
Access | GMSK | 41
Remote command:

CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC:​USER

AQPSK:

CONFigure[:​MS]:​CHANnel:​SLOT<s>:​SUBChannel<ch>:​TSC:​USER


Carrier Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings
Carrier Settings

The "Carrier" settings define whether the expected signal contains a single or multiple carriers. Up to 16 carriers can be configured for a single MCWN measurement.

Carrier settings are available from the "Signal Description" dialog box which is displayed when you select the corresponding button in the configuration "Overview".

└ Carrier Allocation
└ Gap start after carrier (Non-contiguous carriers only)
└ Active carriers
└ Frequency
└ Modulation


Carrier Allocation

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings > Carrier Allocation
Carrier Allocation

Defines whether a multicarrier measurement setup contains one subblock of regularly spaced carriers only (contiguous), or two subblocks of carriers with a gap inbetween (non-contiguous).

For non-contiguous setups the position of the gap must be defined as the number of the active carrier after which the gap starts (see Gap start after carrier).

For details see "Contiguous vs Non-Contiguous Multicarrier Allocation".

Remote command:

CONFigure[:​MS]:​MCARrier:​FALLocation


Gap start after carrier (Non-contiguous carriers only)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings > Gap start after carrier (Non-contiguous carriers only)
Gap start after carrier (Non-contiguous carriers only)

For non-contiguous setups (see "Carrier Allocation") the position of the gap must be defined as the number of the active carrier after which the gap starts.

For details see "Contiguous vs Non-Contiguous Multicarrier Allocation".

Remote command:

CONFigure[:​MS]:​MCARrier:​FALLocation:​NCONtiguous:​GSACarrier


Active carriers

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings > Active carriers
Active carriers

Defines which of the defined carriers are active for the current measurement.

Remote command:

CONFigure[:​MS]:​MCARrier:​CARRier<c>[:​STATe]?


Frequency

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings > Frequency
Frequency

Defines the absolute frequency of each (active) carrier.

Remote command:

CONFigure[:​MS]:​MCARrier:​CARRier<c>:​FREQuency


Modulation

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Signal Description > Carrier Settings > Modulation
Modulation

Defines the burst type, modulation and pulse shape filter of each (active) carrier.

For possible combinations see "Dependency of Slot Parameters".

Note: This setting determines the appropriate limits from the 3GPP standard.

Remote command:

CONFigure[:​MS]:​MCARrier:​CARRier<c>:​MTYPe


Input and Frontend Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings
Input and Frontend Settings

The R&S FSW can evaluate signals from different input sources and provide various types of output (such as noise or trigger signals).

The frequency and amplitude settings represent the "frontend" of the measurement setup.

Contents
  • Input Source Settings
  • Frequency Settings
  • Amplitude Settings
  • Output Settings


Input Source Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

For MCWN measurements, only RF input is available.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Input Coupling

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Digital I/Q Input Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Frequency Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input/Frontend Settings" dialog box.

The "Frequency" settings for MCWN measurements are described in "Frequency Settings".

└ Frequency Band
└ Center Frequency
└ ARFCN
└ Center Frequency Stepsize
└ Frequency Offset


Center Frequency

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Frequency Settings > Center Frequency
Center Frequency

Specifies the center frequency of the signal to be measured (typically the center of the Tx band).

If the frequency is modified, the "ARFCN" is updated accordingly (for I/Q measurements, see "ARFCN").

Remote command:

[SENSe:​]FREQuency:​CENTer


ARFCN

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Frequency Settings > ARFCN
ARFCN

Defines the Absolute Radio Frequency Channel Number (ARFCN). The "Center Frequency" is adapted accordingly.

Possible values are in the range from 0 to 1023; however, some values may not be allowed depending on the selected "Frequency Band".

Remote command:

CONFigure[:​MS]:​ARFCn


Center Frequency Stepsize

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"X * Span" | Sets the step size for the center frequency to a defined factor of the span. The "X-Factor" defines the percentage of the span. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %. This setting is only available for MCWN measurements.
"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings affect the y-axis values.

└ Power Class
└ Reference Level
└ Shifting the Display (Offset)
└ Mechanical Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Mechanical Attenuation

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Mechanical Attenuation
Mechanical Attenuation

Defines the mechanical attenuation for RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Mechanical Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Output Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ IF/VIDEO/DEMOD Output
└ IF Out Frequency
└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


IF/VIDEO/DEMOD Output

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > IF/VIDEO/DEMOD Output
IF/VIDEO/DEMOD Output

This function is not available for the R&S FSW GSM application.


IF Out Frequency

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > IF Out Frequency
IF Out Frequency

This function is not available for the R&S FSW GSM application.


Noise Source

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Trigger Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

Trigger settings can be configured in the "Trigger" dialog box, which is displayed when you do one of the following:
  • Press the TRIG key and then select the "Trigger Config" softkey.
  • In the "Overview", select the "Trigger" button.

The GSM measurements can be performed in "Free Run" (untriggered) mode; however, an external trigger or a power trigger can speed up measurements.

For more information see "Trigger settings".

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

Note that gating is not available for GSM measurements.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

└ Trigger Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff


Trigger Source

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Note: The GSM measurements can be performed in "Free Run" (untriggered) mode; however, an external trigger or a power trigger can speed up measurements.
For more information see "Trigger settings".

Note: Trigger source for MSRA Master. Any trigger source other than "Free Run" defined for the MSRA Master is ignored when determining the frame start in the R&S FSW GSM application (see "Trigger settings"). For this purpose, the trigger is considered to be in "Free Run" mode.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power


Free Run

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


I/Q Power

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


IF Power

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


RF Power

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Drop-Out Time

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

Note: When using an external trigger, the trigger offset is particularly important in order to detect the frame start correctly! (See "Trigger settings".) The R&S FSW GSM application expects the trigger event to be the start of the "active part" in slot 0.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Slope

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Hysteresis

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Trigger Settings > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Data Acquisition

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition
Data Acquisition

You must define how much and how often data is captured from the input signal.

The settings in this dialog box are available when you do one of the following:
  • Select the "Data Acquisition" button from the "Overview".
  • Press the BW, SPAN SWEEP, or MEAS CONFIG key, then the "Data Acquisition" softkey.
Contents
  • Data Acquisition
  • Sweep


Data Acquisition

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition
Data Acquisition

The "Data Acquisition" settings define how long data is captured from the input signal by the R&S FSW GSM application.

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Data Acquisition" button.
  • Press the BW, SPAN or SWEEP key, then the "Data Acquisition" softkey.
  • Press the MEAS CONFIG key, then the "Data Acquisition" softkey.
└ Sample rate
└ Analysis Bandwidth
└ Capture Time
└ Capture Offset
└ Swap I/Q


Sample rate

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition > Sample rate
Sample rate

The sample rate for I/Q data acquisition is indicated for reference only. It is a fixed value, depending on the frequency range to be measured (see also "Spectrum").

Remote command:

TRACe:​IQ:​SRATe?


Analysis Bandwidth

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition > Analysis Bandwidth
Analysis Bandwidth

The analysis bandwidth is indicated for reference only. It defines the flat, usable bandwidth of the final I/Q data. This value is dependent on the Frequency list and the defined signal source.

The following rule applies:

analysis bandwidth = 0.8 * sample rate

For details on the dependencies see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input" .

Note: MSRA operating mode. In MSRA operating mode, the MSRA Master is restricted to an input sample rate of 200 MHz.

Remote command:

TRACe:​IQ:​BWIDth?


Capture Time

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition > Capture Time
Capture Time

Specifies the duration (and therefore the amount of data) to be captured in the capture buffer.

The capture time can be defined automatically or manually.

If Auto mode is enabled (default), the optimal capture time is determined according to the "Sample rate" and "Analysis Bandwidth".

In Manual mode be sure to define a sufficiently long capture time. If the capture time is too short, demodulation will fail.

Note: The duration of one GSM slot equals 15/26 ms = 0.576923 ms. The duration of one GSM frame (8 slots) equals 60/13 ms = 4.615384 ms.

Note: MSRA operating mode. In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The "Capture Time" for the R&S FSW GSM application in MSRA mode defines the length of the application data extract (see also "GSM in MSRA Operating Mode").
For details on the MSRA operating mode see "Applications and Operating Modes" .

The "Capture Time" can also be defined using the softkey which is available from the SPAN, BW or SWEEP menus.

Remote command:

[SENSe:​]SWEep:​TIME

[SENSe:​]SWEep:​TIME:​AUTO


Capture Offset

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition > Capture Offset
Capture Offset

This setting is only available for applications in MSRA operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet


Swap I/Q

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Data Acquisition > Swap I/Q
Swap I/Q

Activates or deactivates the inverted I/Q modulation. If the I and Q parts of the signal from the DUT are interchanged, the R&S FSW can do the same to compensate for it.

Tip: Try this function if the TSC can not be found.

On | I and Q signals are interchanged Inverted sideband, Q+j*I
Off | I and Q signals are not interchanged Normal sideband, I+j*Q
Remote command:

[SENSe:​]SWAPiq


Sweep

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep
Sweep

The "Sweep" settings define how often data is captured from the input signal by the R&S FSW GSM application.

The settings in this dialog box are available when you do one of the following:
  • Select the "Data Acquisition" button from the "Overview" and switch to the "Sweep" tab.
  • Press the SWEEP key.
  • Press the MEAS CONFIG key, select the "Data Acquisition" softkey and switch to the "Sweep" tab.
└ Statistic Count
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh


Statistic Count

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep > Statistic Count
Statistic Count

Defines the number of frames to be included in statistical evaluations. For measurements on the "Slot to Measure", the same slot is evaluated in multiple frames, namely in the number specified by the "Statistic Count", for statistical evaluations.

The default value is 200 in accordance with the GSM standard.

For details on the impact of this value, see "Impact of the "Statistic Count"".

Remote command:

[SENSe:​]SWEep:​COUNt


Continuous Sweep/RUN CONT

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep > Continue Single Sweep
Continue Single Sweep

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Data Acquisition > Sweep > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Demodulation

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation
Demodulation

Demodulation settings determine how frames and slots are detected in the input signal and which slots are to be evaluated.

The "Demodulation" settings are available from the configuration "Overview".

The "Frame" and "Slot" settings are identical to those in the "Signal Description" dialog box, see "Frame" and "Slot Settings".

Contents
  • Slot Scope
  • Demodulation Settings


Slot Scope

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Slot Scope
Slot Scope

The slot scope defines which slots are to be evaluated (see also "Defining the Scope of the Measurement").

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Demodulation" button, then switch to the "Slot Scope" tab.
  • Press the MEAS CONFIG key, then the "Slot Scope" softkey.
└ Slot to Measure
└ Number of Slots to measure
└ First Slot to measure
└ Frame Configuration: Select Slot to Configure


Slot to Measure

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Slot Scope > Slot to Measure
Slot to Measure

This parameter specifies the slot to be measured in single-slot measurements relative to the GSM frame boundary. The following rule applies:

0 ≤ Slot to Measure ≤ 7

The "Slot to Measure" is used as the (only) slot to measure in the following measurements: (see "First Slot to measure")

  • "Modulation Accuracy"
  • "EVM"
  • "Phase Error"
  • "Magnitude Error"
  • Modulation Spectrum
  • "Constellation"

Furthermore, the "Slot to Measure" is used to measure the reference power for the following measurements:

  • Power vs Time
  • Modulation Spectrum
  • Transient Spectrum

Finally, the "Slot to Measure" is used to measure the position of its TSC, which represents the timing reference for the Power vs Time mask (limit lines) of all slots.

See also "Defining the Scope of the Measurement". For details on the measurement types see "GSM I/Q (Modulation Accuracy, etc.) Measurement Results".

Remote command:

CONFigure[:​MS]:​CHANnel:​MSLots:​MEASure


Number of Slots to measure

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Slot Scope > Number of Slots to measure
Number of Slots to measure

This parameter specifies the "Number of Slots to measure" for the measurement interval of multi-slot measurements, i.e. the Power vs Time and Transient Spectrum measurements. Between 1 and 8 consecutive slots can be measured.

See also "Defining the Scope of the Measurement".

Remote command:

CONFigure[:​MS]:​CHANnel:​MSLots:​NOFSlots


First Slot to measure

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Slot Scope > First Slot to measure
First Slot to measure

This parameter specifies the start of the measurement interval for mulit-slot measurements, i.e. Power vs Time and Transient Spectrum measurements, relative to the GSM frame boundary. The following conditions apply:

  • First Slot to measure ≤ "Slot to Measure"
  • "Slot to Measure" ≤ First Slot to measure + "Number of Slots to measure" -1

See also "Defining the Scope of the Measurement".

Remote command:

CONFigure[:​MS]:​CHANnel:​MSLots:​OFFSet


Frame Configuration: Select Slot to Configure

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Slot Scope > Frame Configuration: Select Slot to Configure
Frame Configuration: Select Slot to Configure

This area shows a graphical representation of the configuration of each slot. Select a slot to display its "Slot" dialog box (see "Slot Settings").

For active slots the following information is shown:

  • The burst type, e.g. "Normal (NB)" for a normal burst.
  • The modulation, e.g. GMSK.
  • The training sequence TSC (and Set)

For details on how to interpret the graphic, see "Frame configuration and slot scope in the channel bar".


Demodulation Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings
Demodulation Settings

The demodulation settings provide additional information to optimize frame, slot and symbol detection.

The settings in this dialog box are available when you do the following:
  • In the "Overview", select the "Demodulation" button, then switch to the "Demodulation" tab.
└ Synchronization
└ Measure only on Sync
└ I/Q Correlation Threshold
└ Symbol Decision
└ Tail & TSC Bits


Synchronization

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings > Synchronization
Synchronization

Sets the synchronization mode of the R&S FSW GSM application.

"Burst+TSC"

First search for the power profile (burst search) according to the frame configuration in the capture buffer. Second, inside the found bursts search for the TSC of the "Slot to Measure" as given in the frame configuration. "Burst +TSC" is usually faster than "TSC" for bursted signals.

"TSC"

Search the capture buffer for the TSC of the "Slot to Measure" as given in the frame configuration. This mode corresponds to a correlation with the given TSC. This mode can be used for continuous (but framed) signals or bursted signals.

"Burst"

Search for the power profile (burst search) according to the frame configuration in the capture buffer.

Note: For "Burst" no demodulation measurements (e.g. "Modulation Accuracy") are supported. Only "Power vs Time", "Modulation Spectrum", "Transient Spectrum" measurements are supported.

"None"

Do not synchronize at all. If an external or power trigger is chosen, the trigger instant corresponds to the frame start.

Tip: Manually adjust the trigger offset to move the burst to be analyzed under the mask in the "Power vs Time" measurement.

Note: For "None" no demodulation measurements (e.g. "Modulation Accuracy") are supported. Only "Power vs Time", "Modulation Spectrum", "Transient Spectrum" measurements are supported.

Remote command:

CONFigure[:​MS]:​SYNC:​MODE


Measure only on Sync

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings > Measure only on Sync
Measure only on Sync

If activated (default), only results from frames (slots) where the "Slot to Measure" was found are displayed and taken into account in the averaging of the results. The behavior of this option depends on the value of the "Synchronization" parameter.

Remote command:

CONFigure[:​MS]:​SYNC:​ONLY


I/Q Correlation Threshold

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings > I/Q Correlation Threshold
I/Q Correlation Threshold

This threshold determines whether a burst is accepted if "Measure only on Sync" is activated. If the correlation value between the ideal I/Q signal of the given TSC and the measured TSC is below the I/Q correlation threshold, then the application reports "Sync not found" in the status bar. Additionally, such bursts are ignored if "Measure only on Sync" is activated.

Note: If the R&S FSW GSM application is configured to measure GMSK normal bursts, a threshold below 97% will also accept 8PSK normal bursts (with the same TSC) for analysis. In this case, activate "Measure only on Sync" and set the "I/Q Correlation Threshold" to 97%. This will exclude the 8PSK normal bursts from the analysis.

Remote command:

CONFigure[:​MS]:​SYNC:​IQCThreshold


Symbol Decision

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings > Symbol Decision
Symbol Decision

The symbol decision determines how the symbols are detected in the demodulator. Setting this parameter does not affect the demodulation of normal bursts with GMSK modulator. For normal bursts with 8PSK, 16QAM, 32QAM or AQPSK modulation, or higher symbol rate bursts with QPSK, 16QAM or 32QAM modulation, use this parameter to get a trade-off between performance (symbol error rate of the R&S FSW GSM application) and measurement speed.

"Auto" | Automatically selects the symbol decision method.
"Linear" | Linear symbol decision: Uses inverse filtering (a kind of zero-forcing filter) and a symbol-wise decision method. This method is recommended for high symbol to noise ratios, but not for higher symbol rate bursts with a narrow pulse. The inverse filter colors the noise inside the signal bandwidth and therefore is not recommended for narrow-band signals or signals with a low signal to noise ratio. Peaks in the "EVM vs Time" measurement (see "EVM") may occur if the "Linear" symbol decision algorithm fails. In that case use the "Sequence" method. Linear is the fastest option.
"Sequence" | Symbol decision via sequence estimation. This method uses an algorithm that minimizes the symbol errors of the entire burst. It requires that the tail bits in the analyzed signal are correct. It has a better performance (lower symbol error rate) compared to the "Linear" method, especially at low signal to noise ratios, but with a loss of measurement speed. This method is recommended for normal bursts with 16QAM or 32QAM modulation and for Higher Symbol Rate bursts with a narrow pulse. Tip: Use this setting if it reduces the EVM RMS measurement result.
Remote command:

CONFigure[:​MS]:​DEMod:​DECision


Tail & TSC Bits

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Demodulation > Demodulation Settings > Tail & TSC Bits
Tail & TSC Bits

The demodulator in the R&S FSW GSM application requires the bits of the burst (tail, data, TSC, data, tail) to provide an ideal version of the measured signal. The "data" bits can be random and are typically not known inside the demodulator of the R&S FSW GSM application. "tail" and "TSC" bits are specified in the "Slot" dialog box (see "Training Sequence TSC / Sync").

"Detected"

The detected Tail and TSC bits are used to construct the ideal signal.

"Standard"

The standard tail and TSC bits (as set in the "Slot" dialog box) are used to construct the ideal signal.

Using the standard bits can be advantageous to verify whether the device under test sends the correct tail and TSC bits. Incorrect bits would lead to peaks in the "EVM vs Time" trace (see "EVM") at the positions of the incorrect bits.

Remote command:

CONFigure[:​MS]:​DEMod:​STDBits


Measurement Settings

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings
Measurement Settings

Measurement settings define how power or spectrum measurements are performed.

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Measurement" button.
  • Press the MEAS CONFIG key, then the "Meas Settings" softkey.
Contents
  • Power vs Time
  • Spectrum
  • Trigger to Sync


Power vs Time

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Power vs Time
Power vs Time

The "Power vs Time" filter is used to suppress out-of-band interference in the Power vs Time measurement (see "Power vs Time Filter"). A limit line is available to determine if the power exceeds the limits defined by the standard in each slot.

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Measurement" button.
  • Press the MEAS CONFIG key, then the "Meas Settings" softkey.
└ Power vs Time Filter
└ Limit Line Time Alignment


Power vs Time Filter

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Power vs Time > Power vs Time Filter
Power vs Time Filter

The PvT filter controls the filter used to reduced the measurement bandwidth in "Power vs Time" measurements.

Note: The PvT filter is optimized to get smooth edges after filtering burst signals and to suppress adjacent, active channels.

Depending on the "Device Type" (single carrier or multicarrier), different PvT filters are supported:

"1 MHz Gauss" | default for single carrier device
"600 kHz" | (single carrier only) for backwards compatibility to FS-K5
"500 kHz Gauss" | (single carrier only) for backwards compatibility to FS-K5
"400 kHz (multicarrier)" | (default for multicarrier device) Recommended for measurements with multi channels of equal power.
"300 kHz (multicarrier)" | Recommended for multicarrier measurement scenarios where a total of six channels is active and the channel to be measured has a reduced power (e.g. 30 dB) compared to its adjacent channels.
Remote command:

CONFigure:​BURSt:​PTEMplate:​FILTer


Limit Line Time Alignment

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Power vs Time > Limit Line Time Alignment
Limit Line Time Alignment

Controls how the limit lines are aligned in a "Power vs Time" measurement graph (see "PvT Full Burst"). Limit lines are defined for each slot. The limit lines are time-aligned in each slot, based on the position of the TSC (the center of the TSC is the reference point). This parameter affects how the center of the TSC is determined for each slot:

  • Slot to measure (default): For each slot the center of the TSC is derived from the measured center of the TSC of the "Slot to Measure" and the timeslot lengths specified in the standard (see "Timeslot length" in 3GPP TS 45.010 and "Equal Timeslot Length").
  • Per Slot: For each slot the center of the TSC is measured. This provides reasonable time-alignment if the slot lengths are not according to standard. Note that in this case the "Power vs Time" limit check may show "pass" even if the timeslot lengths are not correct according to the standard.

Note: The "Limit Time Alignment" also decides whether the "Delta to sync" values of the "Power vs Time" list result are measured (for "Limit Time Alignment" = "Per Slot") or if they are constant as defined by the 3PP standard (for "Limit Time Alignment" = "Slot to measure").

The R&S FSW GSM application offers a strictly standard-conformant, multiple-slot PvT limit line check. This is based on time alignment to a single specified slot (the "Slot to Measure") and allows the user to check for correct BTS timeslot alignment in the DUT, according to the GSM standard. In addition, a less stringent test which performs PvT limit line alignment on a per-slot basis ("Per Slot") is also available.

Note: When measuring access bursts the parameter "Limit Time Alignment" should be set to "Per Slot", since the position of an access burst within a slot depends on the set timing advance of the DUT.

Remote command:

CONFigure:​BURSt:​PTEMplate:​TALign


Spectrum

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Spectrum
Spectrum

The modulation and transient spectrum measurements allow for further configuration.

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Measurement" button, then switch to the "Spectrum" tab.
  • Press the MEAS CONFIG key, select the "Meas Settings" softkey, then switch to the "Spectrum" tab.
  • Press the SPAN key then select the "Spectrum Config" softkey.
└ Enable Left Limit/ Enable Right Limit
└ Filter Type
└ Modulation Spectrum Table: Frequency List
└ Transient Spectrum: Reference Power


Enable Left Limit/ Enable Right Limit

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Spectrum > Enable Left Limit/ Enable Right Limit
Enable Left Limit/ Enable Right Limit

Controls whether the results for the frequencies to the left or to the right of the center frequency, or both, are considered in the limit check of the spectrum trace (spectrum graph measurement). This parameter effects the "Modulation Spectrum Graph" and "Transient Spectrum Graph" measurements.

Note: For measurements on multicarrier signals, using either the check on the left or right side only allows you to measure the spectrum of the left or right-most channel while ignoring the side where adjacent channels are located.

Remote command:

CONFigure:​SPECtrum:​LIMit:​LEFT

CONFigure:​SPECtrum:​LIMit:​RIGHt


Filter Type

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Spectrum > Filter Type
Filter Type

Defines the filter type for the resolution filter for the "Modulation Spectrum" and "Transient Spectrum" measurements.

"Normal" | 3 dB Gauss filter
"5-pole" | according to the GSM standard
Remote command:

[SENSe:​]BANDwidth[:​RESolution]:​TYPE


Modulation Spectrum Table: Frequency List

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Spectrum > Modulation Spectrum Table: Frequency List
Modulation Spectrum Table: Frequency List

This setting is only required by the "Modulation Spectrum Table" evaluation (see "Modulation Spectrum Table"). In this evaluation, the spectrum of the signal at fixed frequency offsets is determined. The list of frequencies to be measured is defined by the standard. Additionally, sparse versions of the specified frequency lists with fewer intermediate frequencies are provided for quicker preliminary tests.

Note: Modulation RBW at 1800 kHz. As opposed to previous R&S signal and spectrum analyzers, in which the modulation RBW at 1800 kHz was configurable, the R&S FSW configures the RBW (and VBW) internally according to the selected frequency list (see "Modulation Spectrum Table: Frequency List"). For the "Modulation Spectrum Graph" both the RBW and VBW are set to 30 kHz. For the "Modulation Spectrum Table", they are set according to table "RBW settings for Modulation Spectrum Table measurements according to standard".
The frequency list also determines the used sample rate, see "Sample rate").

"1.8 MHz" | The frequency list comprises offset frequencies up to 1.8 MHz from the carrier. The sample rate is 6.5 MHz. In previous R&S signal and spectrum analyzers, this setting was referred to as "narrow".
"1.8 MHz (sparse)" | More compact version of "1.8 MHz". The sample rate is 6.5 MHz.
"6 MHz" | The frequency list comprises offset frequencies up to 6 MHz from the carrier. The sample rate is 19.5 MHz. In previous R&S signal and spectrum analyzers, this setting was referred to as "wide".
"6 MHz (sparse)" | More compact version of "6 MHz". The sample rate is 19.5 MHz.
Remote command:

CONFigure:​WSPectrum:​MODulation:​LIST:​SELect


Transient Spectrum: Reference Power

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Spectrum > Transient Spectrum: Reference Power
Transient Spectrum: Reference Power

This setting is only required by the "Transient Spectrum" evaluation (see "Transient Spectrum Graph").

In this evaluation, the power vs spectrum for all slots in the slot scope is evaluated and checked against a spectrum mask. To determine the relative limit values, a reference power is required. In order to detect irregularities, it is useful to define the peak power as a reference. However, the standard requires the reference power to be calculated from the RMS power.

Note: To perform the measurement according to the 3GPP standard set the reference power to RMS and the "Slot to Measure" to the slot with the highest power.
See 3GPP TS 45.005, chapter "4 Transmitter characteristics ":
For GMSK modulation, the term output power refers to the measure of the power when averaged over the useful part of the burst (see annex B).
For QPSK, AQPSK, 8-PSK, 16-QAM and 32-QAM modulation, the term "output power" refers to a measure that, with sufficient accuracy, is equivalent to the long term average of the power when taken over the useful part of the burst as specified in 3GPP TS 45.002 with any fixed TSC and with random encrypted bits.
See 3GPP TS 51.021, chapter "6.5.2 Switching transients spectrum":
The reference power for relative measurements is the power measured in a bandwidth of at least 300 kHz for the TRX under test for the time slot in this test with the highest power.

"RMS" | (Default:) The reference power is the RMS power level measured over the useful part of the "Slot to Measure" and averaged according to the defined "Statistic Count".
"Peak" | The reference power is the peak power level measured over the selected slot scope (see "Slot Scope") and its peak taken over "Statistic Count" measurements (GSM frames).
Remote command:

CONFigure:​SPECtrum:​SWITching:​TYPE


Trigger to Sync

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Trigger to Sync
Trigger to Sync

The Trigger to Sync measurement allows for further configuration.

The settings in this dialog box are available when you do one of the following:
  • In the "Overview", select the "Measurement" button, then switch to the "Trigger to Sync" tab.
  • Press the MEAS CONFIG key, select the "Meas Settings" softkey, then switch to the "Trigger to Sync" tab.
└ No. of Bins
└ Adaptive Data Size


No. of Bins

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Trigger to Sync > No. of Bins
No. of Bins

Specifies the number of bins for the histogram of the "Trigger to Sync" measurement.

For details see "Trigger to Sync Graph".

Remote command:

CONFigure:​TRGS:​NOFBins


Adaptive Data Size

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Measurement Settings > Trigger to Sync > Adaptive Data Size
Adaptive Data Size

Specifies the number of measurements (I/Q captures) after which the x-axis of the "Trigger to Sync" histogram is adapted to the measured values and fixed for subsequent measurements.

Up to the defined number of measurements, the Trigger to Sync value is stored. When enough measurements have been performed, the x-axis is adapted to the value range of the stored results. For subsequent measurements, the result is no longer stored and the x-axis (and thus the dimensions of the bins) is maintained at the set range.

The higher the "Adaptive Data Size", the more precise the x-axis scaling.

For details see "Trigger to Sync Graph".

Remote command:

CONFigure:​TRGS:​ADPSize


Adjusting Settings Automatically

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Automatic Frame Configuration
└ Automatic Trigger Offset


Adjusting the Center Frequency Automatically (Auto Freq)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Adjusting Settings Automatically > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency and "ARFCN" (I/Q mode only) automatically.

For multicarrier measurements, all carrier settings are automatically adjusted (see "Carrier Settings").

This command is not available when using the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Carriers are only detected in a range of approximately 25 MHz to 2 GHz. For further details see "Automatic Carrier Detection".

Remote command:

[SENSe:​]ADJust:​FREQuency


Setting the Reference Level Automatically (Auto Level)

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Adjusting Settings Automatically > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is not available in MSRA mode.

Remote command:

CONFigure[:​MS]:​AUTO:​LEVel ONCE


Automatic Frame Configuration

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Adjusting Settings Automatically > Automatic Frame Configuration
Automatic Frame Configuration

When activated, a single auto frame configuration measurement is performed.

Note: This function is not available in MSRA mode if the Sequencer is active.

The auto frame configuration measurement may take a long time, therefore it is deactivated by default. The following parameters are detected and automatically measured:

  • Active slots
  • Slot configuration (burst type, modulation, filter, TSC)
  • Equal time slot length
  • For VAMOS normal burst and GMSK: TSCs of set 1 and set 2
  • For VAMOS normal burst and AQPSK: TSCs of both subchannels (restrictions see "Restriction for auto frame configuration") and SCPIR
Remote command:

CONF:AUTO:FRAM ONCE, see CONFigure[:​MS]:​AUTO:​FRAMe ONCE


Automatic Trigger Offset

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Adjusting Settings Automatically > Automatic Trigger Offset
Automatic Trigger Offset

If activated, the trigger offset (for external and IF power triggers) are detected and automatically measured.

This function is not available in MSRA mode.

For details on the trigger offset refer to "Trigger Offset".

Remote command:

CONF:AUTO:TRIG ONCE, see CONFigure[:​MS]:​AUTO:​TRIGger ONCE


Marker Function and Lines Menus

GSM application (R&S FSW-K10) > Configuration > Modulation Accuracy Measurement Configuration > Marker Function and Lines Menus
Marker Function and Lines Menus

The MARKER FUNCTION and LINES menus are currently not used.


Multicarrier Wideband Noise (MCWN) Measurements

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements
Multicarrier Wideband Noise (MCWN) Measurements

For multicarrier measurements, some parameters defined by the GSM standard require a swept measurement with varying resolution bandwidths. Thus, a new separate measurement is provided by the R&S FSW GSM application to determine the wideband noise in multicarrier measurement setups (see "Multicarrier Wideband Noise Measurements").

Selecting the measurement type

GSM measurements require a special operating mode on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

►

To select the MCWN measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the "MC and Wide Noise Spectrum" measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the "MC and Wide Noise Spectrum" measurement.

The measurement-specific settings for the "MC and Wide Noise Spectrum" measurement are available via the "Overview".

The BW, MARKER FUNCT and LINES menus are currently not used.

Contents
  • Default Settings for GSM MCWN Measurements
  • Configuration Overview
  • Signal Description
  • Input and Frontend Settings
  • Trigger Settings
  • Sweep Settings
  • Reference Measurement Settings
  • Noise Measurement Settings
  • Adjusting Settings Automatically


Default Settings for GSM MCWN Measurements

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Default Settings for GSM MCWN Measurements
Default Settings for GSM MCWN Measurements

The following default settings are activated when a MCWN measurement is selected:

Default settings for GSM MCWN measurements
Parameter | Value
Measurement type | MC and Wide Noise Spectrum
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Device type | as defined (channel default: BTS Normal)
Frequency band | as defined (channel default: E-GSM 900)
Carriers | 1 active carrier at defined center frequency with NB GMSK modulation
Reference power | Maximum measured active carrier level
Noise measurements | Wideband noise
Intermodulation measurements | Order 3 and 5
Average count | Ref. meas: 10 Noise meas: 200
Limit line exceptions | Applied
Evaluations | Window 1: Spectrum Graph Window 2: Carrier Power Table


Configuration Overview

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

Note that the configuration "Overview" depends on the selected measurement type. Configuration for the default I/Q measurement (Modulation Accuracy etc.) is described in "Configuration Overview".

Configuration "Overview" for MCWN measurement

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Signal Description"

  2. Input and Frontend Settings

    See "Input and Frontend Settings"

  3. Triggering

    See "Trigger Settings"

  4. Data Acquisition

    See "Sweep Settings"

  5. Reference Measurement Settings

    See "Reference Measurement Settings"

  6. Noise Measurement Settings

    See "Noise Measurement Settings"

  7. Result Configuration

    See "Result Configuration"

  8. Display Configuration

    See "Display Configuration"

To configure settings
►

Select any button to open the corresponding dialog box. The corresponding dialog box is opened with the focus on the selected setting.

└ Preset Channel
└ Select Measurement


Select Measurement

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Configuration Overview > Select Measurement
Select Measurement

Selects a measurement to be performed.

See "Selecting the measurement type".


Signal Description

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes frame detection and measurement.

The "Signal Description" settings are available from the configuration "Overview".

Contents
  • Device Under Test Settings
  • Carrier Settings


Input and Frontend Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings
Input and Frontend Settings

The R&S FSW can evaluate signals from different input sources and provide various types of output (such as noise or trigger signals).

The frequency and amplitude settings represent the "frontend" of the measurement setup.

Contents
  • Radio Frequency Input
  • Frequency Settings
  • Amplitude Settings
  • Output Settings


Radio Frequency Input

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. This is the only available input source for MCWN measurements.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz


Impedance

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Radio Frequency Input > Impedance
Impedance

For MCWN measurements, the impedance is always 50 Ω.


Frequency Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Frequency Settings
Frequency Settings

The frequency span to be measured can be defined using a start and stop frequency, or a center frequency and span; alternatively, it can be set to a specific characteristic value automatically.

Frequency and span settings can be configured via the "Frequency" dialog box, which is displayed when you press the FREQ or SPAN key and then select "Frequency Config".

└ Frequency Band
└ Center Frequency
└ Span
└ Start / Stop
└ Setting the Span to Specific Values Automatically
└ Frequency Offset


Span

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Frequency Settings > Span
Span

Defines the frequency span. The center frequency is kept constant. The following range is allowed:

spanmin ≤ f span ≤ f max

fmax and spanmin are specified in the data sheet.

For more information see "Defining the Scope of the Measurement - Frequency Range" .

Remote command:

[SENSe:​]FREQuency:​SPAN


Start / Stop

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Frequency Settings > Start / Stop
Start / Stop

Defines the start and stop frequencies. The following range of values is allowed:

fmin ≤ fstart ≤ fmax – spanmin

fmin + spanmin ≤ fstop ≤ fmax

fmin, fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​STARt

[SENSe:​]FREQuency:​STOP


Setting the Span to Specific Values Automatically

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Frequency Settings > Setting the Span to Specific Values Automatically
Setting the Span to Specific Values Automatically

In "Manual" mode, the frequency span is defined by a "Start / Stop", or a "Center Frequency" and "Span".

If the "Auto" span mode is enabled (default), the span for the MCWN measurement is set to one of the following values automatically.

"Tx Band"

The span for the MCWN measurement is set to the Tx band ±10 MHz (for multicarrier BTS device types) or ±2 MHz (for all other device types).

The Tx bands are defined in the standard in 3GPP TS 45.005, chapter "2 Frequency bands and channel arrangement".

This setting is recommended for measurements according to the standard.

"Carriers ± 1.8 MHz"

The span is set to the span of all active (GSM) carriers, plus a margin of 1.8 MHz to either side.

This setting is suitable for narrowband noise measurements.

"Carriers ± 6 MHz"

The span is set to the span of all active (GSM) carriers, plus a margin of 6 MHz to either side.

This setting is suitable for wideband noise and intermodulation measurements.

Remote command:

SENSe:​FREQuency:​SPAN:​MODE


Amplitude Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings affect the y-axis values.

└ Power Class
└ Reference Level
└ Shifting the Display (Offset)
└ Mechanical Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Mechanical Attenuation

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Amplitude Settings > Mechanical Attenuation
Mechanical Attenuation

Defines the mechanical attenuation for RF input.

└ Attenuation Mode / Value


Input Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Noise Source

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Input and Frontend Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

Trigger settings can be configured in the "Trigger" dialog box, which is displayed when you do one of the following:
  • Press the TRIG key and then select the "Trigger Config" softkey.
  • In the "Overview", select the "Trigger" button.

The GSM measurements can be performed in "Free Run" (untriggered) mode; however, an external trigger or a power trigger can speed up measurements.

For more information see "Trigger settings".

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

Note that gating is not available for GSM measurements.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

└ Trigger Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Trigger Settings > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff


Trigger Source

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Trigger Settings > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Note: The GSM measurements can be performed in "Free Run" (untriggered) mode; however, an external trigger or a power trigger can speed up measurements.
For more information see "Trigger settings".

Note: Trigger source for MSRA Master. Any trigger source other than "Free Run" defined for the MSRA Master is ignored when determining the frame start in the R&S FSW GSM application (see "Trigger settings"). For this purpose, the trigger is considered to be in "Free Run" mode.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power


Hysteresis

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Trigger Settings > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Trigger Settings > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Sweep Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Sweep Settings
Sweep Settings

The "Sweep" settings define how often data is captured from the input signal by the R&S FSW GSM application.

The settings in this menu are available when you press the SWEEP key.

└ Reference Average Count
└ Noise Average Count
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep


Reference Average Count

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Sweep Settings > Reference Average Count
Reference Average Count

Defines the number of reference measurements to be performed in order to determine the average reference values.

For details see "Reference measurement".

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​AVERage:​COUNt


Noise Average Count

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Sweep Settings > Noise Average Count
Noise Average Count

Defines the number of noise measurements to be performed in order to determine the average result values.

Remote command:

[SENSe:​]SWEep:​COUNt


Reference Measurement Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings
Reference Measurement Settings

Reference power levels can either be defined manually or determined automatically by a reference measurement prior to the noise measurement.

Reference power settings can be configured in the "Reference Meas" tab of the "Measurement Settings" dialog box, which is displayed when you do one of the following:
  • Press the MEAS CONFIG key and then select the "Reference Meas" softkey.
  • In the "Overview", select the "Reference Meas" button.
└ Enabling a reference power measurement ( Measure )
└ Reference Average Count
└ Carrier Selection / Carrier
└ Defining Reference Powers Manually
└ Power Level
└ Ref Power (RBW 300 kHz)
└ Ref Power (RBW 100 kHz)
└ Ref Power (RBW 30 kHz)


Enabling a reference power measurement ( Measure )

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Enabling a reference power measurement ( Measure )
Enabling a reference power measurement ( Measure )

If enabled, the reference powers of all active carriers are measured for MCWN measurements.

If disabled, the reference powers must be defined manually (see "Defining Reference Powers Manually").

For details see "Reference measurement".

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure


Carrier Selection / Carrier

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Carrier Selection / Carrier
Carrier Selection / Carrier

Specifies the carrier at which the reference powers for the MCWN measurement are measured (if reference power measurement is enabled, see "Enabling a reference power measurement ( Measure )").

In "Auto" mode, the carrier with the maximum power level is selected as a reference.

In "Manual" mode, you must specify the carrier to be used as a reference in the "Carrier" field. All active carriers can be selected (see "Active carriers").

For details see "Reference measurement".

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​CARRier[:​AUTO]

CONFigure:​SPECtrum:​MODulation:​REFerence:​CARRier:​NUMBer


Defining Reference Powers Manually

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Defining Reference Powers Manually
Defining Reference Powers Manually

Alternatively to performing a measurement to determine the reference powers for MCWN measurements, you can define them manually.

Note that reference power levels depend on the modulation characteristics. For details see "Manual Reference Power Definition for MCWN Measurements"

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure

└ Power Level
└ Ref Power (RBW 300 kHz)
└ Ref Power (RBW 100 kHz)
└ Ref Power (RBW 30 kHz)


Power Level

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Defining Reference Powers Manually > Power Level
Power Level

Manually defined carrier power level to be used as a reference for MCWN measurements.

(If reference measurement is enabled (see"Enabling a reference power measurement ( Measure )"), this value is displayed for information only.)

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​PLEVel


Ref Power (RBW 300 kHz)

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Defining Reference Powers Manually > Ref Power (RBW 300 kHz)
Ref Power (RBW 300 kHz)

Manually defined reference power level measured with an RBW of 300 kHz for MCWN measurements.

Note that reference power levels depend on the modulation characteristics, see also "Manual Reference Power Definition for MCWN Measurements"

(If reference measurement is enabled (see"Enabling a reference power measurement ( Measure )"), this value is displayed for information only.)

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​RPOWer


Ref Power (RBW 100 kHz)

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Defining Reference Powers Manually > Ref Power (RBW 100 kHz)
Ref Power (RBW 100 kHz)

Manually defined reference power level measured with an RBW of 100 kHz for MCWN measurements.

Note that reference power levels depend on the modulation characteristics, see also "Manual Reference Power Definition for MCWN Measurements"

(If reference measurement is enabled (see"Enabling a reference power measurement ( Measure )"), this value is displayed for information only.)

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​RPOWer


Ref Power (RBW 30 kHz)

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Reference Measurement Settings > Defining Reference Powers Manually > Ref Power (RBW 30 kHz)
Ref Power (RBW 30 kHz)

Manually defined reference power level measured with an RBW of 30 kHz for MCWN measurements.

Note that reference power levels depend on the modulation characteristics, see also "Manual Reference Power Definition for MCWN Measurements"

(If reference measurement is enabled (see"Enabling a reference power measurement ( Measure )"), this value is displayed for information only.)

Remote command:

CONFigure:​SPECtrum:​MODulation:​REFerence:​RPOWer


Noise Measurement Settings

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Noise Measurement Settings
Noise Measurement Settings

The noise measurement can provide various results.

Noise measurement settings can be configured in the "Noise Meas" tab of the "Measurement Settings" dialog box, which is displayed when you do one of the following:
  • Press the MEAS CONFIG key and then select the "Noise Meas" softkey.
  • In the "Overview", select the "Noise Meas" button.
└ Noise Average Count
└ Wideband Noise (≥1.8 MHz)
└ Intermodulation
└ Adapting the limit lines for wideband noise ( Apply Exceptions )


Wideband Noise (≥1.8 MHz)

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Noise Measurement Settings > Wideband Noise (≥1.8 MHz)
Wideband Noise (≥1.8 MHz)

If enabled, wideband noise is measured as part of the MCWN measurement. Wideband noise is measured with an RBW of 100 kHz over the defined span (typically the RF bandwidth).

For details see "Wideband noise and intermodulation sweeps".

Remote command:

CONFigure:​SPECtrum:​NWIDe


Intermodulation

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Noise Measurement Settings > Intermodulation
Intermodulation

The MCWN noise measurement performs special measurements at the locations of the intermodulation (IM) products of the defined order. To disable intermodulation measurement, select "off".

For details see "Intermodulation Calculation".

Remote command:

CONFigure:​SPECtrum:​IMPorder


Adapting the limit lines for wideband noise ( Apply Exceptions )

GSM application (R&S FSW-K10) > Configuration > Multicarrier Wideband Noise (MCWN) Measurements > Noise Measurement Settings > Adapting the limit lines for wideband noise ( Apply Exceptions )
Adapting the limit lines for wideband noise ( Apply Exceptions )

If enabled, exceptions from the limit line check as defined in the 3GPP standard are applied to the limit checks of the MCWN measurements.

Remote command:

CONFigure:​SPECtrum:​LIMit:​EXCeption[:​STATe]


Analysis

GSM application (R&S FSW-K10) > Analysis
Analysis

General result analysis settings concerning the trace, markers, windows etc. can be configured via the "Result Configuration" dialog box, which is displayed when you do one of the following:

  • In the "Overview", select the "Result Config" button.
  • Press the MEAS CONFIG key, then select the "Result Config" softkey.
Contents
  • Result Configuration
  • Zoom Functions


Result Configuration

GSM application (R&S FSW-K10) > Analysis > Result Configuration
Result Configuration

Some evaluation methods require or allow for additional settings to configure the result display. Note that the available settings depend on the selected window (see "Specifics for").

The "Result Configuration" dialog box is displayed when you do one of the following:
  • In the "Overview", select the "Result Config" button.
  • Press the MEAS CONFIG key, then select the "Result Config" softkey.
Contents
  • Traces
  • Markers
  • Y-Scaling


Traces

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Traces
Traces

The number of available traces depends on the selected window (see "Specifics for"). Only graphical evaluations have trace settings.

└ Trace 1/Trace 2/Trace 3/Trace 4
└ Trace Mode
└ Preset All Traces
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Traces > Trace 1/Trace 2/Trace 3/Trace 4
Trace 1/Trace 2/Trace 3/Trace 4

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Trace Mode

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Traces > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

The available trace modes depend on the selected result display. Not all evaluations support all trace modes.

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Statistic Count" determines the number of averaging procedures.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Preset All Traces

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Traces > Preset All Traces
Preset All Traces

Restores the active traces and trace modes defined by the default settings for the active result displays (see table "Default traces depending on result display").


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Traces > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Markers

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display. Up to 4 markers can be configured.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Result Config", and switch to the vertical "Marker" tab.
  • Press the MEAS CONFIG, MKR or MKR TO key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Positioning Functions


Individual Marker Settings

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings
Individual Marker Settings

In GSM evaluations, up to 4 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ Assigning the Marker to a Trace
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / Marker 4

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X


Selected Marker

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis (channel, slot, symbol, depending on evaluation).

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Assigning the Marker to a Trace

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


All Markers Off

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > General Marker Settings
General Marker Settings

General marker settings are defined in the "Marker Config" tab of the "Marker" dialog box.

└ Marker Table Display


Marker Table Display

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
Remote command:

DISPlay:​MTABle


Marker Positioning Functions

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Minimum
└ Max |Peak|


Select Marker

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Marker Positioning Functions > Select Marker
Select Marker

Selects the subsequent marker (marker 1/2/3/4 or delta marker) to be edited or to be used for a marker function. The currently selected marker number is highlighted.

Remote command:

Marker selected via suffix <m> in remote commands.


Peak Search

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Minimum

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Max |Peak|

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Markers > Marker Positioning Functions > Max |Peak|
Max |Peak|

Sets the active marker/delta marker to the largest absolute peak value (maximum or minimum) of the selected trace.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​APEak


Y-Scaling

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling
Y-Scaling

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These settings are described here.

└ Automatic Grid Scaling
└ Absolute Scaling (Min/Max Values)
└ Relative Scaling (Reference/ per Division)
└ Per Division
└ Ref Position
└ Ref Value


Automatic Grid Scaling

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Automatic Grid Scaling
Automatic Grid Scaling

The y-axis is scaled automatically according to the current measurement settings and results.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Absolute Scaling (Min/Max Values)

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Absolute Scaling (Min/Max Values)
Absolute Scaling (Min/Max Values)

Define the scaling using absolute minimum and maximum values.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Relative Scaling (Reference/ per Division)

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division)
Relative Scaling (Reference/ per Division)

Define the scaling relative to a reference value, with a specified value range per division.

└ Per Division
└ Ref Position
└ Ref Value


Per Division

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Per Division
Per Division

Defines the value range to be displayed per division of the diagram (1/10 of total range).

Note: The value defined per division refers to the default display of 10 divisions on the y-axis. If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​PDIVision


Ref Position

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Ref Position
Ref Position

Defines the position of the reference value in percent of the total y-axis range.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Ref Value

GSM application (R&S FSW-K10) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Ref Value
Ref Value

Defines the reference value to be displayed at the specified reference position.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Zoom Functions

GSM application (R&S FSW-K10) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

GSM application (R&S FSW-K10) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

GSM application (R&S FSW-K10) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

GSM application (R&S FSW-K10) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

GSM application (R&S FSW-K10) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


I/Q Data Import and Export

GSM application (R&S FSW-K10) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

For example, you can capture I/Q data using the I/Q Analyzer application, if available, and then perform a GSM measurement on that data later using the R&S FSW GSM application.

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


How to Perform Measurements in the GSM Application

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application
How to Perform Measurements in the GSM Application

The following step-by-step instructions demonstrate how to perform common GSM measurements with the R&S FSW GSM application.

Contents
  • How to Perform a Basic Measurement on GSM Signals
  • How to Determine Modulation Accuracy Parameters for GSM Signals
  • How to Analyze the Power in GSM Signals
  • How to Analyze the Spectrum of GSM Signals
  • How to Measure Wideband Noise in Multicarrier Setups


How to Perform a Basic Measurement on GSM Signals

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application > How to Perform a Basic Measurement on GSM Signals
How to Perform a Basic Measurement on GSM Signals

  1. Press the MODE key on the front panel and select the "GSM" application.

  2. Select the "Overview" softkey to display the "Overview" for a GSM measurement.

  3. Select the "Signal Description" button and configure the expected signal by defining the used device and slot characteristics as well as the modulation:

    • Define the expected burst type and modulation for each active slot.
    • Define the training sequences (or syncs) with which each slot will be compared to synchronize the measured data with the expected data.
    • For AQPSK modulated signals, define a TSC for each subchannel and each active slot.
    • For access bursts, also define a "Timing Advance", i.e. the position of the burst within the slot.
    • For signals from base stations capable of using multiple carriers, define additional settings on the "Multicarrier" tab.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's frequency band and center frequency.

  5. Select the "Amplitude" tab in the "Input/Frontend" dialog box to define the correct power class for the base station or mobile device.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

  7. Optionally, to perform statistical evaluation over several measurements, switch to the "Sweep" tab in the "Data Acquisition" dialog box and define a "Statistics Count".

  8. Select the "Demodulation" button to determine how bursts are detected and demodulated.

  9. Select the "Measurement" button and define the special measurement settings for the Spectrum, Trigger to Sync and Power vs Time measurements.

    In particular, define the frequency list to be used to determine the modulation spectrum, and filters to be used for multicarrier measurements.

  10. Select the "Display Config" button and select up to 16 displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  11. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  12. Select the "Result Config" button to configure settings for specific result displays. These settings can be configured individually for each window, so select the window first and then configure the settings.

    • Define the "Traces" to be displayed in the window.
      Optionally, configure the trace to display the average over a series of measurements. If necessary, increase the "Statistics Count" in the "Sweep Config" dialog box.
    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.
    • Adapt the diagram scaling to the displayed data.

  13. Start a new sweep with the defined settings.

    • To perform a single measurement, press the RUN SINGLE key.
    • To start a (new) continuous measurement, press the RUN CONT key.


How to Determine Modulation Accuracy Parameters for GSM Signals

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application > How to Determine Modulation Accuracy Parameters for GSM Signals
How to Determine Modulation Accuracy Parameters for GSM Signals

  1. Press the MODE key on the front panel and select the "GSM" application.

  2. Select the "Overview" softkey to display the "Overview" for a GSM measurement.

  3. Select the "Signal Description" button and configure the expected signal by defining the used device and slot characteristics as well as the modulation:

    • Define the expected burst type and modulation for each active slot.
    • Define the training sequences (or syncs) with which each slot will be compared to synchronize the measured data with the expected data.
    • For AQPSK modulated signals, define a TSC for each subchannel and each active slot.
    • For access bursts, also define a "Timing Advance", i.e. the position of the burst within the slot.
    • For signals from base stations capable of using multiple carriers, define additional settings on the "Multicarrier" tab.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's frequency band and center frequency.

  5. Select the "Amplitude" tab in the "Input/Frontend" dialog box to define the correct power class for the base station or mobile device.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted. For external triggers, do not forget to set the correct "Trigger Offset" to the beginning of the GSM frame.

  7. Optionally, to perform statistical evaluation over several measurements, switch to the "Sweep" tab in the "Data Acquisition" dialog box and define a "Statistics Count".

  8. Select the "Demodulation" button to determine how bursts are detected and demodulated.

  9. Select the "Display Config" button and activate one or more of the following result displays for modulation accuracy and error parameters (up to a total of 16 windows):

    • "Modulation Accuracy"
    • "EVM"
    • "Magnitude Error"
    • "Phase Error"

    Tip: Also activate the "Magnitude Capture" result display for a general overview of the measured data.

    Arrange them on the display to suit your preferences.

  10. Exit the SmartGrid mode.

  11. Start a new sweep with the defined settings.

    • To perform a single measurement, press the RUN SINGLE key.
    • To start a (new) continuous measurement, press the RUN CONT key.

  12. Check the "Magnitude Capture" for irregular behavior, e.g. an unexpected rise or fall in power. If such an effect occurs, determine whether it occured in the current slot scope and current slot to measure (compare the green and blue bars beneath the trace). If necessary, zoom into the display to view it in greater detail.

  13. If necessary, change the slot scope or slot to measure to display the slot of interest (e.g. using the softkeys in the "GSM" menu).

    Now you can analyze the "Magnitude Error", "Phase Error", or "EVM" for that slot.

  14. Compare the current results of the "EVM" with those of previous measurements to find out if the error occurs only sporadically or repeatedly.


How to Analyze the Power in GSM Signals

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application > How to Analyze the Power in GSM Signals
How to Analyze the Power in GSM Signals

  1. Press the MODE key on the front panel and select the "GSM" application.

  2. Select the "Overview" softkey to display the "Overview" for a GSM measurement.

  3. Select the "Signal Description" button and configure the expected signal by defining the used device and slot characteristics as well as the modulation:

    • Define the expected burst type and modulation for each active slot.
    • Define the training sequences (or syncs) with which each slot will be compared to synchronize the measured data with the expected data.
    • For AQPSK modulated signals, define a TSC for each subchannel and each active slot.
    • For access bursts, also define a "Timing Advance", i.e. the position of the burst within the slot.
    • For signals from base stations capable of using multiple carriers, define additional settings on the "Multicarrier" tab.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's frequency band and center frequency.

  5. Select the "Amplitude" tab in the "Input/Frontend" dialog box to define the correct power class for the base station or mobile device.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted. For external triggers, do not forget to set the correct "Trigger Offset" to the beginning of the GSM frame.

  7. Optionally, to perform statistical evaluation over several measurements, switch to the "Sweep" tab in the "Data Acquisition" dialog box and define a "Statistics Count".

  8. Select the "Demodulation" button to determine how bursts are detected and demodulated.

  9. Select the "Measurement" button and define the special measurement settings for the Power vs Time measurement:

    • Define the PvT filter to be used (for selection criteria see "Power vs Time Filter").
    • Define how the limit line defined by the standard is to be aligned to the measured slots, and whether the relative positioning of the TSCs is measured or derived from the position of the specified "Slot to Measure" only.
      For measurements strictly according to standard, use the default "Limit Line Time Alignment": "Slot to Measure".
      For non-standard signals or signals with conspicuous slot timing, use the "Per Slot" setting.
      (Tip: use the "Delta to Sync" result of the Power vs Slot measurement to verify the slot timing.)

  10. Select the "Display Config" button and select one or more of the following displays for power results (up to a total of 16 windows):

    • "PvT Full Burst" (power graph of all slots (bursts) in the selected slot scope over time)
    • "Power vs Slot" (table of power per slot in the current frame and over all frames)

    Tip: Also display the "Magnitude Capture" for a general overview of the measured data.

    Arrange them on the display to suit your preferences.

  11. Exit the SmartGrid mode.

  12. Start a new sweep with the defined settings.

    • To perform a single measurement, press the RUN SINGLE key.
    • To start a (new) continuous measurement, press the RUN CONT key.

  13. Check the "PvT Full Burst" results to determine if the signal remains within the limits specified by the standard in all slots to measure.

  14. If the "Limit Check" indicates "FAIL", zoom into the Power vs Time graph to determine the time at which the power exceeded the limit.

    Note: in measurements according to standard, the delta value will be identical for all slots in the scope due to the "Limit Line Time Alignment": "Slot to Measure" setting (see step 9).

  15. Check the irregular slot in more detail in the "Magnitude Capture" (compare the green and blue bars beneath the trace). If necessary, zoom into the display to view it in greater detail.


How to Analyze the Spectrum of GSM Signals

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application > How to Analyze the Spectrum of GSM Signals
How to Analyze the Spectrum of GSM Signals

  1. Press the MODE key on the front panel and select the "GSM" application.

  2. Select the "Overview" softkey to display the "Overview" for a GSM measurement.

  3. Select the "Signal Description" button and configure the expected signal by defining the used device and slot characteristics as well as the modulation:

    • Define the expected burst type and modulation for each active slot.
    • Define the training sequences (or syncs) with which each slot will be compared to synchronize the measured data with the expected data.
    • For AQPSK modulated signals, define a TSC for each subchannel and each active slot.
    • For access bursts, also define a "Timing Advance", i.e. the position of the burst within the slot.
    • For signals from base stations capable of using multiple carriers, define additional settings on the "Multicarrier" tab.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's frequency band and center frequency.

  5. Select the "Amplitude" tab in the "Input/Frontend" dialog box to define the correct power class for the base station or mobile device.

  6. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted. For external triggers, do not forget to set the correct "Trigger Offset" to the beginning of the GSM frame.

  7. Optionally, to perform statistical evaluation over several measurements, switch to the "Sweep" tab in the "Data Acquisition" dialog box and define a "Statistics Count".

  8. Select the "Demodulation" button to determine how bursts are detected and demodulated.

  9. Select the "Measurement" button and define the special measurement settings for the Spectrum measurements:

    • For multicarrier base stations, define which carriers are measured:
      – the left-most carrier only ("Enable Left Limit" = ON)
      – the right-most carrier only ("Enable Right Limit" = ON)
      – all carriers ("Enable Left Limit" = ON, "Enable Right Limit" = ON)
    • Select the type of resolution filter to be used.
      For measurements strictly according to standard, use the "Normal (3dB)" filter.
    • Select the frequency list to be used to determine the modulation spectrum.
      For a quick overview, select a sparse list; for a conformance test, use the list specified by the standard
      As a rule, use the narrow list to test mobile devices, use the wide list for base station tests.
    • Select the reference power to be used to determine the relative limit values for the transient spectrum.
      For measurements strictly according to standard, use the "RMS" setting.

  10. Select the "Display Config" button and select one or more of the following displays for spectrum results (up to a total of 16 windows):

    • "Modulation Spectrum Graph"
    • "Modulation Spectrum Table"
    • "Transient Spectrum Graph"
    • "Transient Spectrum Table"
    Tips:
    • Also display the "Magnitude Capture" for a general overview of the measured data.
    • Use the graph displays for a general overview of the currently measured spectrum; the tables provide detailed numeric values, and an accurate conformance check of the DUT to the GSM standard.
    • The modulation spectrum shows the spectrum for a portion of a burst in a single slot (see "Modulation Spectrum Graph"); the transient spectrum shows the spectrum for all slots in the slot scope, including the rising and falling edges of the bursts.

    Arrange the windows on the display to suit your preferences.

  11. Exit the SmartGrid mode.

  12. Start a new sweep with the defined settings.

    • To perform a single measurement, press the RUN SINGLE key.
    • To start a (new) continuous measurement, press the RUN CONT key.

  13. Check the result of the limit check in the graph. If it indicates "FAIL", refer to the numeric results in the table display for more precise information on which frequency exceeds the limit (indicated by a negative "Δ to Limit" value and red characters).


How to Measure Wideband Noise in Multicarrier Setups

GSM application (R&S FSW-K10) > How to Perform Measurements in the GSM Application > How to Measure Wideband Noise in Multicarrier Setups
How to Measure Wideband Noise in Multicarrier Setups

  1. Press the MODE key on the front panel and select the "GSM" application.

  2. Press the MEAS key and select the "MC and Wide Noise" measurement.

  3. Select the "Overview" softkey to display the "Overview" for the MCWN measurement.

  4. Select the "Signal Description" button and configure the expected signal by selecting a multicarrier device type and defining the active carriers.

    • Select a device type supports multiple carriers on the "Device" tab.
    • Activate the required number of carriers and define the frequency, expected burst type and modulation for each active carrier in the "Carriers" tab.

  5. Select the "Input/Frontend" button and then the "Frequency" tab to define the required frequency band and measurement span.

  6. Select the "Amplitude" tab in the "Input/Frontend" dialog box to define the correct power class for the base station or mobile device.

  7. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted. For external triggers, do not forget to set the correct "Trigger Offset" to the beginning of the GSM frame.

  8. Select the "Reference measurement" button to determine how the reference powers are determined. Do one of the following:

    • Enable automatic measurement with automatic carrier selection.
    • Enable automatic measurement and select a carrier to be used for reference.
    • Disable the reference measurement and define the power level and the three reference power levels (for 30 kHz/100 kHz/300 kHz RBW; see also "Manual Reference Power Definition for MCWN Measurements").

  9. Select the "Measurement" button and define which of the noise and intermodulation measurements are to be performed.

    If necessary, increase the number of measurements to be performed for averaging (Average count).

  10. Select the "Display Config" button and select up to 16 displays that are of interest to you.

    Arrange them on the display to suit your preferences.

  11. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  12. Select the "Result Config" button to configure settings for specific result displays. These settings can be configured individually for each window, so select the window first and then configure the settings.

    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.
    • Adapt the diagram scaling to the displayed data.

  13. Start a new sweep with the defined settings.

    • To perform a single measurement, press the RUN SINGLE key.
    • To start a (new) continuous measurement, press the RUN CONT key.


Optimizing and Troubleshooting the Measurement

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results of a GSM measurement do not meet your expectations, try the following recommendations to optimize the measurement.

Contents
  • Improving Performance
  • Improving EVM Accuracy
  • Optimizing Limit Checks
  • Error Messages


Improving Performance

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Improving Performance
Improving Performance

If the GSM measurement seems to take a long time, try the following tips.

Using external triggers to mark the frame start

The R&S FSW GSM application needs the frame start as a time reference. It either searches for a frame start after every I/Q data acquisition, or relies on a trigger event that marks the frame start. An external trigger or a power trigger that mark the frame start can speed up measurements. See also "Trigger settings".

In MSRA mode, trigger events are not considered when determining the frame start in a GSM measurement, as the trigger is defined by the MSRA Master for all applications simultaneously and most likely does not coincede with the frame start for the GSM signal.

Avoiding unnecessary high sample rates

According to the GSM standard, modulation spectrum results must be performed at frequencies up to 6 MHz from the carrier in some cases. When the frequency list to be used is set to 6 MHz in the "Measurement" settings (see "Modulation Spectrum Table: Frequency List"), the R&S FSW GSM application uses a sample rate of 19.5 MHz, as opposed to the usual 6.5 MHz sample rate. The higher sample rate extends the required measurement time. Only use the 6 MHz frequency list setting if you actually require "Modulation Spectrum" results according to standard.


Improving EVM Accuracy

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Improving EVM Accuracy
Improving EVM Accuracy

If the EVM results show unexpected power levels, check the following issues.

Extending the data basis

Sporadic distortions in the EVM can be eliminated by evaluating several measurements and determining the average over all traces. Increase the "Statistic Count" in the "Sweep" settings to obtain sufficiently stable results.

Excluding results from adjacent channels

For signals from base stations capable of using multiple carriers, configure the DUT as such in the signal description. In this case, an additional multicarrier (PvT) filter suppresses power from adjacent channels. This filter is also taken into account during the generation of the ideal (reference) signal, otherwise there would be an increase in EVM because the measured signal has a smaller bandwidth compared to the reference signal. Define which PvT filter to use, depending on whether the channel to be measured has a reduced or equal power compared to its adjacent channels (see "Power vs Time Filter").

For single carrier measurements, make sure the correct "Device Type" setting is selected so the correct PvT filter is used for the power measurement.


Optimizing Limit Checks

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Optimizing Limit Checks
Optimizing Limit Checks

If the limit checks fail unexpectedly, check the following issues.

Excluding results from adjacent channels

In limit checks for multicarrier spectrum measurements, the frequencies from adjacent carriers in the signal may distort the results of the limit check for a single carrier. If you only want to check the frequencies from a single carrier in a multicarrier signal, disable the limit check for frequencies to the left or right of the carrier frequency of interest (see "Enable Left Limit/ Enable Right Limit"). This allows you to measure the spectrum of the left or right-most channel while ignoring the side where adjacent channels are located.

Make sure you select the correct "Slot to Measure" for Modulation Spectrum results (see "Slot Scope").

Calculating limit lines according to the used DUT

For multicarrier measurements, ensure that the DUT is configured correctly (see "Frame"). The number of active carriers and the specified BTS class affect the calculation of the limits according to the 3GPP standard for the modulation spectrum measurement.

Aligning the limit line correctly

The limit line defined by the standard must be aligned to the measured slots. The alignment can either be determined individually for each slot, or the entire line is aligned according to the "Slot to Measure" (see "Limit Line Time Alignment").

The standard requires that the entire line be aligned according to the "Slot to Measure". However, in this case the "Delta to Sync" value will be identical for all slots in the scope (see table "Measured power values for Power vs Slot results").

Note that the R&S FSW GSM application assumes that all slots have equal length. If they do not, disable this setting in the "Frame" settings (see "Equal Timeslot Length") so the limit line is aligned to the slots correctly.

For non-standard signals or if you require more precise delta values, use the "Time Alignment": "Per Slot" setting.


Error Messages

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Error Messages
Error Messages

The following error messages may be displayed in the status bar of the R&S FSW GSM application. Check these descriptions for possible error causes and solutions.

└ Burst not found
└ Sync not found


Burst not found

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Error Messages > Burst not found
Burst not found
Possible causes | Possible solutions
Training sequence (TSC) or sync is not defined correctly. | Check the TSC/sync definition in "Slot" settings (see "Training Sequence TSC / Sync")
Slot is not in defined slot scope | Include the slot in the slots to measure (see "Slot Scope")


Sync not found

GSM application (R&S FSW-K10) > Optimizing and Troubleshooting the Measurement > Error Messages > Sync not found
Sync not found
Possible causes | Possible solutions
Training sequence (TSC) or sync is not defined correctly. | Check the TSC/sync definition in "Slot" settings (see "Training Sequence TSC / Sync")
No or incorrect position of access burst in slot defined. | Define the correct "Timing Advance" for the slots containing an access burst (see "Timing Advance (Access Burst only)").
The trigger event does not correspond to the start of the "active part" in slot 0. | Correct the trigger offset (for an external trigger, see "Trigger Offset")
The DUT interchanged the I and Q parts of the signal. | Swap the I and Q values after data acquisition in the R&S FSW GSM application to reverse this effect (see "Swap I/Q").


Remote Commands to Perform GSM Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements
Remote Commands to Perform GSM Measurements

The following commands are required to perform measurements in the GSM application in a remote environment. It is assumed that the R&S FSW has already been set up for remote operation in a network as described in the R&S FSW User Manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following topics specific to the GSM application are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating GSM Measurements
  • Selecting the Measurement
  • Configuring and Performing GSM I/Q Measurements
  • Configuring and Performing MCWN Measurements
  • Analyzing GSM Measurements
  • Retrieving Results
  • Importing and Exporting I/Q Data and Results
  • Status Reporting System
  • Troubleshooting
  • Deprecated Commands (Commands for Compatibility)
  • Programming Examples


Introduction

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Common Suffixes
Common Suffixes

In the GSM application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<m> | 1..4 | Marker
<n> | 1..16 | Window
<s> | 0..7 | Slot
<t> | 1..4 | Trace


Activating GSM Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements
Activating GSM Measurements

GSM measurements require a special application on the R&S FSW. A measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer


INSTrument:CREate:DUPLicate

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
GSM

GSM application, R&S FSW–K10


SYSTem:PRESet:CHANnel[:EXECute]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


SYSTem:SEQuencer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Activating GSM Measurements > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "Sequencer State"


Selecting the Measurement

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Selecting the Measurement
Selecting the Measurement

In addition to the default GSM I/Q measurement, a new separate measurement is now available for multicarrier wideband noise (see "Multicarrier Wideband Noise Measurements").

List of Commands
CONFigure:MEASurement


CONFigure:MEASurement

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Selecting the Measurement > CONFigure:MEASurement
CONFigure:MEASurement <MeasType>

This command selects the measurement to be performed in the GSM application.

Parameters:
<MeasType>
IQ

Default I/Q measurement to determine the modulation accuracy, modulation /transient spectrum, trigger parameters etc.

MCWNoise

Sweep measurement to determine noise and intermodulation in multicarrier setups.

*RST: IQ
Example:

CONF:MEAS MCWN

Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".


Configuring and Performing GSM I/Q Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements
Configuring and Performing GSM I/Q Measurements

The following commands are required to configure a default GSM I/Q (Modulation Accuracy...) measurement on an R&S FSW in a remote environment.

Contents
  • Signal Description
  • Input/Output Settings
  • Frontend Configuration
  • Triggering Measurements
  • Data Acquisition
  • Demodulation
  • Measurement
  • Adjusting Settings Automatically


Signal Description

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes frame detection and measurement.

Contents
  • Device under Test Settings
  • Frame
  • Slot
  • Carrier


Device under Test Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings
Device under Test Settings

The type of device to be tested provides additional information on the signal to be expected.

List of Commands
CONFigure[:MS]:DEVice:TYPE
CONFigure[:MS]:NETWork[:TYPE]
CONFigure[:MS]:NETWork:FREQuency:BAND
CONFigure[:MS]:POWer:CLASs
CONFigure[:MS]:POWer:PCARrier?
CONFigure[:MS]:POWer:PCARrier:AUTO?


CONFigure[:MS]:DEVice:TYPE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:DEVice:TYPE
CONFigure[:MS]:DEVice:TYPE <Value>

This command specifies the type of device to be measured.

Parameters for setting and query:
<Value>
BTSNormal

BTS, TRX power class Normal

BTSMicro

BTS, TRX power class Micro

BTSPico

BTS, TRX power class Pico

MSNormal

MS, normal type

MSSMall

MS, small type

MCBLocal

Multicarrier BTS Local Area

MCBMedium

Multicarrier BTS Medium Range

MCBWide

Multicarrier BTS Wide Area

*RST: BTSNormal
Example: CONF:DEV:TYPE BTSNormal
Example:

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Device Type"


CONFigure[:MS]:NETWork[:TYPE]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:NETWork[:TYPE]
CONFigure[:MS]:NETWork[:TYPE] <Value>

This command works in conjunction with the CONFigure[:​MS]:​NETWork:​FREQuency:​BAND command to specify the frequency band of the signal to be measured. The command is not in-line with the manual operation so the SCPI remote control command remains compatible with the R&S FS-K5.

Parameters for setting and query:
<Value>
PGSM | EGSM | DCS | PCS | TGSM | RGSM | GSM
PGSM

Primary GSM

EGSM

Extended GSM

DCS

DCS

PCS

PCS

TGSM

T-GSM

RGSM

Railway GSM

GSM

GSM

*RST: EGSM
Example: CONF:NETW PGSM
Example:

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Frequency Band"


CONFigure[:MS]:NETWork:FREQuency:BAND

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:NETWork:FREQuency:BAND
CONFigure[:MS]:NETWork:FREQuency:BAND <Value>

This command works in conjunction with theCONFigure[:​MS]:​NETWork[:​TYPE] command to specify the frequency band of the signal to be measured. The command is not in-line with the manual operation so the SCPI remote control command remains compatible with the R&S FS-K5.

Parameters for setting and query:
<Value>
380 | 410 | 450 | 480 | 710 | 750 | 810 | 850 | 900 | 1800 | 1900
380

380 MHz band – valid for TGSM

410

410 MHz band – valid for TGSM

450

450 MHz band – valid for GSM

480

480 MHz band – valid for GSM

710

710 MHz band – valid for GSM

750

750 MHz band – valid for GSM

810

810 MHz band – valid for TGSM

850

850 MHz band – valid for GSM

900

900 MHz band – valid for PGSM, EGSM, RGSM and TGSM

1800

1800 MHz band – valid for DCS

1900

1900 MHz band – valid for PCS

*RST: 900
Example: CONF:NETW:FREQ 380
Example:

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Frequency Band"


CONFigure[:MS]:POWer:CLASs

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:POWer:CLASs
CONFigure[:MS]:POWer:CLASs <Value>

This command the power class of the device under test.

Parameters for setting and query:
<Value>
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | E1 | E2 | E3 | M1 | M2 | M3 | P1 | NONE
1

MS and BTS power class 1

2

MS and BTS power class 2

3

MS and BTS power class 3

4

MS and BTS power class 4

5

MS and BTS power class 5

6

BTS power class 6

7

BTS power class 7

8

BTS power class 8

E1

MS power class E1

E2

MS power class E2

E3

MS power class E3

M1

BTS power class M1 (Micro)

M2

BTS power class M2 (Micro)

M3

BTS power class M3 (Micro)

P1

BTS power class P1 (Pico)

NONE

No power classes defined

*RST: 2
Example: CONF:POW:CLAS 1
Example:

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Power Class"


CONFigure[:MS]:POWer:PCARrier?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:POWer:PCARrier?
CONFigure[:MS]:POWer:PCARrier? <Power>

Defines the maximum output power per carrier, which determines the limit lines for the modulation spectrum (I/Q measurements) and MCWN measurement.

This value is ignored if CONFigure[:​MS]:​POWer:​PCARrier:​AUTO? is ON.

Parameters:
<Power>

maximum output power in dBm

*RST: 0 dBm
Example: CONF:POW:PCAR:AUTO OFF
CONF:POW:PCAR 4 dBm
Usage: Query only
Manual operation: See "Maximum Output Power per Carrier (multicarrier measurements only)"


CONFigure[:MS]:POWer:PCARrier:AUTO?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Device under Test Settings > CONFigure[:MS]:POWer:PCARrier:AUTO?
CONFigure[:MS]:POWer:PCARrier:AUTO? <State>

If enabled, the maximum measured power level for the carriers is used as the maximum output power per carrier.

If disabled, the maximum power is defined by CONFigure[:​MS]:​POWer:​PCARrier?.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CONF:POW:PCAR:AUTO OFF
CONF:POW:PCAR 4 dBm
Usage: Query only
Manual operation: See "Maximum Output Power per Carrier (multicarrier measurements only)"


Frame

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Frame
Frame

Frame settings determine the frame configuration used by the device under test.

List of Commands
CONFigure[:MS]:CHANnel:FRAMe:EQUal


CONFigure[:MS]:CHANnel:FRAMe:EQUal

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Frame > CONFigure[:MS]:CHANnel:FRAMe:EQUal
CONFigure[:MS]:CHANnel:FRAMe:EQUal <State>

If activated, all slots of a frame have the same length (8 x 156.26 normal symbol periods).

If deactivated, slots number 0 and 4 of a frame have a longer duration, all other a shorter duration compared to the "equal slot length" (157, 156, 156, 156, 157, 156, 156, 156 normal symbol periods).

See 3GPP TS 51.0213GPP TS 51.021 and 3GPP TS 45.0103GPP TS 45.010 chapter "6.7 Timeslot length" for further details.

This parameter is used to adjust the time for the "Power vs Time" masks of all slots. The "Slot to measure" is used as the time reference for the entire frame.

Parameters for setting and query:
<State>
1 | 0 | ON | OFF
*RST: ON
Example: CONF:CHAN:FRAM:EQU OFF
Manual operation: See "Equal Timeslot Length"

For a detailed example see "Programming Example: Determining the EVM".


Slot

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot
Slot

The R&S FSW GSM application is slot-based. Thus, information on the expected slots of the input signal are required. The following commands are required to provide this information.

List of Commands
CONFigure[:MS]:CHANnel:SLOT<Number>:FILTer
CONFigure[:MS]:CHANnel:SLOT<Number>[:STATe]
CONFigure[:MS]:CHANnel:SLOT<Number>:MTYPe
CONFigure[:MS]:CHANnel:SLOT<s>:SCPir
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC:USER
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC
CONFigure[:MS]:CHANnel:SLOT<Number>:TADVance
CONFigure[:MS]:CHANnel:SLOT<s>:TSC
CONFigure[:MS]:CHANnel:SLOT<s>:TSC:USER
CONFigure[:MS]:CHANnel:SLOT<Number>:TYPE


CONFigure[:MS]:CHANnel:SLOT<Number>:FILTer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<Number>:FILTer
CONFigure[:MS]:CHANnel:SLOT<Number>:FILTer <Type>

This command specifies the pulse shape of the ideal modulator.

Suffix:
<Number>
<0..7>

the slot to configure

Parameters for setting and query:
<Type>
GMSK | LINearised | NARRow | WIDE
GMSK

GMSK Pulse

LINearised

Linearised GMSK Pulse

NARRow

Narrow Pulse

WIDE

Wide Pulse

*RST: GMSK
Example: CONF:CHAN:SLOT:FILT GMSK
Manual operation: See "Filter"

For a detailed example see "Programming Example: Determining the EVM".


CONFigure[:MS]:CHANnel:SLOT<Number>[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<Number>[:STATe]
CONFigure[:MS]:CHANnel:SLOT<Number>[:STATe] <State>

This command activates this slot (this means that e.g. this slot is not considered as inactive in the PvT evaluation).

Suffix: |
<Number> | <0..7> Select the slot to configure.
Parameters for setting and query:
<State> | ON | OFF
Example: | CONF:CHAN:SLOT ON
Manual operation: | See "Slot State (On/Off)"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:SLOT<Number>:MTYPe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<Number>:MTYPe
CONFigure[:MS]:CHANnel:SLOT<Number>:MTYPe <Modulation>

This command specifies the modulation type.

Suffix:
<Number>
<0..7>

the slot to configure

Parameters for setting and query:
<Modulation>
GMSK

GMSK, Gaussian Minimum Shift Keying, 1 bit/symbol.

QPSK

QPSK, Quadrature Phase Shift keying, 2 bits/symbol.

PSK8

8PSK (EDGE), Phase Shift Keying, 3 bits/symbol.

QAM16

16QAM, 16-ary Quadrature Amplitude Modulation, 4 bits/symbol.

QAM32

32QAM, 16-ary Quadrature Amplitude Modulation, 5 bits/symbol.

*RST: GMSK
Example: CONF:CHAN:SLOT0:MTYP GMSK
Manual operation: See "Modulation"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:SLOT<s>:SCPir

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<s>:SCPir
CONFigure[:MS]:CHANnel:SLOT<s>:SCPir <Value>

This command specifies the Subchannel Power Imbalance Ratio (SCPIR) of the specified slot.

Notes:

This command is only available for AQPSK modulation.

Suffix:
<s>
<0..7>

Number of slot to configure

Parameters for setting and query:
<Value>
numeric value

Subchannel Power Imbalance Ratio (SCPIR) in dB

Range: | -15 to 15
*RST: | 0
Default unit: | NONE
Example:

// Subchannel Power Imbalance Ratio (SCPIR) = 4 dB

CONFigure:MS:CHANnel:SLOT0:SCPir 4
Manual operation: See "SCPIR"

For a detailed example see "Programming Example: Measuring an AQPSK Signal" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC:USER

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC:USER
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC:USER <Value>

This command sets the bits of the user definable TSC. The number of bits must be 26. CONFigure[:​MS]:​CHANnel:​SLOT<s>:​SUBChannel<ch>:​TSC:​USER must be set first.

This command is only available for AQPSK modulation.

Suffix:
<s>
<0..7>

Number of slot to configure

<ch>
<1|2>

Subchannel number

Parameters for setting and query:
<Value>
string

String containing the 26 user-defined bits

Example:

// Subchannel 1: User TSC

CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC USER
CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC?

// -> USER

Manual operation: See "User TSC / User Sync"

For a detailed example see "Programming Example: Measuring an AQPSK Signal" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC <Value>

This command selects the training sequence of the specified slot and subchannel used by the mobile or base station.

This command is only available for AQPSK modulation.

Suffix:
<s>
<0..7>

Number of slot to configure

<ch>
<1|2>

Subchannel number

Query parameters:
<ResultType>
TSC | SET

Queries the currently used TSC number or the set.

Parameters for setting and query:
<Value>
0,1 | 0,2 | 1,1 | 1,2 | 2,1 | 2,2 | 3,1 | 3,2 | 4,1 | 4,2 | 5,1 | 5,2 | 6,1 | 6,2 | 7,1 | 7,2 | USER

TSC number and Set or User TSC

Set 2 is only available for subchannel 2.

*RST: 0,1
Example:

// Subchannel 1: TSC 0 (Set 1)

CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC 0,1

// Subchannel 1: Query TSC number and Set number

CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC?

// -> 0,1

// Subchannel 1: Query TSC number

CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC? TSC

// -> 0

// Subchannel 1: Query Set number

CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC? SET

// -> 1

Manual operation: See "Training Sequence TSC / Sync"

For a detailed example see "Programming Example: Measuring an AQPSK Signal" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:SLOT<Number>:TADVance

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<Number>:TADVance
CONFigure[:MS]:CHANnel:SLOT<Number>:TADVance <Offset>

Specifies the position of an access burst within a single slot.

This command is only available for access bursts (see CONFigure[:​MS]:​CHANnel:​SLOT<Number>:​TYPE).

Suffix:
<Number>
<0..7>
Parameters for setting and query:
<Offset>

offset from slot start in symbols

Range: | 0 to 63
Increment: | 10
*RST: | 0
Example: CONF:CHAN:SLOT:TADV 1
Manual operation: See "Timing Advance (Access Burst only)"


CONFigure[:MS]:CHANnel:SLOT<s>:TSC

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<s>:TSC
CONFigure[:MS]:CHANnel:SLOT<s>:TSC <Value>

This command selects the training sequence code TSC (Normal and Higher Symbol Rate Bursts) or training (synchronization) sequence TS (for Access Bursts) of the specified slot and subchannel used by the mobile or base station. See 3GPP TS 45.002, chapter 5.2 'Bursts'.

This command is not available for AQPSK modulation (use CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC instead).

Suffix:
<s>
0..7

Number of the slot to configure

Query parameters:
<ResultType>
TSC | SET

Queries the currently used TSC number or the set.

If no query parameter is defined, only the TS or the TSC is returned.

TSC

Only the TSC or TS is returned.

SET

The set of the TSC is returned.

Parameters for setting and query:
<Value>
0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 0,1 | 0,2 | 1,1 | 1,2 | 2,1 | 2,2 | 3,1 | 3,2 | 4,1 | 4,2 | 5,1 | 5,2 | 6,1 | 6,2 | 7,1 | 7,2 | TS0 | TS1 | TS2 | USER

training sequence for normal burst

0...7

One of the 7 pre-defined training sequence codes is used

0,1 | 0,2 | 1,1 | 1,2 | 2,1 | 2,2 | 3,1 | 3,2 | 4,1 | 4,2 | 5,1 | 5,2 | 6,1 | 6,2 | 7,1 | 7,2

TSC number and set for normal burst rates

TS0 | TS1 | TS2

Training (synchronization) sequence for access bursts

USER

A user-defined training sequence is used (see CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC:​USER).

*RST: 0
Example:

// TSC 3 (Set 1)

CONFigure:MS:CHANnel:SLOT0:TSC 3,1

// Query TSC number

CONFigure:MS:CHANnel:SLOT0:TSC? TSC

// -> 3

// Query Set number

CONFigure:MS:CHANnel:SLOT0:TSC? SET

// -> 1

Manual operation: See "Training Sequence TSC / Sync"

For a detailed example see "Programming Example: Determining the EVM".


CONFigure[:MS]:CHANnel:SLOT<s>:TSC:USER

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<s>:TSC:USER
CONFigure[:MS]:CHANnel:SLOT<s>:TSC:USER <Value>

This command sets the bits of the user definable TSC. The number of bits must be in accordance with the defined burst type and modulation (as indicated in table "Number of TSC bits depending on burst type and modulation"). CONFigure:MS:CHANnel:SLOT0:TSC USER must be defined first (see CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC).

Suffix: |
<s> | <0..7> The slot to configure
Parameters for setting and query:
<Value> | String containg the user defined bits, e.g. '10101111101010101100111100' for a GMSK normal burst.
Example: | CONF:CHAN:SLOT:TSC:USER
Manual operation: | See "User TSC / User Sync"

For a detailed example see "Programming Example: Determining the EVM".

Number of TSC bits depending on burst type and modulation
Burst Type | Modulation | Number of Bits
Normal | GMSK | 26
Normal | 8PSK | 78
Normal | 16QAM | 104
Normal | 32QAM | 130
Higher Symbol Rate | QPSK | 62
Higher Symbol Rate | 16QAM | 124
Higher Symbol Rate | 32QAM | 155
Access Burst | GMSK | 41


CONFigure[:MS]:CHANnel:SLOT<Number>:TYPE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Slot > CONFigure[:MS]:CHANnel:SLOT<Number>:TYPE
CONFigure[:MS]:CHANnel:SLOT<Number>:TYPE <BurstType>

Specifies the type of the burst.

Suffix:
<Number>
<0..7>
Parameters for setting and query:
<BurstType>
NB | HB | AB
NB

Normal Burst

HB

Higher Symbol Rate Burst

AB

Access Burst

*RST: NB
Example: CONF:CHAN:SLOT:TYPE NB
Manual operation: See "Burst Type"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


Carrier

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier
Carrier

The following commands are required to provide information on the carriers in the input signal.

List of Commands
CONFigure[:MS]:MCARrier:CARRier<c>[:STATe]?
CONFigure[:MS]:MCARrier:CARRier<c>:FREQuency
CONFigure[:MS]:MCARrier:CARRier<c>:MTYPe
CONFigure[:MS]:MCARrier:FALLocation
CONFigure[:MS]:MCARrier:FALLocation:NCONtiguous:GSACarrier


CONFigure[:MS]:MCARrier:CARRier<c>[:STATe]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier > CONFigure[:MS]:MCARrier:CARRier<c>[:STATe]?
CONFigure[:MS]:MCARrier:CARRier<c>[:STATe]?

This command queries the activity of the selected carrier.

Note: to activate a carrier, define its absolute frequency using CONFigure[:​MS]:​MCARrier:​CARRier<c>:​FREQuency.

Suffix:
<c>
1..16

Active carrier

Return values:
<State>
ON | OFF
*RST: OFF
Example: CONF:MCAR:CARR3?
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Usage: Query only
Manual operation: See "Active carriers"


CONFigure[:MS]:MCARrier:CARRier<c>:FREQuency

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier > CONFigure[:MS]:MCARrier:CARRier<c>:FREQuency
CONFigure[:MS]:MCARrier:CARRier<c>:FREQuency <AbsFreq>

This command defines or queries the absolute frequency of the selected carrier.

Suffix:
<c>
1..16

Active carrier

Parameters:
<AbsFreq>

Frequency in Hz

*RST: 0
Example:

CONF:MCAR:CARR3:FREQ 1GHZ

Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Frequency"


CONFigure[:MS]:MCARrier:CARRier<c>:MTYPe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier > CONFigure[:MS]:MCARrier:CARRier<c>:MTYPe
CONFigure[:MS]:MCARrier:CARRier<c>:MTYPe <Modulation>

This command defines or queries the burst type and modulation of the selected carrier.

Suffix:
<c>
1..16

Active carrier

Parameters:
<Modulation>

Frequency in Hz

AGMSk

Access burst, GMSK modulation

HN16qam

Higher symbol rate burst, narrow pulse, 16 QAM modulation

HN32qam

Higher symbol rate burst, narrow pulse, 32 QAM modulation

HNQPsk

Higher symbol rate burst, narrow pulse, QPSK modulation

HW16qam

Higher symbol rate burst, wide pulse, 16 QAM modulation

HW32qam

Higher symbol rate burst, wide pulse, 32 QAM modulation

HWQPsk

Higher symbol rate burst, wide pulse, 16 QPSK modulation

N16Qam

Normal burst, 16 QAM modulation

N32Qam

Normal burst, 32 QAM modulation

N8PSk

Normal burst, 8PSK modulation

NAQPsk

Normal burst, AQPSK modulation

NGMSk

Normal burst, GMSK modulation

*RST: NGMS
Example:

CONF:MCAR:CARR3:MTYP AQPS

Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Modulation"


CONFigure[:MS]:MCARrier:FALLocation

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier > CONFigure[:MS]:MCARrier:FALLocation
CONFigure[:MS]:MCARrier:FALLocation <Mode>

This command describes the measurement setup for multicarrier measurements.

Parameters:
<Mode>
CONTiguous

Setup contains one subblock of regularly spaced carriers only

NCONtiguous

Setup contains two subblocks of carriers with a gap inbetween.

The position of the gap between the subblocks must be defined using CONFigure[:​MS]:​MCARrier:​FALLocation:​NCONtiguous:​GSACarrier.

*RST: CONT
Example: CONF:MCAR:FALL NCON

Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Carrier Allocation"


CONFigure[:MS]:MCARrier:FALLocation:NCONtiguous:GSACarrier

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Signal Description > Carrier > CONFigure[:MS]:MCARrier:FALLocation:NCONtiguous:GSACarrier
CONFigure[:MS]:MCARrier:FALLocation:NCONtiguous:GSACarrier <CarrNo>

This command defines the position of the gap for non-contiguous setups (see CONFigure[:​MS]:​MCARrier:​FALLocation).

Parameters:
<CarrNo>

Number of the active carrier after which the gap starts.

Range: | 1..16
*RST: | 1
Example: CONF:MCAR:FALL:NCON:GSAC 7

Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Gap start after carrier (Non-contiguous carriers only)"


Input/Output Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings
Input/Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals). The following commands are required to configure data input and output.

Contents
  • RF Input
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Configuring the Outputs


RF Input

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed


INPut:COUPling

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Digital I/Q Input State"
See "Analog Baseband Input State"


Configuring Digital I/Q Input and Output

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO


INPut:DIQ:CDEVice

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:FULLscale[:LEVel]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:TYPE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Configuring the Outputs

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Input/Output Settings > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration
Frontend Configuration

The following commands are required to configure frequency and amplitude settings, which represent the "frontend" of the measurement setup.

Contents
  • Frequency
  • Amplitude Settings
  • Configuring the Attenuation


Frequency

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency
Frequency

The following commands are required to configure the frequencies to measure.

Useful commands for configuring frequencies described elsewhere:
  • CONFigure[:​MS]:​NETWork:​FREQuency:​BAND
  • CONFigure[:​MS]:​NETWork[:​TYPE]
Remote commands exclusive to configuring frequencies:
List of Commands
CONFigure[:MS]:ARFCn
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


CONFigure[:MS]:ARFCn

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency > CONFigure[:MS]:ARFCn
CONFigure[:MS]:ARFCn <Value>

This command specifies the Absolute Radio Frequency Channel Number (ARFCN) to be measured. Setting the ARFCN updates the frequency.

Parameters for setting and query:
<Value>
numeric value
Range: | 0 to 1023 (some values may not be allowed depending on the selected frequency band)
Default unit: | NONE
Example: CONF:ARFC 5
Manual operation: See "ARFCN"


[SENSe:]FREQuency:CENTer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

If you change the frequency, the R&S FSW updates the "ARFCN" accordingly.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center Frequency"


[SENSe:]FREQuency:CENTer:STEP

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings
Amplitude Settings

The following commands are required to configure the amplitude settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • CONFigure[:​MS]:​POWer:​CLASs
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

Manual operation: See "Per Division"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


INPut:GAIN:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Configuring the Attenuation

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Triggering Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements
Triggering Measurements

Trigger settings determine when the input signal is measured.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions

The following commands are required to configure the trigger for the GSM measurement.

List of Commands
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:DTIMe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V


TRIGger[:SEQuence]:LEVel:IFPower

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:RFPower:HOLDoff

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:RFPower:HOLDoff <Time>

This command defines the holding time before the next trigger event. Note that this command is available for any trigger source, not just RF Power.

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Time>
Default unit: S


TRIGger[:SEQuence]:SLOPe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "I/Q Power"
See "IF Power"
See "RF Power"
See "Trigger Source"


Configuring the Trigger Output

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Data Acquisition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition
Data Acquisition

You must define how much and how often data is captured from the input signal.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the GSM application in MSRA mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Contents
  • Data Acquisition
  • Configuring and Performing Sweeps


Data Acquisition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition
Data Acquisition

The "Data Acquisition" settings define how long data is captured from the input signal by the R&S FSW GSM application.

List of Commands
[SENSe:]SWAPiq
[SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME:AUTO
TRACe:IQ:SRATe?
TRACe:IQ:BWIDth?


[SENSe:]SWAPiq

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition > [SENSe:]SWAPiq
[SENSe:]SWAPiq <State>

This command defines whether or not the recorded IQ pairs should be swapped (I<->Q) before being processed. Swapping I and Q inverts the sideband.

This is useful if the DUT interchanged the I and Q parts of the signal; then the R&S FSW can do the same to compensate for it.

For GSM measurements: Try this function if the TSC can not be found.

Parameters:
<State>
ON

I and Q signals are interchanged

Inverted sideband, Q+j*I

OFF

I and Q signals are not interchanged

Normal sideband, I+j*Q

*RST: OFF
Manual operation: See "Swap I/Q"


[SENSe:]SWEep:TIME

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the data capture time.

Parameters:
<Time>
*RST: 0.1 (0.02 in MSRA mode)
Example: SWE:TIME 1s
Usage: SCPI confirmed
Manual operation: See "Capture Time"


[SENSe:]SWEep:TIME:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition > [SENSe:]SWEep:TIME:AUTO
[SENSe:]SWEep:TIME:AUTO <State>

If enabled, the capture time is determined according to the set statistic count with the objective to get a fast measurement.

If disabled, the capture time must be defined manually using [SENSe:​]SWEep:​TIME.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SWE:TIME:AUTO OFF
SWE:TIME 1s
Manual operation: See "Capture Time"


TRACe:IQ:SRATe?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition > TRACe:IQ:SRATe?
TRACe:IQ:SRATe?

This command queries the final user sample rate for the acquired I/Q data.

Parameters:
<SampleRate>

The sample rate is a fixed value, depending on the frequency range to be measured (see also "Modulation Spectrum Table: Frequency List").

Range: | 100 Hz to 10 GHz continuously adjustable;
*RST: | 32 MHz
Example:

See "Programming Example: Determining the EVM".

Usage: Query only
Manual operation: See "Sample rate"


TRACe:IQ:BWIDth?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Data Acquisition > TRACe:IQ:BWIDth?
TRACe:IQ:BWIDth?

This command queries the bandwidth of the resampling filter.

The bandwidth of the resampling filter depends on the sampling rate.

Usage: | Query only
Manual operation: | See "Analysis Bandwidth"


Configuring and Performing Sweeps

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps
Configuring and Performing Sweeps

The "Sweep" settings define how often data is captured from the input signal by the R&S FSW GSM application.

Useful commands for configuring sweeps described elsewhere:
  • [SENSe:​]SWEep:​TIME
  • INITiate:​REFResh
Remote commands exclusive to configuring and performing sweeps
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate:DISPlay
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
[SENSe]:BURSt:COUNt
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:TRGS:CURRent?


ABORt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate:DISPlay

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:DISPlay
INITiate:DISPlay <State>

This command turns the display update during single sweep measurements on and off.

Parameters:
<State>
ON | OFF
*RST: ON


INITiate[:IMMediate]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: | Event
Manual operation: | See "Sequencer State"


INITiate:SEQuencer:IMMediate

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event
Manual operation: See "Sequencer State"


INITiate:SEQuencer:MODE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Manual operation: See "Sequencer Mode"


[SENSe]:BURSt:COUNt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > [SENSe]:BURSt:COUNt
[SENSe]:BURSt:COUNt <Count>
[SENSe:]SWEep:COUNt <SweepCount>

These commands define the number of measurements the R&S FSW uses to average traces.

In case of continuous sweep measurements, the R&S FSW calculates the moving average over the "Statistic Count".

In case of single sweep measurements, the R&S FSW stops the measurement and calculates the average after "Statistic Count" measurements.

Parameters:
<SweepCount>

If you set a sweep count of 0 or 1, the R&S FSW performs one single measurement.

Range: | 0 to 32767
*RST: | 200
Example: SWE:COUN 64

Sets the number of measurements to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*OPC?

Starts a series of 64 measurements and waits till its end.

Usage: SCPI confirmed
Manual operation: See "Statistic Count"
See "Noise Average Count"


[SENSe:]SWEep:COUNt:CURRent?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This command returns the currently reached number of frames or measurements used for statistical evaluation. It can be used to track the progress of the averaging process until it reaches the set "Statistic Count" (see [SENSe:​]SWEep:​COUNt).

For Trigger to Sync measurements, use the [SENSe:​]SWEep:​COUNt:​TRGS:​CURRent? command to query the number of data acquisitions that contribute to the current result.

Usage: Query only


[SENSe:]SWEep:COUNt:TRGS:CURRent?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Data Acquisition > Configuring and Performing Sweeps > [SENSe:]SWEep:COUNt:TRGS:CURRent?
[SENSe:]SWEep:COUNt:TRGS:CURRent?

This command returns the currently reached number of data acquisitions that contribute to the Trigger to Sync result. It can be used to track the progress of the averaging process until it reaches the set "Statistic Count" (see [SENSe:​]SWEep:​COUNt).

For GSM measurements other than Trigger to Sync, use the [SENSe:​]SWEep:​COUNt:​CURRent? command to query the number of frames or measurements that contribute to the current result.

Usage: Query only


Demodulation

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation
Demodulation

Demodulation settings determine how frames and slots are detected in the input signal and which slots are to be evaluated.

The commands for frame and slot configuration are described in "Frame" and "Slot".

Contents
  • Slot Scope
  • Demodulation


Slot Scope

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Slot Scope
Slot Scope

The slot scope defines which slots are to be evaluated (see also "Defining the Scope of the Measurement").

List of Commands
CONFigure[:MS]:CHANnel:MSLots:MEASure
CONFigure[:MS]:CHANnel:MSLots:NOFSlots
CONFigure[:MS]:CHANnel:MSLots:OFFSet


CONFigure[:MS]:CHANnel:MSLots:MEASure

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Slot Scope > CONFigure[:MS]:CHANnel:MSLots:MEASure
CONFigure[:MS]:CHANnel:MSLots:MEASure <SlotToMeasure>

This command specifies the slot to be measured in single-slot measurements relative to the GSM frame boundary.

Parameters for setting and query:
<SlotToMeasure>

Slot to measure in single-slot measurements.

*RST: 0 Slots
Example: CONF:CHAN:MSL:MEAS 5
Manual operation: See "Slot to Measure"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:MSLots:NOFSlots

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Slot Scope > CONFigure[:MS]:CHANnel:MSLots:NOFSlots
CONFigure[:MS]:CHANnel:MSLots:NOFSlots <NofSlotsToMeas>

This command specifies the number of slots to measure for the measurement interval of multi-slot measurements, i.e. the "Power vs Time" and "Transient Spectrum" measurements. Between 1 and 8 consecutive slots can be measured.

Parameters for setting and query:
<NofSlotsToMeas>

Number of slots to measure.

Range: | 1 to 8
*RST: | 8 Slots
Example: CONF:CHAN:MSL:NOFS 5
Manual operation: See "Number of Slots to measure"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


CONFigure[:MS]:CHANnel:MSLots:OFFSet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Slot Scope > CONFigure[:MS]:CHANnel:MSLots:OFFSet
CONFigure[:MS]:CHANnel:MSLots:OFFSet <FirstSlotToMeas>

This command specifies the start for the measurement interval for multi-slot measurements, i.e. the "Power vs Time" and "Transient Spectrum" measurements, relative to the GSM frame boundary.

Parameters for setting and query:
<FirstSlotToMeas>

0-based index for the first slot to measure relative to the GSM frame start.

*RST: 0 Slots
Example: CONF:CHAN:MSL:OFFS 5
Manual operation: See "First Slot to measure"

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".


Demodulation

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation
Demodulation

The demodulation settings provide additional information to optimize frame, slot and symbol detection.

List of Commands
CONFigure[:MS]:SYNC:MODE
CONFigure[:MS]:SYNC:ONLY
CONFigure[:MS]:SYNC:IQCThreshold
CONFigure[:MS]:DEMod:DECision
CONFigure[:MS]:DEMod:STDBits


CONFigure[:MS]:SYNC:MODE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation > CONFigure[:MS]:SYNC:MODE
CONFigure[:MS]:SYNC:MODE <Mode>

This command sets the synchronization mode of the R&S FSW-K10.

Parameters for setting and query:
<Mode>
ALL | TSC | BURSt | NONE
ALL

First search for the power profile (burst search) according to the frame configuration in the capture buffer. Second, inside the found bursts search for the TSC of the "Slot to measure" as given in the frame configuration. "ALL" is usually faster than "TSC" for bursted signals.

TSC

Search the capture buffer for the TSC of the "Slot to measure" as given in the frame configuration. This mode corresponds to a correlation with the given TSC. This mode can be used for continous (but framed) signals or bursted signals.

BURSt

Search for the power profile (burst search) according to the frame configuration in the capture buffer.

Note: For "Burst" no demodulation measurements (e.g. "Modulation Accuracy") are supported. Only "Power vs Time", "Modulation Spectrum", "Transient Spectrum" measurements are supported.

NONE

Do not synchronize at all. If an external or power trigger is chosen, the trigger instant corresponds to the frame start.

Tip: Manually adjust the trigger offset to move the burst to be analyzed under the mask in the "Power vs Time" measurement.

Note: For "None" no demodulation measurements (e.g. "Modulation Accuracy") are supported. Only "Power vs Time", "Modulation Spectrum", "Transient Spectrum" measurements are supported.

*RST: ALL
Example: CONF:SYNC:MODE TSC
Manual operation: See "Synchronization"


CONFigure[:MS]:SYNC:ONLY

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation > CONFigure[:MS]:SYNC:ONLY
CONFigure[:MS]:SYNC:ONLY <State>

If activated, only results from frames (slots) where the "Slot to measure" was found are displayed and taken into account in the averaging of the results. The behavior of this function depends on the value of the"Synchronization" parameter (see CONFigure[:​MS]:​SYNC:​MODE).

Parameters for setting and query:
<State>
ON | OFF
*RST: ON
Example: CONF:SYNC:MODE TSC

Search the capture buffer for the TSC of the "Slot to measure" as given in the frame configuration.

CONF:SYNC:ONLY ON

Only if the TSC is found, the results are displayed.

Manual operation: See "Measure only on Sync"


CONFigure[:MS]:SYNC:IQCThreshold

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation > CONFigure[:MS]:SYNC:IQCThreshold
CONFigure[:MS]:SYNC:IQCThreshold <Value>

This command sets the IQ correlation threshold. The IQ correlation threshold decides whether a burst is accepted if "Measure only on Sync" is activated. If the correlation value between the ideal IQ signal of the given TSC and the measured TSC is below the IQ correlation threshold, then the application reports "Sync not found" in the status bar. Additionally, such bursts are ignored if "Measure only on Sync" is activated.

Parameters for setting and query:
<Value>
Range: | 0 to 100
*RST: | 85
Default unit: | NONE
Example: CONF:SYNC:IQCT 0
Manual operation: See "I/Q Correlation Threshold"


CONFigure[:MS]:DEMod:DECision

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation > CONFigure[:MS]:DEMod:DECision
CONFigure[:MS]:DEMod:DECision <Value>

This command determines how the symbols are detected in the demodulator. The setting of this parameter does not effect the demodulation of Normal Bursts with GMSK modulation.

For Normal Bursts with 8PSK, 16QAM, 32QAM or AQPSK modulation or Higher Symbol Rate Bursts with QPSK, 16QAM or 32QAM modulation use this parameter to get a trade-off between performance (symbol error rate of the K10) and measurement speed.

Parameters for setting and query:
<Value>
AUTO | LINear | SEQuence
AUTO

Automatically selects the symbol decision method.

LINear

Linear symbol decision: Uses inverse filtering (a kind of zero-forcing filter) and a symbol-wise decision method. This method is recommended for high symbol to noise ratios, but not for Higher Symbol Rate bursts with a narrow pulse. The inverse filter colors the noise inside the signal bandwidth and therefore is not recommended for narrow-band signals or signals with a low signal to noise ratio. Peaks in the "EVM vs Time" measurement (see "EVM") may occur if the "Linear" symbol decision algorithm fails. In that case use the "Sequence" method. Linear is the fastest option.

SEQuence

Symbol decision via sequence estimation. This method uses an algorithm that minimizes the symbol errors of the entire burst. It requires that the tail bits in the analyzed signal are correct. It has a better performance (lower symbol error rate) compared to the "Linear" method, especially at low signal to noise ratios, but with a loss of measurement speed. This method is recommended for normal bursts with 16QAM or 32QAM modulation and for Higher Symbol Rate bursts with a narrow pulse.

*RST: AUTO
Example:

// Use 'sequence estimator' for the symbol decision

CONFigure:MS:DEMod:DECision SEQuence

For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring an AQPSK Signal".

Manual operation: See "Symbol Decision"


CONFigure[:MS]:DEMod:STDBits

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Demodulation > Demodulation > CONFigure[:MS]:DEMod:STDBits
CONFigure[:MS]:DEMod:STDBits <Value>

The demodulator of the R&S FSW GSM application requires the bits of the burst (Tail, Data, TSC, Data, Tail) to provide an ideal version of the measured signal. The "Data" bits can be random and are typically not known inside the demodulator of the GSM application.

Parameters for setting and query:
<Value>
DETected | STD
DETected

The detected tail and TSC bits are used to construct the ideal signal.

STD

The standard tail and TSC bits (as set using CONFigure[:​MS]:​CHANnel:​SLOT<s>:​TSC) are used to construct the ideal signal.

Using the standard bits can be advantageous to verify whether the device under test sends the correct tail and TSC bits. Incorrect bits would lead to peaks in the "EVM vs Time" trace (see "EVM") at the positions of the incorrect bits.

*RST: DETected
Example:

// Replace detected Tail & TSC bits by the standard bits

CONFigure:MS:DEMod:STDBits STD

For a detailed example see "Programming Example: Determining the EVM".

Manual operation: See "Tail & TSC Bits"


Measurement

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement
Measurement

Measurement settings define how power or spectrum measurements are performed.

Contents
  • Power vs Time
  • Spectrum
  • Trigger to Sync


Power vs Time

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Power vs Time
Power vs Time

The "Power vs Time" filter is used to suppress out-of-band interference in the Power vs Time measurement (see "Power vs Time Filter").

List of Commands
CONFigure:BURSt:PTEMplate:FILTer
CONFigure:BURSt:PTEMplate:TALign


CONFigure:BURSt:PTEMplate:FILTer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Power vs Time > CONFigure:BURSt:PTEMplate:FILTer
CONFigure:BURSt:PTEMplate:FILTer <Type>

The PvT Filter controls the filter used to reduce the measurement bandwidth for "Power vs Time" measurements.

The PvT filter is optimized to get smooth edges after filtering burst signals and to suppress adjacent, active channels.

Depending on the device type (single carrier or multicarrier, see CONFigure[:​MS]:​DEVice:​TYPE), different PvT filters are supported.

Parameters for setting and query:
<Type>
G1000

Default for single carrier device, Gaussian Filter, 1000 kHz

B600

(single carrier only) Gaussian Filter, 600 kHz

G500

(single carrier only) Gaussian Filter, 500 kHz

MC400

Recommended for measurements with multi channels of equal power.

MC300

Recommended for measurement scenarios where a total of six channels is active and the channel to be measured has a reduced power (e.g. 30 dB) compared to its adjacent channels.

*RST: G1000 (single carrier), MC400 (multicarrier)
Example: CONF:BURS:PTEM:FILT G500
Manual operation: See "Power vs Time Filter"

For a detailed example see "Programming Example: Determining the EVM".


CONFigure:BURSt:PTEMplate:TALign

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Power vs Time > CONFigure:BURSt:PTEMplate:TALign
CONFigure:BURSt:PTEMplate:TALign <Mode>

This command controls the time-alignment of the limit lines for the "Power vs Time" measurement (see "PvT Full Burst").

Parameters for setting and query:
<Mode>
STMeasure | PSLot
STMeasure

For each slot the mid of TSC is derived from the measured mid of TSC of the "Slot to measure" and the timeslot lengths specified in the standard (see "Timeslot length" in 3GPP TS 45.010).

PSLot

For each slot the mid of TSC is measured. This provides reasonable time-alignment if the slot lengths are not according to standard. However, the "Power vs Time" limit check is also passed.

*RST: STMeasure
Example:

CONF:BURS:PTEM:TAL PSL

Manual operation: See "Limit Line Time Alignment"

For a detailed example see "Programming Example: Determining the EVM".


Spectrum

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum
Spectrum

The modulation and transient spectrum measurements allow for further configuration.

List of Commands
CONFigure:SPECtrum:LIMit:LEFT
CONFigure:SPECtrum:LIMit:RIGHt
CONFigure:SPECtrum:SWITching:TYPE
CONFigure:SPECtrum:SWITching:LIMIT
CONFigure:SPECtrum:MODulation:LIMIT
CONFigure:WSPectrum:MODulation:LIST:SELect
[SENSe:]BANDwidth[:RESolution]:TYPE
READ:WSPectrum:MODulation:GATing?


CONFigure:SPECtrum:LIMit:LEFT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:SPECtrum:LIMit:LEFT
CONFigure:SPECtrum:LIMit:LEFT <State>

This command controls the left limit check of the spectrum trace (spectrum graph measurement) and which offset frequencies in the table (spectrum list measurement) are checked against the limit. This command affects the "Modulation Spectrum" and "Transient Spectrum" measurements.

Note: For measurements on multicarrier signals, use either the check on the left or right side to measure the spectrum of the left- or right-most channel and to ignore the side where adjacent channels are located.

Parameters for setting and query:
<State>
1 | 0 | ON | OFF
1 | ON

check limit

0 | OFF

do not check limit

*RST: 1
Example: CONF:SPEC:LIM:LEFT OFF
Manual operation: See "Enable Left Limit/ Enable Right Limit"


CONFigure:SPECtrum:LIMit:RIGHt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:SPECtrum:LIMit:RIGHt
CONFigure:SPECtrum:LIMit:RIGHt <State>

This command controls the right limit check of the spectrum trace (spectrum graph measurement) and which offset frequencies in the table (spectrum list measurement) are checked against the limit. This command affects the "Modulation Spectrum" and "Transient Spectrum" measurements.

Note: For measurements on multicarrier signals, use either the check on the left or right side to measure the spectrum of the left- or right-most channel and to ignore the side where adjacent channels are located.

Parameters for setting and query:
<State>
1 | 0 | ON | OFF
1 | ON

check limit

0 | OFF

do not check limit

*RST: 1
Example: CONF:SPEC:LIM:LEFT OFF
Manual operation: See "Enable Left Limit/ Enable Right Limit"


CONFigure:SPECtrum:SWITching:TYPE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:SPECtrum:SWITching:TYPE
CONFigure:SPECtrum:SWITching:TYPE <DetectorMode>

This command is retained for compatibility with R&S FSW-K5 only.

Parameters for setting and query:
<DetectorMode>
PEAK | RMS
*RST: RMS
Example:

CONFigure:SPECtrum:SWITching:TYPE?

Manual operation: See "Transient Spectrum: Reference Power"


CONFigure:SPECtrum:SWITching:LIMIT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:SPECtrum:SWITching:LIMIT
CONFigure:SPECtrum:SWITching:LIMIT <Mode>

This command selects whether the list results (power and limit values) of the "Transient Spectrum" measurement are returned in a relative (dB) or absolute (dBm) unit. This command is only available when the "Transient Spectrum" measurement is selected (see CONFigure:​SPECtrum:​SWITching[:​IMMediate]).

Parameters for setting and query:
<Mode>
ABSolute | RELative
*RST: RELative
Example:

// Select Transient Spectrum measurement

// (measurement on captured I/Q data)

CONFigure:SPECtrum:SWITching:IMMediate

// Only list results are required

CONFigure:SPECtrum:SELect LIST

// Absolute power and limit results in dBm

CONFigure:SPECtrum:SWITching:LIMit ABSolute

// Run one measurement and query absolute list results

READ:SPECtrum:SWITching:ALL?

// -> 0,933200000,933200000,-101.55,-36.00,ABS,PASSED, ...


CONFigure:SPECtrum:MODulation:LIMIT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:SPECtrum:MODulation:LIMIT
CONFigure:SPECtrum:MODulation:LIMIT <Mode>

This command selects whether the list results (power and limit values) of the "Modulation Spectrum" measurement are returned in a relative (dB) or absolute (dBm) unit. This command is only available when the "Modulation Spectrum" measurement is selected (see LAYout:​ADD[:​WINDow]?.

Parameters for setting and query:
<Mode>
ABSolute | RELative
*RST: RELative
Example:

// Absolute power and limit results in dBm

CONFigure:SPECtrum:MODulation:LIMit ABSolute

// Run one measurement and query absolute list results

READ:SPECtrum:MODulation:ALL?

// -> 0,933200000,933200000,-108.66,-65.00,ABS,PASSED, ...

For a detailed example see "Programming Example: Determining the EVM".


CONFigure:WSPectrum:MODulation:LIST:SELect

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > CONFigure:WSPectrum:MODulation:LIST:SELect
CONFigure:WSPectrum:MODulation:LIST:SELect <Mode>

For "Modulation Spectrum Table" measurements, this command controls whether offset frequencies are measured up to 1800 kHz or 5800 kHz.

Parameters for setting and query:
<Mode>
NARRow

The frequency list comprises offset frequencies up to 1.8 MHz from the carrier. The sample rate is 6.5 MHz.

NSParse

More compact version of "NARRow". The sample rate is 6.5 MHz.

WIDE

The frequency list comprises offset frequencies up to 6 MHz from the carrier. The sample rate is 19.5 MHz.

WSParse

More compact version of WIDE. The sample rate is 19.5 MHz.

*RST: WIDE
Example: CONFigure:WSPectrum:MODulation:LIST:SELect NARRow
Manual operation: See "Modulation Spectrum Table: Frequency List"

For a detailed example see "Programming Example: Determining the EVM".


[SENSe:]BANDwidth[:RESolution]:TYPE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > [SENSe:]BANDwidth[:RESolution]:TYPE
[SENSe:]BANDwidth[:RESolution]:TYPE <Type>

This command switches the filter type for the resolution filter for the "Modulation Spectrum", "Transient Spectrum" and "Wide Modulation Spectrum" measurement.

Parameters for setting and query:
<Type>
NORMal | P5
NORMal

Gaussian filter with a 3 dB bandwidth of either 30 kHz or 100 kHz. This value is retained for compatibility with R&S FS-K5 only.

P5

5 Pole filter with a 3 dB bandwidth of either 30 kHz or 100 kHz. This filter is required by the GSM standard specification.

*RST: P5
Example: BAND:TYPE NORM
Manual operation: See "Filter Type"


READ:WSPectrum:MODulation:GATing?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Spectrum > READ:WSPectrum:MODulation:GATing?
READ:WSPectrum:MODulation:GATing?

This command reads out the gating settings for gated "Modulation Spectrum" measurements (see "Modulation Spectrum Table").

The returned values can be used to set the gating interval for "list" measurements (i.e. a series of measurements in zero span mode at several offset frequencies). This is done in the "Spectrum" mode using the SENSe:LIST subsystem (see [SENSe:]LIST:POWer:SET).

Prior to this command make sure you set the correct Trigger Mode ("IF power" or "External") and Trigger Offset (see "Triggering Measurements").

Return values:
<TriggerOffset> | Calculated trigger offset, based on the user-defined "Trigger Offset" and "Frame Configuration", such that 50-90% of the active part of the "Slot to measure" (excluding TSC) is measured.
<GateLength> | Calculated gate length, based on the user-defined "Trigger Offset" and "Frame Configuration", such that 50-90% of the active part of the "Slot to measure" (excluding TSC) is measured.
Example: | READ:WSP:MOD:GAT? Result: 0.00032303078,0.00016890001
Usage: | Query only


Trigger to Sync

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Trigger to Sync
Trigger to Sync
List of Commands
CONFigure:TRGS:NOFBins
CONFigure:TRGS:ADPSize


CONFigure:TRGS:NOFBins

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Trigger to Sync > CONFigure:TRGS:NOFBins
CONFigure:TRGS:NOFBins <Value>

This command specifies the number of bins for the histogram of the "Trigger to Sync" measurement.

Parameters for setting and query:
<Value>
numeric value

Number of bins

Range: | 10 to 1000
*RST: | 10
Default unit: | NONE
Manual operation: See "No. of Bins"


CONFigure:TRGS:ADPSize

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Measurement > Trigger to Sync > CONFigure:TRGS:ADPSize
CONFigure:TRGS:ADPSize <Value>

This command specifies the number of measurements after which the x-axis is fixed for the histogram calculation of the "Trigger to Sync" measurement.

Parameters for setting and query:
<Value>
numeric value

Adaptive data size

Range: | 10 to 1000
*RST: | 100
Default unit: | NONE
Manual operation: See "Adaptive Data Size"


Adjusting Settings Automatically

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

List of Commands
CONFigure[:MS]:AUTO:FRAMe ONCE
CONFigure[:MS]:AUTO:LEVel ONCE
CONFigure[:MS]:AUTO:TRIGger ONCE
CONFigure[:MS]:POWer:AUTO:SWEep:TIME
[SENSe:]ADJust:FREQuency


CONFigure[:MS]:AUTO:FRAMe ONCE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically > CONFigure[:MS]:AUTO:FRAMe ONCE
CONFigure[:MS]:AUTO:FRAMe ONCE <Value>

This command automatically performs a single measurement to detect the optimal frame configuration (i.e. frame and slot parameters) depending on the current measurement settings and results.

This function is not available in MSRA mode if the Sequencer is active.

Note that in Signal and Spectrum Analyzer mode, if the Sequencer is active, this command cannot be aborted via the ABORt command!

Example: | CONF:AUTO:FRAM ONCE
Manual operation: | See "Automatic Frame Configuration"


CONFigure[:MS]:AUTO:LEVel ONCE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically > CONFigure[:MS]:AUTO:LEVel ONCE
CONFigure[:MS]:AUTO:LEVel ONCE

This command is used to perform a single measurement to detect the required level automatically.

This command is not available in MSRA mode.

Note that this command cannot be aborted via the ABORt command!

Example: | CONF:AUTO:LEV ONCE
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


CONFigure[:MS]:AUTO:TRIGger ONCE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically > CONFigure[:MS]:AUTO:TRIGger ONCE
CONFigure[:MS]:AUTO:TRIGger ONCE

This command is used to perform a single measurement that determines the trigger offset automatically.

This command is not available in MSRA mode.

Note that in Signal and Spectrum Analyzer mode, if the Sequencer is active, this command cannot be aborted via the ABORt command! This can lead to a hang up situation when no trigger signal is available or the trigger level is not set correctly. Use a device clear to abort the operation correctly.

Example: | CONF:AUTO:TRIG ONCE
Usage: | Setting only
Manual operation: | See "Automatic Trigger Offset"


CONFigure[:MS]:POWer:AUTO:SWEep:TIME

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically > CONFigure[:MS]:POWer:AUTO:SWEep:TIME
CONFigure[:MS]:POWer:AUTO:SWEep:TIME <Value>

This command is used to specify the auto track time, i.e. the capture time for auto detection.

This setting can currently only be defined in remote control, not in manual operation.

Tip: increase this value if less than every second GSM frame contains a signal.

Parameters for setting and query:
<Value>
numeric value

Auto level measurement sweep time

Range: | 0.01 to 1
*RST: | 0.1 s
Default unit: | S
Example: CONF:POW:AUTO:SWE:TIME 0.01 MS


[SENSe:]ADJust:FREQuency

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing GSM I/Q Measurements > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This function adjusts the center frequency and "ARFCN" (I/Q mode only) automatically.

For multicarrier measurements, all carrier settings are automatically adjusted (see "Carrier Settings").

This command is not available when using the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


Configuring and Performing MCWN Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements
Configuring and Performing MCWN Measurements

A new separate measurement is provided by the R&S FSW GSM application to determine the wideband noise in multicarrier measurement setups (see "Multicarrier Wideband Noise Measurements").

Contents
  • Signal Description
  • Input/Output and Frontend Settings
  • Triggering Measurements
  • Configuring the Reference Measurement
  • Configuring the Noise Measurement
  • Adjusting Settings Automatically
  • Performing Sweeps


Signal Description

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Signal Description
Signal Description
The commands required for signal description are described in:
  • "Device under Test Settings"
  • "Carrier"


Input/Output and Frontend Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings
Input/Output and Frontend Settings
The commands required for input, output and amplitude settings are described in:
  • "RF Input"
  • "Configuring the Outputs"
  • "Amplitude Settings"
Contents
  • Frequency Settings


Frequency Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings > Frequency Settings
Frequency Settings

The frequency span to be measured can be defined using a start and stop frequency, or a center frequency and span; alternatively, it can be set to a specific characteristic value automatically.

Useful commands for frequency settings described elsewhere:
  • CONFigure[:​MS]:​ARFCn
  • [SENSe:​]FREQuency:​CENTer
  • [SENSe:​]FREQuency:​CENTer:​STEP
  • [SENSe:​]FREQuency:​OFFSet
Remote commands exclusive to frequency settings in MCWN measurements
List of Commands
[SENSe:]FREQuency:SPAN
SENSe:FREQuency:SPAN:MODE
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP


[SENSe:]FREQuency:SPAN

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings > Frequency Settings > [SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN <Span>

This command defines the frequency span.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Span"


SENSe:FREQuency:SPAN:MODE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings > Frequency Settings > SENSe:FREQuency:SPAN:MODE
SENSe:FREQuency:SPAN:MODE <Mode>

This command sets the span for the MCWN measurement to a predefined value.

Parameters:
<Mode>
TXBand

The span for the MCWN measurement is set to the TX band ±2 MHz (for single carrier BTS or MS) or ±10 MHz (for multicarrier BTS device types).

CNARrow

The span is set to the span of the active carriers, plus a margin of 1.8 MHz to either side.

This setting is suitable for narrowband noise measurements.

CWIDe

The span is set to the span of the active carriers, plus a margin of 6 MHz to either side.

This setting is suitable for wideband noise and intermodulation measurements.

MANual

the frequency span is defined by a start and stop frequency, or a center frequency and span.

*RST: TXB
Example: FREQ:SPAN:MODE MAN
FREQ:SPAN:STAR 9150000
FREQ:SPAN:STOP 970000000
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Setting the Span to Specific Values Automatically"


[SENSe:]FREQuency:STARt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings > Frequency Settings > [SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STARt <Frequency>
Parameters:
<Frequency>
0 to (fmax - min span)
*RST: 0
Example: FREQ:STAR 20MHz
Usage: SCPI confirmed
Manual operation: See "Start / Stop"


[SENSe:]FREQuency:STOP

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Input/Output and Frontend Settings > Frequency Settings > [SENSe:]FREQuency:STOP
[SENSe:]FREQuency:STOP <Frequency>
Parameters:
<Frequency>
min span to fmax
*RST: fmax
Example: FREQ:STOP 2000 MHz
Usage: SCPI confirmed
Manual operation: See "Start / Stop"


Triggering Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Triggering Measurements
Triggering Measurements
The commands for triggering measurements are described in:
  • "Triggering Measurements"


Configuring the Reference Measurement

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement
Configuring the Reference Measurement

Reference power levels can either be defined manually or determined automatically by a reference measurement prior to the noise measurement. the following commands are required to configure the reference measurement.

List of Commands
CONFigure:SPECtrum:MODulation:REFerence:AVERage:COUNt
CONFigure:SPECtrum:MODulation:REFerence:CARRier[:AUTO]
CONFigure:SPECtrum:MODulation:REFerence:CARRier:NUMBer
CONFigure:SPECtrum:MODulation:REFerence:MEASure
CONFigure:SPECtrum:MODulation:REFerence:PLEVel
CONFigure:SPECtrum:MODulation:REFerence:RPOWer


CONFigure:SPECtrum:MODulation:REFerence:AVERage:COUNt

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:AVERage:COUNt
CONFigure:SPECtrum:MODulation:REFerence:AVERage:COUNt <Number>

This command defines the number of reference measurements to be performed in order to determine the average reference values.

This value is ignored if no reference measurement is performed (see CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure).

Parameters:
<Number>
integer value
Range: | 1..32767
*RST: | 10
Example: CONF:SPEC:MOD:REF:AVER:COUN 5
Manual operation: See "Reference Average Count"


CONFigure:SPECtrum:MODulation:REFerence:CARRier[:AUTO]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:CARRier[:AUTO]
CONFigure:SPECtrum:MODulation:REFerence:CARRier[:AUTO] <State>

This command specifies whether the carrier at which the reference powers for the MCWN measurement are measured is selected automatically (if reference power measurement is enabled, see CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure).

Parameters:
<State>
ON | OFF
ON

The carrier with the maximum power level is selected as a reference.

OFF

The carrier to be used as a reference must be specified using CONFigure:​SPECtrum:​MODulation:​REFerence:​CARRier:​NUMBer.

*RST: ON
Example: CONF:SPEC:MOD:REF:MEAS ON
CONF:SPEC:MOD:REF:CARR:AUTO OFF
CONF:SPEC:MOD:REF:CARR:AUTO:NUMB 2
Manual operation: See "Carrier Selection / Carrier"


CONFigure:SPECtrum:MODulation:REFerence:CARRier:NUMBer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:CARRier:NUMBer
CONFigure:SPECtrum:MODulation:REFerence:CARRier:NUMBer <CarrNo>

This command specifies the carrier at which the reference powers for the MCWN measurement are measured (if reference power measurement is enabled, see CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure).

Parameters:
<CarrNo>

Number of the active carrier after which the gap starts.

Range: | 1..16
*RST: | 1
Example: CONF:SPEC:MOD:REF:MEAS ON
CONF:SPEC:MOD:REF:CARR:AUTO OFF
CONF:SPEC:MOD:REF:CARR:AUTO:NUMB 2
Manual operation: See "Carrier Selection / Carrier"


CONFigure:SPECtrum:MODulation:REFerence:MEASure

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:MEASure
CONFigure:SPECtrum:MODulation:REFerence:MEASure <State>

This command specifies whether a reference power measurement is performed.

Parameters:
<State>
ON | OFF
ON

The reference powers of all active carriers are measured for MCWN measurements.

OFF

the reference powers must be defined manually (see CONFigure:​SPECtrum:​MODulation:​REFerence:​PLEVel).

*RST: ON
Example: CONF:SPEC:MOD:REF:MEAS OFF

Manual operation: See "Enabling a reference power measurement ( Measure )"
See "Defining Reference Powers Manually"


CONFigure:SPECtrum:MODulation:REFerence:PLEVel

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:PLEVel
CONFigure:SPECtrum:MODulation:REFerence:PLEVel <Level>

This command defines the reference power level for MCWN measurements (if no reference measurement is performed, see CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure).

Parameters:
<Level>

power level in dBm

*RST: 0.00
Example: CONF:SPEC:MOD:REF:MEAS OFF
CONF:SPEC:MOD:REF:PLEV 35
Manual operation: See "Power Level"


CONFigure:SPECtrum:MODulation:REFerence:RPOWer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Reference Measurement > CONFigure:SPECtrum:MODulation:REFerence:RPOWer
CONFigure:SPECtrum:MODulation:REFerence:RPOWer <RBW>,<Level>

This command defines the reference power level using different RBWs for MCWN measurements (if no reference measurement is performed, see CONFigure:​SPECtrum:​MODulation:​REFerence:​MEASure).

The query returns the measured values and is only available if a reference measurement is performed.

Parameters:
<Level>

reference power level in dBm (without a unit!)

Parameters for setting and query:
<RBW>
RBW in Hz
30e3

Reference power for RBW = 30 kHz

100e3

Reference power for RBW = 100 kHz

300e3

Reference power for RBW = 300 kHz

Example:
CONF:SPEC:MOD:REF:MEAS OFF
CONF:SPEC:MOD:REF:PLEV        35
CONF:SPEC:MOD:REF:RPOW 300e3, 34.7
CONF:SPEC:MOD:REF:RPOW 100e3, 32.8
CONF:SPEC:MOD:REF:RPOW  30e3, 27.2
Example: CONF:SPEC:MOD:REF:MEAS ON
CONF:SPEC:MOD:REF:RPOW? 30e3

Queries the measured reference power level for an RBW of 30 kHz.

Manual operation: See "Ref Power (RBW 300 kHz)"
See "Ref Power (RBW 100 kHz)"
See "Ref Power (RBW 30 kHz)"


Configuring the Noise Measurement

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Noise Measurement
Configuring the Noise Measurement

The noise measurement can provide various results. The follwoing commands are required to configure the noise measurement.

Useful commands for configuring noise measurements described elsewhere:
  • [SENSe:​]SWEep:​COUNt
Remote commands exclusive to configuring noise measurements:
List of Commands
CONFigure:SPECtrum:IMPorder
CONFigure:SPECtrum:LIMit:EXCeption[:STATe]
CONFigure:SPECtrum:NWIDe


CONFigure:SPECtrum:IMPorder

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Noise Measurement > CONFigure:SPECtrum:IMPorder
CONFigure:SPECtrum:IMPorder <Order>

This command defines for which order of intermodulation products the noise measurement determines the level.

Parameters:
<Order>
0 | 3 | 3,5
0

No intermodulation products are measured.

3

IM products order of 3 are measured

3,5

IM products order of 3 and 5 are measured

*RST: 3,5
Example: CONF:SPEC:IMP 3
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Intermodulation"


CONFigure:SPECtrum:LIMit:EXCeption[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Noise Measurement > CONFigure:SPECtrum:LIMit:EXCeption[:STATe]
CONFigure:SPECtrum:LIMit:EXCeption[:STATe] <State>

If enabled, exceptions from the limit line check as defined in the 3GPP standard are applied to the limit checks of the MCWN measurements.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CONF:SPEC:LIM:EXC OFF
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Adapting the limit lines for wideband noise ( Apply Exceptions )"


CONFigure:SPECtrum:NWIDe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Configuring the Noise Measurement > CONFigure:SPECtrum:NWIDe
CONFigure:SPECtrum:NWIDe <State>

If enabled, wideband noise is measured as part of the MCWN measurement. Wideband noise is measured with an RBW of 100 kHz over the defined span (typically the RF bandwidth).

Parameters:
<State>
ON | OFF
*RST: ON
Example: CONF:SPEC:NWID OFF
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Manual operation: See "Wideband Noise (≥1.8 MHz)"


Adjusting Settings Automatically

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Adjusting Settings Automatically
Adjusting Settings Automatically
The commands required to adjust settings automatically are described in:
  • "Adjusting Settings Automatically"


Performing Sweeps

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Configuring and Performing MCWN Measurements > Performing Sweeps
Performing Sweeps
The commands required to perform sweeps are described in:
  • "Configuring and Performing Sweeps"


Analyzing GSM Measurements

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements
Analyzing GSM Measurements

General analysis settings and functions concerning the trace, markers, windows etc. are available for GSM measurement results.

Contents
  • Configuring the Result Display
  • Result Config
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Zooming into the Display


Configuring the Result Display

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display
Configuring the Result Display

The commands required to configure the screen display in a remote environment are described here.

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:TYPe?


LAYout:ADD[:WINDow]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example: LAY:ADD:WIND? '1',RIGH,MACC

Adds a Modulation Accuracy display to the right of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Constellation"
See "EVM"
See "Magnitude Capture"
See "Magnitude Error"
See "Marker Table"
See "Modulation Accuracy"
See "Modulation Spectrum Graph"
See "Modulation Spectrum Table"
See "Phase Error"
See "Power vs Slot"
See "PvT Full Burst"
See "Transient Spectrum Graph"
See "Transient Spectrum Table"
See "Trigger to Sync Graph"
See "Trigger to Sync Table"
See "Spectrum Graph"
See "Carrier Power Table"
See "Outer IM Table"
See "Inner IM Table"

For a detailed example see "Programming Example: Determining the EVM".

<WindowType> parameter values for GSM application
Parameter value | Window type
Default I/Q (Modulation Accuracy,...) measurement:
CONStell | Constellation
ETIMe | EVM vs Time
MCAPture | Magnitude Capture
MERRor | Magnitude Error vs Time
MTABle | Marker Table
MACCuracy | Modulation Accuracy
MSFDomain | Modulation Spectrum Graph (Frequency domain)
MSTable | Modulation Spectrum Table
PERRor | Phase Error vs Time
PSTable | Power vs Slot
PTFull | PvT Full Burst
TGSGraph | Trigger vs Sync Graph
TGSTable | Trigger to Sync Table
TSFDomain | Transient Spectrum Graph (Frequency domain)
TSTable | Transient Spectrum Table
Multicarrier wideband noise measurement:
IIMProducts | Inner IM Table
OIMProducts | Outer IM Table
WSFDomain | Spectrum Graph
WSRPower | Carrier Power Table


LAYout:CATalog[:WINDow]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


LAYout:WINDow<n>:TYPe?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:TYPe?
LAYout:WINDow<n>:TYPe?

Queries the window type of the window specified by the index <n>. For a list of possible window types see LAYout:​ADD[:​WINDow]?.

Example: | LAY:WIND2:TYPE? Response: MACC Modulation accuracy
Usage: | Query only


Result Config

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config
Result Config

Some evaluation methods require or allow for additional settings to configure the result display. Note that the available settings depend on the selected window.

Contents
  • Traces
  • Marker
  • Scaling


Traces

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Traces
Traces

The number of available traces depends on the selected window (see "Specifics for"). Only graphical evaluations have trace settings.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>:MODE


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


DISPlay[:WINDow<n>]:TRACe<t>:MODE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command controls whether a trace is displayed or not, and in which mode. Each trace can only display a certain mode, or nothing at all ("Blank"). table "Available traces and trace modes for the result diplays" below indicates which measurements can display which traces and which trace modes.

Note: even if a trace is not displayed, the results can still be queried (see TRACe<n>[:​DATA]?).

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Basics on Setting up Traces" .

Parameters:
<Mode>
AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

BLANk

Hides the selected trace.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

PDFavg

The probability density function (PDF) of the average value.

WRITe

Overwrite mode: the trace is overwritten by each sweep.

Example:

// Preset the instrument

*RST

// Enter the GSM option K10

INSTrument:SELect GSM

// Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

// Modulation spectrum graph measurement

LAY:ADD:WIND? '1',RIGH,MSFD

//Result: 2

INITiate:IMMediate

// Switch off the display of all available traces

DISPlay:WINDow2:TRACe1:MODE BLANk
DISPlay:WINDow2:TRACe2:MODE BLANk

// Switch on the display of all available traces again

DISPlay:WINDow2:TRACe1:MODE AVERage
DISPlay:WINDow2:TRACe2:MODE WRITe
Manual operation: See "Trigger to Sync Graph"
See "Trace Mode"
Available traces and trace modes for the result diplays
Measurement | Trace 1 | Trace 2 | Trace 3 | Trace 4
Magnitude Capture | WRITe | - | - | -
EVM Phase Error Magnitude Error PvT Full Burst | AVERage | MAXHold | MINHold | WRITe
Modulation Spectrum Graph Transient Spectrum Graph | AVERage | WRITe | - | -
Trigger to Sync | WRITe | PDFavg | - | -


Marker

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker
Marker

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display. Up to 4 markers can be configured.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Positioning Settings


Individual Marker Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings
Individual Marker Settings

In GSM evaluations, up to 4 markers can be activated in each diagram at any time. the following commandas are required to configure the markers.

List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:TRACe


CALCulate<n>:DELTamarker:AOFF

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:MARKer<m>[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:AOFF

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>:TRACe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Individual Marker Settings > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 4 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


General Marker Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > General Marker Settings
General Marker Settings

The following commands define general settings for all markers.

List of Commands
DISPlay:MTABle


DISPlay:MTABle

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Marker Positioning Settings

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings
Marker Positioning Settings

The following commands are required to set a specific marker to the result of a peak search.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]


CALCulate<n>:MARKer<m>:MAXimum:APEak

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum:APEak

sets the marker to the largest absolute peak value (maximum or minimum) of the selected trace.

Usage: | Event
Manual operation: | See "Max |Peak|"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MAXimum:APEak

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum:APEak

This command positions the active marker or deltamarker on the largest absolute peak value (maximum or minimum) of the selected trace.

Usage: Event


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Marker > Marker Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


Scaling

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling
Scaling

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These commands are described here.

List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO <State>

If enabled, the Y-axis is scaled automatically according to the current measurement.

Parameters for setting and query:
<State>
OFF

Switch the function off

ON

Switch the function on

*RST: ON
Manual operation: See "Automatic Grid Scaling"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Position"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Ref Value"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum <Value>

This command defines the maximum value on the y-axis in the specified window.

Parameters:
<Value>
numeric value
Default unit: dBm


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Result Config > Scaling > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum <Value>

This command defines the minimum value on the y-axis in the specified window.

Parameters:
<Value>
numeric_value
Default unit: dBm


Configuring an Analysis Interval and Line (MSRA mode only)

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the GSM application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the GSM measurement.

Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:MIVal?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON


CALCulate:MSRA:ALINe[:VALue]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s


CALCulate:MSRA:WINDow<n>:IVAL?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


CALCulate:MSRA:WINDow<n>:MIVal?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:MIVal?
CALCulate:MSRA:WINDow<n>:MIVal?

This command queries the individual analysis intervals in the window specified by the index <n>. This command is only available for GSM measurement channels (R&S FSW-K10) in MSRA mode, and only for result displays that display traces with a history, i.e. maxhold, minhold or average traces.

The result is a comma-separated list of <IntStart>,<IntStop> values for each interval.

Return values:
<IntStart>

Start value of the analysis interval in seconds (global time scale)

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds (global time scale)

Example: CALC:MSRA:WIND2:MIV?

//Result:

+3.707922995E-003,+4.509000108E-003,+8.323308080E-003,+9.124384262E-003,+1.293869223E-002,+1.373976935E-002
Usage: Query only


INITiate:REFResh

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA mode, not the MSRA Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


[SENSe:]MSRA:CAPTure:OFFSet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Zooming into the Display

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Analyzing GSM Measurements > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Retrieving Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results from the GSM measurements.

Contents
  • Graphical Results
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Magnitude Capture Results
  • Modulation Accuracy Results
  • Modulation Spectrum Results
  • Power vs Slot Results
  • Transient Spectrum Results
  • Trigger to Sync Results
  • Limit Check Results
  • MCWN Results
  • Retrieving Marker Results


Graphical Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results
Graphical Results

The results of the trace queries depend on the selected evaluation (see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>").

List of Commands
FORMat[:DATA]
FORMat:DEXPort:DSEParator
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:X?
TRACe:IQ:DATA:MEMory?


FORMat[:DATA]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


FORMat:DEXPort:DSEParator

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.


TRACe<n>[:DATA]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <TraceNumber>

This command reads trace data out of the window specified by the suffix <n>. This command is only available for graphical result displays.

The returned values are scaled in the current level unit. The data format depends on FORMat[:​DATA].

For Constellation diagrams, the result is a vector of I/Q values for the measured points in the diagram. The result is returned as a list of (I,Q) value pairs.

Query parameters:
<TraceNumber> | TRACe1 | TRACe2 | TRACe3 | TRACe4 Trace name to be read out TRACe1 Average trace; (transient spectrum: Maximum trace) TRACe2 Maximum trace TRACe3 Minimum trace TRACe4 Current trace
Example: | TRAC1:DATA? TRACe1
Usage: | Query only
Manual operation: | See "EVM" See "Magnitude Capture" See "Magnitude Error" See "Modulation Spectrum Graph" See "Phase Error" See "PvT Full Burst" See "Transient Spectrum Graph" See "Trigger to Sync Graph" See "Spectrum Graph"

For a detailed example see "Programming Example: Determining the EVM".


TRACe<n>[:DATA]:X?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command reads the x-values (time in seconds) of the "Power vs Time" measurement (if active) out of the window specified by the suffix <n>.

If a trace number is defined as a parameter for this command, the x-values (time in seconds) of the "Trigger to Sync" measurement (if active) out of the window specified by the suffix <n> are returned.

For details see "Trigger to Sync Results".

Query parameters:
<TraceNumber> | TRACe1 | TRACe2 | TRACe3 | TRACe4 Trace number TRACe1 Average trace; (Transient Spectrum: Maximum trace, Trigger to Sync: histogram values) TRACe2 Maximum trace (Trigger to Sync: PDF of average trace) TRACe3 Minimum trace TRACe4 Current trace
Example: | TRACe2:DATA:X? Returns the Power vs Time values for the active trace in window 2. TRACe3:DATA:X? TRACe1 Returns the Trigger to Sync values for trace 1 in window 3.
Usage: | Query only
Manual operation: | See "PvT Full Burst" See "Trigger to Sync Graph"


TRACe:IQ:DATA:MEMory?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Graphical Results > TRACe:IQ:DATA:MEMory?
TRACe:IQ:DATA:MEMory? [<OffsetSamples>,<NoOfSamples>]

This command queries the I/Q data currently stored in the memory of the R&S FSW.

By default, the command returns all I/Q data in the memory. You can, however, narrow down the amount of data that the command returns using the optional parameters.

By default, the amount of available data depends on TRACe:​IQ:​SRATe? and [SENSe:​]SWEep:​TIME.

Parameters:
<OffsetSamples>

Selects an offset at which the output of data should start in relation to the first data. If omitted, all captured samples are output, starting with the first sample.

Range: | 0 to <# of samples> – 1, with <# of samples> being the maximum number of captured values
*RST: | 0
<NoOfSamples>

Number of samples you want to query, beginning at the offset you have defined. If omitted, all captured samples (starting at offset) are output.

Range: | 1 to <# of samples> - <offset samples> with <# of samples> maximum number of captured values
*RST: | <# of samples>
Return values:
<IQData>

Measured value pair (I,Q) for each sample that has been recorded.

The data format depends on FORMat[:​DATA].

Default unit: V
Example:

// Preset the instrument

*RST

// Enter GSM option

INST:SEL GSM

// Set center frequency to 935 MHz

FREQ:CENT 935MHZ

Sample Rate = 6.5 MHz

TRAC:IQ:SRAT 6.5MHz

Capture Time = 1.0 ms

SET:SWE:TIME 1 s

// Set statistic count to 1 to obtain the I/Q data of a single capture.

// Otherwise several captures are performed until the set

// statistic count is reached.

// I/Q data is returned from the last capture.

SWE:COUN 1

// Switch to single sweep mode

INIT:CONT OFF

// Start measurement and wait for sync

// This performs one sweep or a single I/Q capture.

INIT;*WAI

// Determine output format (binary float32)

FORMat REAL,32

// Read I/Q data of the entire capture buffer.

// 653751 samples are returned as I,Q,I,Q,...

// 653751 * 4 Bytes (float32) * 2 (I+Q) = 5230008 bytes

TRAC:IQ:DATA:MEM?

// Read 2048 I/Q samples starting at the beginning of data acquisition

TRAC:IQ:DATA:MEM? 0,2048

// Read 1024 I/Q samples starting at sample 2048.

TRAC:IQ:DATA:MEM? 2048,1024
Example:

See "Programming Example: Determining the EVM".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Basic I/Q Analysis with Improved Performance" .

Usage: Query only


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The evaluation method selected by the LAY:ADD:WIND command also affects the results of the trace data query (see TRACe<n>[:DATA]? TRACE<n>).

Details on the returned trace data depending on the evaluation method are provided here.

For details on the graphical results of these evaluation methods, see "GSM I/Q (Modulation Accuracy, etc.) Measurement Results".

Contents
  • EVM, Phase Error, Magnitude Error Trace Results
  • PvT Full Burst Trace Results
  • Modulation Spectrum and Transient Spectrum Graph Results
  • Magnitude Capture Results
  • Trigger to Sync Results
  • MCWN Spectrum Graph


EVM, Phase Error, Magnitude Error Trace Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > EVM, Phase Error, Magnitude Error Trace Results
EVM, Phase Error, Magnitude Error Trace Results

The error vector magnitude (EVM), as well as the phase and magnitude errors are calculated and displayed for each symbol. Thus, the TRAC:DATA? query returns one value per symbol. The number of symbols depends on the burst type, modulation and number of carriers used for transmission, as well as the oversampling factor used internally by the R&S FSW GSM application. The following table provides an overview of the possible number of symbols.

Number of trace result values for EVM, Phase Error, Magnitude Error measurements
Burst Type | Modulation | Multicarrier BTS | No. of trace points | Comment
AB | GMSK | any | 348 = 87 symbols (NSP) * ov | ov = oversampling factor = 4
NB | GMSK | OFF | 588 = 147 symbols (NSP) * ov | ov = oversampling factor = 4 this corresponds to the "useful part" of the burst, see 3GPP TS 45.004, § "2.2 Start and stop of the burst"
NB | GMSK | ON | 568 samples = 142 symbols (NSP) * ov | ov = oversampling factor = 4 This corresponds to the "useful part" of the burst, excluding the tail bits to allow the multicarrier filter to settle.
NB | not GMSK | any | 142 symbols (NSP) | only one sample per symbol (ov=1) this corresponds to the "useful part" of the burst, excluding tail symbols see 3GPP TS 45.005, § "Annex G (normative): Calculation of Error Vector Magnitude"
HSR | any | any | 169 symbols (RSP) | only one sample per symbol (ov=1) this corresponds to the "useful part" of the burst, excluding tail symbols see 3GPP TS 45.005, § "Annex G (normative): Calculation of Error Vector Magnitude"
NSP = Normal Symbol Period (= symbol duration for normal symbol rate / normal bursts) RSP = Reduced Symbol Period (= symbol duration for higher symbol rate / HSR bursts)


PvT Full Burst Trace Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > PvT Full Burst Trace Results
PvT Full Burst Trace Results

The Power vs Time results depend on the number of slots that are measured, and thus the duration of the measurement. 30 additional symbols (NSP) are added at the beginning and at the end of the trace.

The number of trace result values is calculated as:

(30 + <NofSlots> * 157 + 30) * ov

where:

<NofSlots> = Number of Slots (Slot Scope)

ov = oversampling factor = 24

157 = length of a long slot (a slot can have a length of 156, 156.25 or 157 symbols (NSP))


Modulation Spectrum and Transient Spectrum Graph Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Modulation Spectrum and Transient Spectrum Graph Results
Modulation Spectrum and Transient Spectrum Graph Results

Modulation Spectrum and Transient Spectrum Graphs consist of 1135 trace values (two less than in previous R&S signal and spectrum analyzers).


Magnitude Capture Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Magnitude Capture Results
Magnitude Capture Results

The Magnitude Capture trace consists of 32001 trace values, regardless of the defined capture time and thus of the length of the capture buffer.

To retrieve the (complete) captured I/Q data, use the MMEM:STOR:IQ:STAT command, see MMEMory:​STORe:​IQ:​STATe.


Trigger to Sync Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Trigger to Sync Results
Trigger to Sync Results

The Trigger to Sync Graph results consist of two traces. Thus, the results of the TRAC:DATA? query depend on the <TraceNumber> parameter.

TRACe1: returns the height of the histogram bins; the number of values is defined by the number of bins (see CONFigure:​TRGS:​NOFBins)

TRACe2: returns the y-values for the probability density function (PDF) of the averaged values. The number of values depends on the number of data captures (Statistic Count, see [SENSe:​]SWEep:​COUNt).

X-values

The results of the TRAC:DATA:X? query also depend on the <TraceNumber> parameter:

TRACe1: returns the time (in s) at the center of each bin in the histogram.

TRACe2: returns the time (in s) for the PDF function of the averaged values


MCWN Spectrum Graph

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > MCWN Spectrum Graph
MCWN Spectrum Graph

The Multicarrier Wideband Noise Spectrum Graph consists of one (average) trace with 10001 trace points.


Magnitude Capture Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Magnitude Capture Results
Magnitude Capture Results

The following commands are required to query the results of the "Magnitude Capture" evaluation.

List of Commands
FETCh:MCAPture:SLOTs:MEASure?
FETCh:MCAPture:SLOTs:SCOPe?


FETCh:MCAPture:SLOTs:MEASure?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Magnitude Capture Results > FETCh:MCAPture:SLOTs:MEASure?
FETCh:MCAPture:SLOTs:MEASure?

This command queries the positions of the slots to measure in the current capture buffer (indicated by blue bars in the result display).

Return values:
<Result> | The result is a comma-separated list of positions for each slot with the following syntax: xPos[0],xLen[0], xPos[1],xLen[1],… where: xPos[i] is the x-value (in seconds) of the i-th slot to measure xLen[i] is the length of the i-th slot to measure (in seconds) The number of values is 2* [the number of GSM frames in the current capture buffer]. If the number of frames defined by the statistic count all fit into the capture buffer at once, the number of values is 2*statistic count. If not, the number of values is 2*[the number of frames in the last capture].
Example: | FETCh:MCAPture:SLOTs:MEASure? Result for 3 slot scopes (e.g. after a single sweep with statistic count = 3) 0.002261,0.000577,0.006876,0.000577,0.011492,0.000577
Usage: | Query only
Manual operation: | See "Magnitude Capture"


FETCh:MCAPture:SLOTs:SCOPe?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Magnitude Capture Results > FETCh:MCAPture:SLOTs:SCOPe?
FETCh:MCAPture:SLOTs:SCOPe?

This command queries the positions of the slot scopes in the current capture buffer (indicated by green bars in the result display).

Return values:
<Result> | The result is a comma-separated list of positions for each scope with the following syntax: xPos[0],xLen[0], xPos[1],xLen[1],… where: xPos[i] is the x-value (in seconds) of the i-th scope xLen[i] is the length of the i-th scope (in seconds) The number of values is 2* [the number of GSM frames in the current capture buffer]. If the number of frames defined by the statistic count all fit into the capture buffer at once, the number of values is 2*statistic count. If not, the number of values is 2*[the number of frames in the last capture].
Example: | FETCh:MCAPture:SLOTs:SCOPe? Result for 3 slots to measure (e.g. after a single sweep with statistic count = 3) 0.002261,0.001154,0.006876,0.001154,0.011492,0.001154
Usage: | Query only
Manual operation: | See "Magnitude Capture"


Modulation Accuracy Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results
Modulation Accuracy Results

The following commands are required to query the results of the "Modulation Accuracy" evaluation. For details on the individual results see table "Modulation accuracy parameters".

READ vs FETCh commands

Note that for each result type, two commands are provided which are almost identical.

The READ command starts the measurement and reads out the result. When the measurement is started the R&S FSW GSM application is automatically set to single sweep.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt commands.

Statistical results

For most results, both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

List of Commands
FETCh:BURSt[:MACCuracy]:ALL?
READ:BURSt[:MACCuracy]:ALL
FETCh:BURSt[:MACCuracy]:ADRoop:AVERage?
FETCh:BURSt[:MACCuracy]:ADRoop:CURRent?
FETCh:BURSt[:MACCuracy]:ADRoop:MAXimum?
FETCh:BURSt[:MACCuracy]:ADRoop:SDEViation?
READ:BURSt[:MACCuracy]:ADRoop:AVERage?
READ:BURSt[:MACCuracy]:ADRoop:CURRent?
READ:BURSt[:MACCuracy]:ADRoop:MAXimum?
READ:BURSt[:MACCuracy]:ADRoop:SDEViation?
FETCh:BURSt[:MACCuracy]:BPOWer:AVERage?
FETCh:BURSt[:MACCuracy]:BPOWer:CURRent?
FETCh:BURSt[:MACCuracy]:BPOWer:MAXimum?
FETCh:BURSt[:MACCuracy]:BPOWer:SDEViation?
READ:BURSt[:MACCuracy]:BPOWer:AVERage?
READ:BURSt[:MACCuracy]:BPOWer:CURRent?
READ:BURSt[:MACCuracy]:BPOWer:MAXimum?
READ:BURSt[:MACCuracy]:BPOWer:SDEViation?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
READ:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
READ:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
READ:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
READ:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?
FETCh:BURSt[:MACCuracy]:FREQuency:AVERage?
FETCh:BURSt[:MACCuracy]:FREQuency:CURRent?
FETCh:BURSt[:MACCuracy]:FREQuency:MAXimum?
FETCh:BURSt[:MACCuracy]:FREQuency:SDEViation?
READ:BURSt[:MACCuracy]:FREQuency:AVERage?
READ:BURSt[:MACCuracy]:FREQuency:CURRent?
READ:BURSt[:MACCuracy]:FREQuency:MAXimum?
READ:BURSt[:MACCuracy]:FREQuency:SDEViation?
FETCh:BURSt[:MACCuracy]:IQIMbalance:AVERage?
FETCh:BURSt[:MACCuracy]:IQIMbalance:CURRent?
FETCh:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
FETCh:BURSt[:MACCuracy]:IQIMbalance:SDEViation?
READ:BURSt[:MACCuracy]:IQIMbalance:AVERage?
READ:BURSt[:MACCuracy]:IQIMbalance:CURRent?
READ:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
READ:BURSt[:MACCuracy]:IQIMbalance:SDEViation?
FETCh:BURSt[:MACCuracy]:IQOFfset:AVERage?
FETCh:BURSt[:MACCuracy]:IQOFfset:CURRent?
FETCh:BURSt[:MACCuracy]:IQOFfset:MAXimum?
FETCh:BURSt[:MACCuracy]:IQOFfset:SDEViation?
READ:BURSt[:MACCuracy]:IQOFfset:AVERage?
READ:BURSt[:MACCuracy]:IQOFfset:CURRent?
READ:BURSt[:MACCuracy]:IQOFfset:MAXimum?
READ:BURSt[:MACCuracy]:IQOFfset:SDEViation?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?
FETCh:BURSt[:MACCuracy]:OSUPpress:AVERage?
FETCh:BURSt[:MACCuracy]:OSUPpress:CURRent?
FETCh:BURSt[:MACCuracy]:OSUPpress:MAXimum?
FETCh:BURSt[:MACCuracy]:OSUPpress:SDEViation?
READ:BURSt[:MACCuracy]:OSUPpress:AVERage?
READ:BURSt[:MACCuracy]:OSUPpress:CURRent?
READ:BURSt[:MACCuracy]:OSUPpress:MAXimum?
READ:BURSt[:MACCuracy]:OSUPpress:SDEViation?
FETCh:BURSt[:MACCuracy]:PERCentile:EVM?
READ:BURSt[:MACCuracy]:PERCentile:EVM?
FETCh:BURSt[:MACCuracy]:PERCentile:MERRor?
READ:BURSt[:MACCuracy]:PERCentile:MERRor?
FETCh:BURSt[:MACCuracy]:PERCentile:PERRor?
READ:BURSt[:MACCuracy]:PERCentile:PERRor?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?


FETCh:BURSt[:MACCuracy]:ALL?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:ALL?
FETCh:BURSt[:MACCuracy]:ALL?
READ:BURSt[:MACCuracy]:ALL

This command starts the measurement and returns all the modulation accuracy results. For details on the individual parameters see "Modulation Accuracy".

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

Return values:
<MeasValue> | <Error Vector Magnitude RMS>, <Error Vector Magnitude Peak>, <Magnitude Error RMS>, <Magnitude Error Peak>, <Phase Error RMS>, <Phase Error Peak>, <Origin Offset Suppression>, <IQ Offset>, <IQ Imbalance>,< Frequency Error>, <Burst Power>, <Amplitude Droop>, <95%ile EVM>, <95%ile Mag Error>, <95%ile Phase Error> The results are output as a list of comma separated strings. For each result (except for %iles), the Current, Average, Maximum and Standard Deviation values are returned.
Example: | READ:BURS:ALL? 17.283994674682617,17.283994674682617,17.283994674682617,0,24.647823333740234, 24.647823333740234,24.647823333740234,0,1.0720701217651367,1.0720701217651367, 1.0720701217651367,0,1.0720850229263306,1.0720850229263306, 1.0720850229263306, 0,9.8495550155639648,9.8495550155639648,9.8495550155639648, 0,-14.069089889526367,14.069089889526367,-14.069089889526367, 0,-0.091422632336616516,-0.091422632336616516,-0.091422632336616516, 0,101.05810546875,101.05810546875,101.05810546875, 0,0.036366362124681473,0.036366362124681473,0.036366362124681473, 0,76.698326110839844,76.698326110839844,76.698326110839844,0, -112.8399658203125,-112.8399658203125,-112.8399658203125,0, 0.083038687705993652,0.083038687705993652,0.083038687705993652,0, 24.07130241394043,1.0950000286102295,14.060454368591309
Manual operation: | See "Modulation Accuracy"


FETCh:BURSt[:MACCuracy]:ADRoop:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:ADRoop:AVERage?
FETCh:BURSt[:MACCuracy]:ADRoop:AVERage?
FETCh:BURSt[:MACCuracy]:ADRoop:CURRent?
FETCh:BURSt[:MACCuracy]:ADRoop:MAXimum?
FETCh:BURSt[:MACCuracy]:ADRoop:SDEViation?
READ:BURSt[:MACCuracy]:ADRoop:AVERage?
READ:BURSt[:MACCuracy]:ADRoop:CURRent?
READ:BURSt[:MACCuracy]:ADRoop:MAXimum?
READ:BURSt[:MACCuracy]:ADRoop:SDEViation?

This command starts the measurement and reads out the result of the Amplitude Droop.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Amplitude Droop see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Amplitude droop

Default unit: dB
Example: READ:BURS:ADR:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:BPOWer:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:BPOWer:AVERage?
FETCh:BURSt[:MACCuracy]:BPOWer:AVERage?
FETCh:BURSt[:MACCuracy]:BPOWer:CURRent?
FETCh:BURSt[:MACCuracy]:BPOWer:MAXimum?
FETCh:BURSt[:MACCuracy]:BPOWer:SDEViation?
READ:BURSt[:MACCuracy]:BPOWer:AVERage?
READ:BURSt[:MACCuracy]:BPOWer:CURRent?
READ:BURSt[:MACCuracy]:BPOWer:MAXimum?
READ:BURSt[:MACCuracy]:BPOWer:SDEViation?

This command starts the measurement and reads out the result of the Burst Power.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Burst Power see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Burst Power

Default unit: dB
Example: READ:BURS:BPOW:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
READ:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
READ:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?

This command starts the measurement and reads out the peak result of the Error Vector Magnitude taken over the selected number of bursts. When the measurement is started the analyzer is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the EVM results see table "Modulation accuracy parameters"

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

EVM

Default unit: NONE
Example: READ:BURS:PEAK:AVER?
Usage: Query only

For a detailed example see "Programming Example: Determining the EVM".


FETCh:BURSt[:MACCuracy][:EVM]:RMS:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
READ:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
READ:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?

This command starts the measurement and reads out the RMS value of the Error Vector Magnitude.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the EVM results see table "Modulation accuracy parameters".

Return values:
<Result>
numeric value

EVM

Default unit: NONE
Example: READ:BURS:RMS:SDEV?
Usage: Query only

For a detailed example see "Programming Example: Determining the EVM".


FETCh:BURSt[:MACCuracy]:FREQuency:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:FREQuency:AVERage?
FETCh:BURSt[:MACCuracy]:FREQuency:AVERage?
FETCh:BURSt[:MACCuracy]:FREQuency:CURRent?
FETCh:BURSt[:MACCuracy]:FREQuency:MAXimum?
FETCh:BURSt[:MACCuracy]:FREQuency:SDEViation?
READ:BURSt[:MACCuracy]:FREQuency:AVERage?
READ:BURSt[:MACCuracy]:FREQuency:CURRent?
READ:BURSt[:MACCuracy]:FREQuency:MAXimum?
READ:BURSt[:MACCuracy]:FREQuency:SDEViation?

This command starts the measurement and reads out the result of the Frequency Error.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Frequency Error see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Frequency error

Default unit: Hz
Example: READ:BURS:FREQ:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:IQIMbalance:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:IQIMbalance:AVERage?
FETCh:BURSt[:MACCuracy]:IQIMbalance:AVERage?
FETCh:BURSt[:MACCuracy]:IQIMbalance:CURRent?
FETCh:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
FETCh:BURSt[:MACCuracy]:IQIMbalance:SDEViation?
READ:BURSt[:MACCuracy]:IQIMbalance:AVERage?
READ:BURSt[:MACCuracy]:IQIMbalance:CURRent?
READ:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
READ:BURSt[:MACCuracy]:IQIMbalance:SDEViation?

This command starts the measurement and reads out the result of the I/Q Imbalance.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the I/Q Imbalance see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

I/Q Imbalance

Default unit: NONE
Example: READ:BURS:IQIM:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:IQOFfset:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:IQOFfset:AVERage?
FETCh:BURSt[:MACCuracy]:IQOFfset:AVERage?
FETCh:BURSt[:MACCuracy]:IQOFfset:CURRent?
FETCh:BURSt[:MACCuracy]:IQOFfset:MAXimum?
FETCh:BURSt[:MACCuracy]:IQOFfset:SDEViation?
READ:BURSt[:MACCuracy]:IQOFfset:AVERage?
READ:BURSt[:MACCuracy]:IQOFfset:CURRent?
READ:BURSt[:MACCuracy]:IQOFfset:MAXimum?
READ:BURSt[:MACCuracy]:IQOFfset:SDEViation?

This command starts the measurement and reads out the standard deviation measurement of the IQ Offset taken over the selected number of bursts. When the measurement is started the analyzer is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

Return values:
<Result>
numeric value

Standard deviation

Default unit: NONE
Example: READ:BURS:IQOF:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?

This command starts the measurement and reads out the peak value of the Magnitude Error.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Magnitude Error see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Magnitude error

Default unit: NONE
Example: READ:BURS:MERR:PEAK:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:MERRor:RMS:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?

This command starts the measurement and reads out the RMS value of the Magnitude Error.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Magnitude Error see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Magnitude error

Default unit: NONE
Example: READ:BURS:MERR:RMS:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:OSUPpress:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:OSUPpress:AVERage?
FETCh:BURSt[:MACCuracy]:OSUPpress:AVERage?
FETCh:BURSt[:MACCuracy]:OSUPpress:CURRent?
FETCh:BURSt[:MACCuracy]:OSUPpress:MAXimum?
FETCh:BURSt[:MACCuracy]:OSUPpress:SDEViation?
READ:BURSt[:MACCuracy]:OSUPpress:AVERage?
READ:BURSt[:MACCuracy]:OSUPpress:CURRent?
READ:BURSt[:MACCuracy]:OSUPpress:MAXimum?
READ:BURSt[:MACCuracy]:OSUPpress:SDEViation?

This command starts the measurement and reads out the result of the I/Q Offset Suppression.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the I/Q Offset Suppression see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

I/Q offset suppression

Default unit: dB
Example: READ:BURS:OSUP:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:PERCentile:EVM?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:PERCentile:EVM?
FETCh:BURSt[:MACCuracy]:PERCentile:EVM?
READ:BURSt[:MACCuracy]:PERCentile:EVM?

This command starts the measurement and reads out the 95 % percentile of the Error Vector Magnitude measurement taken over the selected number of frames.

When the measurement is started the R&S FSW GSM application is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

Return values:
<Result>
numeric value
Default unit: NONE
Example: READ:BURS:PERC:EVM?
Usage: Query only


FETCh:BURSt[:MACCuracy]:PERCentile:MERRor?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:PERCentile:MERRor?
FETCh:BURSt[:MACCuracy]:PERCentile:MERRor?
READ:BURSt[:MACCuracy]:PERCentile:MERRor?

This command starts the measurement and reads out the 95 % percentile of the Magnitude Error measurement taken over the selected number of frames.

When the measurement is started the R&S FSW GSM application is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

Return values:
<Result>
numeric value
Default unit: NONE
Example: READ:BURS:PERC:MERR?
Usage: Query only


FETCh:BURSt[:MACCuracy]:PERCentile:PERRor?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:PERCentile:PERRor?
FETCh:BURSt[:MACCuracy]:PERCentile:PERRor?
READ:BURSt[:MACCuracy]:PERCentile:PERRor?

This command starts the measurement and reads out the 95 % percentile of the Phase Error measurement taken over the selected number of frames.

When the measurement is started the R&S FSW GSM application is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

Return values:
<Result>
numeric value

Phase error

Default unit: NONE
Example: READ:BURS:PERC:PERR?
Usage: Query only


FETCh:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?

This command starts the measurement and reads out the peak value of the Phase Error.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Phase Error results see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Phase error

Default unit: NONE
Example: READ:BURS:PERR:PEAK:SDEV?
Usage: Query only


FETCh:BURSt[:MACCuracy]:PERRor:RMS:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Accuracy Results > FETCh:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?

This command starts the measurement and reads out the RMS value of the Phase Error.

When the measurement is started the R&S FSW is automatically set to single sweep. Further results of the measurement can then be queried without restart of the measurement via the FETCh:BURSt subsystem.

For details on the Phase Error results see table "Modulation accuracy parameters".

Both the current result and the statistical evaluation of all results over a number of frames (specified by "Statistic Count") are provided.

For details on how the statistical evaluation is performed see table "Calculated summary results".

Return values:
<Result>
numeric value

Phase error

Default unit: NONE
Example: READ:BURS:PERR:RMS:SDEV?
Usage: Query only


Modulation Spectrum Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Spectrum Results
Modulation Spectrum Results

The following commands are required to query the results of the "Modulation Spectrum Table" evaluation. For details on the individual results see "Modulation Spectrum Table".

READ vs FETCh commands

Note that for each result type, two commands are provided which are almost identical.

The READ command starts the measurement and reads out the result. When the measurement is started the R&S FSW GSM application is automatically set to single sweep.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt commands.

List of Commands
FETCh:SPECtrum:MODulation[:ALL]?
READ:SPECtrum:MODulation[:ALL]?
FETCh:SPECtrum:MODulation:REFerence?
READ:SPECtrum:MODulation:REFerence[:IMMediate]?
READ:SPECtrum:MODulation:GATing?
READ:WSPectrum:MODulation:GATing?


FETCh:SPECtrum:MODulation[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Spectrum Results > FETCh:SPECtrum:MODulation[:ALL]?
FETCh:SPECtrum:MODulation[:ALL]?
READ:SPECtrum:MODulation[:ALL]?

This command starts the measurement and returns the modulation spectrum of the mobile or base station. This command is only available for "Modulation Spectrum Table" evaluations (see "Modulation Spectrum Table").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

The result is a list of partial result strings separated by commas, with one list for each measured frequency in the frequency list.

Return values:
<Placeholder> | curently irrelevant
<Freq1> | Absolute offset frequency in Hz
<Freq2> | Absolute offset frequency in Hz
<Level> | Measured level at the offset frequency in dB or dBm (depending on CONF:SPEC:MOD:LIM).
<Limit> | Limit at the offset frequency in dB or dBm (depending on CONF:SPEC:MOD:LIM).
<Abs/Rel> | Indicates whether relative (dB) or absolute (dBm) limit and level values are returned (depending on CONF:SPEC:MOD:LIM).
<Status> | Result of the limit check in character data form PASSED no limit exceeded FAILED limit exceeded
Example: | READ:SPEC:MOD? 0,998200000,998200000,-84.61,-56.85,REL,PASSED, 0,998400000,998400000,-85.20,-56.85,REL,PASSED, ...
Usage: | Query only
Manual operation: | See "Modulation Spectrum Table"

For a detailed example see "Programming Example: Determining the EVM".


FETCh:SPECtrum:MODulation:REFerence?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Spectrum Results > FETCh:SPECtrum:MODulation:REFerence?
FETCh:SPECtrum:MODulation:REFerence?
READ:SPECtrum:MODulation:REFerence[:IMMediate]?

This command starts the measurement and returns the (internal) reference power of the "Modulation Spectrum". This command is only available for "Modulation Spectrum Table" evaluations (see "Modulation Spectrum Table").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

The result is a list of partial result strings separated by commas.

Return values:
<Level1> | measured reference power in dBm
<Level2> | measured reference power in dBm
<RBW> | resolution bandwidth used to measure the reference power in Hz; (30 kHz)
Example: | READ:SPECtrum:MODulation:REFerence:IMMediate?
Usage: | Query only
Manual operation: | See "Modulation Spectrum Table"

For a detailed example see "Programming Example: Determining the EVM".


READ:SPECtrum:MODulation:GATing?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Modulation Spectrum Results > READ:SPECtrum:MODulation:GATing?
READ:SPECtrum:MODulation:GATing?
READ:WSPectrum:MODulation:GATing?

This command reads out the gating settings for gated "Modulation Spectrum" measurements (see "Modulation Spectrum Table").

The returned values can be used to set the gating interval for "list" measurements (i.e. a series of measurements in zero span mode at several offset frequencies). This is done in the "Spectrum" mode using the SENSe:LIST subsystem (see [SENSe:]LIST:POWer:SET).

Prior to this command make sure you set the correct Trigger Mode ("IF power" or "External") and Trigger Offset (see "Triggering Measurements").

Return values:
<TriggerOffset> | Calculated trigger offset, based on the user-defined "Trigger Offset" and "Frame Configuration", such that 50-90% of the active part of the "Slot to measure" (excluding TSC) is measured.
<GateLength> | Calculated gate length, based on the user-defined "Trigger Offset" and "Frame Configuration", such that 50-90% of the active part of the "Slot to measure" (excluding TSC) is measured.
Example: | READ:WSP:MOD:GAT? Results: 0.00032303078,0.00016890001
Usage: | Query only


Power vs Slot Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results
Power vs Slot Results

The following commands are required to query the results of the "Power vs Slot" evaluation. For details on the individual results see "Power vs Slot".

READ vs FETCh commands

Note that for each result type, two commands are provided which are almost identical.

The READ command starts the measurement and reads out the result. When the measurement is started the R&S FSW GSM application is automatically set to single sweep.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt commands.

List of Commands
FETCh:BURSt:SPOWer:SLOT<s>:ALL:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:DELTatosync?
READ:BURSt:SPOWer:SLOT<Slot>:DELTatosync?
FETCh:BURSt:SPOWer:SLOT<s>:LIMit:FAIL?
READ:BURSt:SPOWer:SLOT<Slot>:LIMit:FAIL?


FETCh:BURSt:SPOWer:SLOT<s>:ALL:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:ALL:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:AVERage?

This command starts the measurement and reads out the average power for the selected slot for all measured frames.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Average

Default unit: dBm
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:ALL:AVERage?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:ALL:CRESt?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:ALL:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:CRESt?

This command starts the measurement and reads out the crest factor for the selected slot for all measured frames.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Crest factor

Default unit: dB
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:ALL:CRESt?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:ALL:MAXimum?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:ALL:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:MAXimum?

This command starts the measurement and reads out the maximum power for the selected slot for all measured frames.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Maximum

Default unit: dBm
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:ALL:MAXimum?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:CURRent:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:CURRent:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:AVERage?

This command starts the measurement to read out the average power for the selected slot in the current frame.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Average

Default unit: dBm
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:CURRent:AVERage?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:CURRent:CRESt?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:CURRent:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:CRESt?

This command starts the measurement to read out the crest factor for the selected slot in the current frame.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Crest factor

Default unit: dB
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:CURRent:CRESt?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:CURRent:MAXimum?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:CURRent:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:MAXimum?

This command starts the measurement to read out the maximum power for the selected slot in the current frame.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot s must be within the slot scope, i.e. (First slot to measure) ≦ s ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

Maximum

Default unit: dBm
Example:

\\ Preset the instrument

*RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:CURRent:MAXimum?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:DELTatosync?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:DELTatosync?
FETCh:BURSt:SPOWer:SLOT<s>:DELTatosync?
READ:BURSt:SPOWer:SLOT<Slot>:DELTatosync?

This command starts the measurement of the "Delta to Sync" value for the selected slot in the current frame.

This command is only available when the "Power vs Time" measurement is selected (see "PvT Full Burst").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Suffix:
<Slot>
<0..7>

Slot number to measure power on. The selected slot must be within the slot scope, i.e.

(First slot to measure) ≦ <slot> ≦ (First slot to measure + Number of Slots to measure - 1).

Return values:
<Result>
numeric value

For equal timeslot length: the expected offset

For non-equal time slots: the measured offset

(See CONFigure[:​MS]:​CHANnel:​FRAMe:​EQUal)

Default unit: dBm
Example:

\\ Preset the instrument

RST

\\ Enter the GSM option K10

INSTrument:SELect GSM

\\ Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

\\ Set the slot scope: Use all 8 slots for the PvT measurement.

\\ Number of slots to measure = 8

CONFigure:MS:CHANnel:MSLots:NOFSlots 8

\\ First Slot to measure = 0

CONFigure:MS:CHANnel:MSLots:OFFSet 0

\\ Activate PvT (Power vs Time) measurement

LAY:ADD? '1',LEFT,PTF

\\ Note: 'READ' starts a new single sweep annd then reads the results. Use 'FETCh' to query several results!

READ:BURSt:SPOWer:SLOT1:DELTatosync?
Usage: Query only
Manual operation: See "Power vs Slot"


FETCh:BURSt:SPOWer:SLOT<s>:LIMit:FAIL?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Power vs Slot Results > FETCh:BURSt:SPOWer:SLOT<s>:LIMit:FAIL?
FETCh:BURSt:SPOWer:SLOT<s>:LIMit:FAIL?
READ:BURSt:SPOWer:SLOT<Slot>:LIMit:FAIL?

This command starts a "Power vs Time" measurement and queries the result of the limit check for the selected slot.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

Note: in manual operation, the result of the limit check for an individual slot is included in the "Power vs Slot" results (see "Power vs Slot").

Suffix: |
<Slot> | <0..7> Slot number to perform the limit check on. The selected slot must be within the slot scope, i.e. (First slot to measure) ≦ <slot> ≦ (First slot to measure + Number of Slots to measure - 1).
Return values:
<Result> | 1 | 0 | ON | OFF 1 | ON Pass 0 | OFF Fail
Example: | READ:BURSt:SPOWer:SLOT1:LIMit:FAIL?
Usage: | Query only
Manual operation: | See "Power vs Slot"

For a detailed example see "Programming Example: Determining the EVM".


Transient Spectrum Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Transient Spectrum Results
Transient Spectrum Results

The following commands are required to query the results of the "Modulation Spectrum Table" evaluation. For details on the individual results see "Modulation Spectrum Table".

READ vs FETCh commands

Note that two commands are provided which are almost identical.

The READ command starts the measurement and reads out the result. When the measurement is started the R&S FSW GSM application is automatically set to single sweep.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

List of Commands
FETCh:SPECtrum:SWITching[:ALL]?
READ:SPECtrum:SWITching[:ALL]?
FETCh:SPECtrum:SWITching:REFerence?
READ:SPECtrum:SWITching:REFerence[:IMMediate]
READ:SPECtrum:SWITching:REFerence:GATing?


FETCh:SPECtrum:SWITching[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Transient Spectrum Results > FETCh:SPECtrum:SWITching[:ALL]?
FETCh:SPECtrum:SWITching[:ALL]?
READ:SPECtrum:SWITching[:ALL]?

This command starts the measurement and reads out the transient spectrum.

This command is only available for "Transient Spectrum Table" evaluations (see "Transient Spectrum Table").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

The result is a list of partial result strings separated by commas.

Return values:
<Placeholder> | curently irrelevant
<Freq1> | Absolute offset frequency in Hz
<Freq2> | Absolute offset frequency in Hz
<Level> | Measured level at the offset frequency in dB or dBm. For more information see CONFigure:​SPECtrum:​SWITching:​LIMIT).
<Limit> | Limit at the offset frequency in dB or dBm For more information see CONFigure:​SPECtrum:​SWITching:​LIMIT).
<Abs/Rel> | Indicates whether relative (dB) or absolute (dBm) limit and level values are returned. For more information see CONFigure:​SPECtrum:​SWITching:​LIMIT).
<Status> | Result of the limit check in character data form PASSED no limit exceeded FAILED limit exceeded
Example: | READ:SPEC:SWIT? 0,998200000,998200000,-84.61,-56.85,REL,PASSED, 0,998400000,998400000,-85.20,-56.85,REL,PASSED,
Usage: | Query only
Manual operation: | See "Transient Spectrum Table"


FETCh:SPECtrum:SWITching:REFerence?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Transient Spectrum Results > FETCh:SPECtrum:SWITching:REFerence?
FETCh:SPECtrum:SWITching:REFerence?
READ:SPECtrum:SWITching:REFerence[:IMMediate]

This command starts the measurement and returns the measured reference power of the "Transient Spectrum".

This command is only available for "Transient Spectrum Table" evaluations (see "Transient Spectrum Table").

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

The result is a list of partial result strings separated by commas.

Return values:
<Level1> | measured reference power in dBm
<Level2> | measured reference power in dBm
<RBW> | resolution bandwidth used to measure the reference power in Hz
Example: | READ:SPECtrum:SWITching:REFerence:IMMediate?
Manual operation: | See "Transient Spectrum Table"


READ:SPECtrum:SWITching:REFerence:GATing?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Transient Spectrum Results > READ:SPECtrum:SWITching:REFerence:GATing?
READ:SPECtrum:SWITching:REFerence:GATing?

This command reads out the gating settings for gated measurements of the reference power of the "Transient Spectrum" measurement (see "Transient Spectrum Table").

Prior to this command make sure you set the correct Trigger Mode ("IF power" or "External") and Trigger Offset (see "Triggering Measurements").

Return values:
<TriggerOffset> | Calculated trigger offset, based on the user-defined "Trigger Offset" and "Frame Configuration", such that the useful part of the "Slot to measure" is measured.
<GateLength> | Calculated gate length, based on the user-defined "Trigger Offset" and "Frame Configuration", such that the useful part of the "Slot to measure" is measured.
Example: | READ:SPEC:SWIT:REF:GAT? Result: 0.00000185076,0.00054277002
Usage: | Query only


Trigger to Sync Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Trigger to Sync Results
Trigger to Sync Results

The following commands are required to query the (numeric) results of a Trigger to Sync measurement. For details on the individual results see "Trigger to Sync Table".

READ vs FETCh commands

Note that two commands are provided for each result type which are almost identical.

The READ command starts the measurement and reads out the result. When the measurement is started the R&S FSW GSM application is automatically set to single sweep.

Further results of the measurement can then be queried without performing a new measurement via the FETCh:BURSt command.

List of Commands
FETCh:BURSt:PTEMplate:TRGS:AVERage?
FETCh:BURSt:PTEMplate:TRGS:CURRent?
FETCh:BURSt:PTEMplate:TRGS:MAXimum?
FETCh:BURSt:PTEMplate:TRGS:MINimum?
FETCh:BURSt:PTEMplate:TRGS:SDEViation?
READ:BURSt:PTEMplate:TRGS:AVERage?
READ:BURSt:PTEMplate:TRGS:CURRent?
READ:BURSt:PTEMplate:TRGS:MAXimum?
READ:BURSt:PTEMplate:TRGS:MINimum?
READ:BURSt:PTEMplate:TRGS:SDEViation?


FETCh:BURSt:PTEMplate:TRGS:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Trigger to Sync Results > FETCh:BURSt:PTEMplate:TRGS:AVERage?
FETCh:BURSt:PTEMplate:TRGS:AVERage?
FETCh:BURSt:PTEMplate:TRGS:CURRent?
FETCh:BURSt:PTEMplate:TRGS:MAXimum?
FETCh:BURSt:PTEMplate:TRGS:MINimum?
FETCh:BURSt:PTEMplate:TRGS:SDEViation?
READ:BURSt:PTEMplate:TRGS:AVERage?
READ:BURSt:PTEMplate:TRGS:CURRent?
READ:BURSt:PTEMplate:TRGS:MAXimum?
READ:BURSt:PTEMplate:TRGS:MINimum?
READ:BURSt:PTEMplate:TRGS:SDEViation?

This command starts a "Trigger to Sync" measurement and reads out the time between the external trigger event and the start of the first symbol of the TSC.

This command is only available if an external trigger is selected and the "Trigger to Sync" measurement is active (see TRIGger[:​SEQuence]:​SOURce and "Trigger to Sync Graph").

Return values:
<Result>
numeric value

Trigger to Sync time

Default unit: S
Example:

// Preset the instrument

*RST

// Enter the GSM option K10

INSTrument:SELect GSM

// Switch to single sweep mode and stop sweep

INITiate:CONTinuous OFF;:ABORt

// Set external trigger mode

TRIGger1:SEQuence:SOURce EXTernal

// Set minimum capture time to speed up measurement

SENSe1:SWEep:TIME MINimum

// Auto set trigger offset

// Note: Correct frame / slot configuration assumed!

CONFigure:MS:AUTO:TRIGger ONCE

// Activate Trigger to Sync measurement

LAY:ADD? '1',LEFT,TGSG
LAY:ADD? '1',BEL,TGST

//Query standard deviation of trigger to sync time.

// Note: 'READ' starts a new single sweep and then reads the results.

// Use 'FETCh' to query several results!

READ:BURS:PTEM:TRGS:SDEV?
Usage: Query only


Limit Check Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Limit Check Results
Limit Check Results

The following commands are required to query the results of a limit check.

Currently, limit check results can only be queried for the following result displays:
  • "PvT Full Burst"
  • "Modulation Spectrum Graph"
  • "Transient Spectrum Graph"
  • "Spectrum Graph"
Useful commands for retrieving limit check results described elsewhere:
  • READ:​BURSt:​SPOWer:​SLOT<Slot>:​LIMit:​FAIL?
  • FETCh:​SPECtrum:​MODulation:​LIMit:​FAIL?
Remote commands exclusive to retrieving limit check results:
List of Commands
CALCulate<n>:LIMit<k>:CONTrol:DATA?
CALCulate<n>:LIMit<k>:FAIL?
CALCulate<n>:LIMit<k>:LOWer[:DATA]?
CALCulate<n>:LIMit<k>:UPPer[:DATA]?


CALCulate<n>:LIMit<k>:CONTrol:DATA?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Limit Check Results > CALCulate<n>:LIMit<k>:CONTrol:DATA?
CALCulate<n>:LIMit<k>:CONTrol:DATA?

This command queries the x-values of the limit specified line.

Suffix: |
<k> | 1 | 2 | 3 | 4 The limit line to query 1: upper limit line for MCWN: wideband noise limit 2: lower limit line (PvT Full Burst only); for MCWN: intermodulation limit at 100 kHz 3: (MCWN only:) intermodulation limit at 300 kHz 4: (MCWN only:) narrowband noise limit
Return values:
<LimitLinePoints> | For "PvT Full Burst" display: Time in seconds For "Modulation Spectrum Graph","Transient Spectrum Graph" or "Spectrum Graph" result displays: relative frequency in Hz
Example: | See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only SCPI confirmed
Manual operation: | See "Modulation Spectrum Graph" See "PvT Full Burst" See "Spectrum Graph"


CALCulate<n>:LIMit<k>:FAIL?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Limit Check Results > CALCulate<n>:LIMit<k>:FAIL?
CALCulate<n>:LIMit<k>:FAIL?

This command queries the result of the limit check of the limit line indicated in the selected measurement window. Note that a complete sweep must have been performed to obtain a valid result. A synchronization with *OPC, *OPC? Or *WAI should therefore be provided.

Suffix: |
<k> | 1 | 2 | 3 | 4 The limit check to query 1: Max trace (-> upper limit line); for MCWN: wideband noise 2: Min trace (-> lower limit line; PvT Full Burst only); for MCWN: intermodulation at 100 kHz 3: (MCWN only:) intermodulation at 300 kHz 4: (MCWN only:) narrowband noise 5: (MCWN only:) Exceptions in subblock A 6: (MCWN only:) Exceptions in subblock B
Return values:
<Result> | 1 | 0 1 Failed (see table "Meaning of return values depending on result display") 0 Passed (see table "Meaning of return values depending on result display")
Example: | CALCulate2:LIMit1:FAIL?
Example: | For a detailed example see "Programming Example: Determining the EVM" or "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only
Manual operation: | See "Modulation Spectrum Graph" See "PvT Full Burst" See "Transient Spectrum Graph" See "Spectrum Graph"
Meaning of return values depending on result display
Result display | SCPI | Return values
Power vs Time Graph | CALCulate<n>:LIMit1:FAIL? | 1: the limit check of the upper limit line against the max hold trace failed 0: passed
 | CALCulate<n>:LIMit2:FAIL? | 1: the limit check of the lower limit line against the min hold trace failed 0: passed
Mod. Spectrum Graph | CALCulate<n>:LIMit1:FAIL? | 1: the limit check of the upper limit line against the average trace failed 0: passed
Tra. Spectrum Graph | CALCulate<n>:LIMit1:FAIL? | 1: the limit check of the upper limit line against the max hold trace failed 0: passed
Power Spectrum (MCWN) | CALCulate<n>:LIMit1:FAIL? | 1: the limit check of the wideband noise limit line against the max hold trace failed 0: passed (possibly with allowed exceptions, if enabled)
 | CALCulate<n>:LIMit2:FAIL? | 1: the limit check of the limit line for intermodulation at 100 kHz against the max hold trace failed 0: passed (possibly with allowed exceptions, if enabled)
 | CALCulate<n>:LIMit3:FAIL? | 1: the limit check of the limit line for intermodulation at 300 kHz against the max hold trace failed 0: passed (possibly with allowed exceptions, if enabled)
 | CALCulate<n>:LIMit4:FAIL? | 1: the limit check of the narrowband noise limit line against the max hold trace failed 0: passed (possibly with allowed exceptions, if enabled)
 | CALCulate<n>:LIMit5:FAIL? | 1: the allowed number of exceptions (if enabled) in subblock A was exceeded 0: passed (possibly with allowed exceptions)
 | CALCulate<n>:LIMit6:FAIL? | 1: the allowed number of exceptions (if enabled) in subblock B was exceeded 0: passed (possibly with allowed exceptions)


CALCulate<n>:LIMit<k>:LOWer[:DATA]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Limit Check Results > CALCulate<n>:LIMit<k>:LOWer[:DATA]?
CALCulate<n>:LIMit<k>:LOWer[:DATA]?

This command queries the y-values of the lower limit line.

This command is only available for "PvT Full Burst" results.

Suffix: |
<k> | 2: lower limit line ("PvT Full Burst" only)
Return values:
<LimitLinePoints> | Absolute level values in dBm
Usage: | Query only SCPI confirmed


CALCulate<n>:LIMit<k>:UPPer[:DATA]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Limit Check Results > CALCulate<n>:LIMit<k>:UPPer[:DATA]?
CALCulate<n>:LIMit<k>:UPPer[:DATA]?

This command queries the y-values of the specified limit line.

Suffix: |
<k> | 1 | 2 | 3 | 4 The limit line to query 1: upper limit line for MCWN: wideband noise limit 2: lower limit line (PvT Full Burst only); for MCWN: intermodulation limit at 100 kHz 3: (MCWN only:) intermodulation limit at 300 kHz 4: (MCWN only:) narrowband noise limit
Return values:
<LimitLinePoints> | Absolute level values in dBm
Example: | See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only SCPI confirmed
Manual operation: | See "Modulation Spectrum Graph" See "PvT Full Burst" See "Spectrum Graph"


MCWN Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results
MCWN Results

The following commands are required to retrieve results from a multicarrier wideband noise measurement (see "Multicarrier Wideband Noise Measurements").

Useful commands for retrieving MCWN results described elsewhere:
  • "Limit Check Results"
Remote commands exclusive to retrieving MCWN results:
List of Commands
CALCulate<n>:LIMit<k>:EXCeption:COUNt:CURR?
CALCulate<n>:LIMit<k>:EXCeption:COUNt:MAX?
FETCh:SPECtrum:MODulation:LIMit:FAIL?
FETCh:WSPectrum:IMPRoducts:INNer[:ALL]?
FETCh:WSPectrum:IMPRoducts:OUTer[:ALL]?
FETCh:WSPectrum:REFerence:POWer[:ALL]?


CALCulate<n>:LIMit<k>:EXCeption:COUNt:CURR?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > CALCulate<n>:LIMit<k>:EXCeption:COUNt:CURR?
CALCulate<n>:LIMit<k>:EXCeption:COUNt:CURR?

This command queries the number of bands with exceptions to the limit line that occurred for the specified limit check in the selected measurement window.

Suffix: |
<k> | 1 | 2 The number of the limit check to query 1: Limit check for wideband noise 2: Limit check for intermodulation at 100 kHz (no exceptions allowed) 3: Limit check for intermodulation at 300 kHz (no exceptions allowed) 5: Exceptions in subblock A 6: Exceptions in subblock B
Return values:
<NoExcept> | integer Number of exceptions
Example: | CALCulate2:LIMit1:EXC:COUN:CURR? Queries the number of bands with exceptions to the limit line check that occurred for wideband noise in window 2.
Example: | See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only
Manual operation: | See "Spectrum Graph"


CALCulate<n>:LIMit<k>:EXCeption:COUNt:MAX?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > CALCulate<n>:LIMit<k>:EXCeption:COUNt:MAX?
CALCulate<n>:LIMit<k>:EXCeption:COUNt:MAX?

This command queries the maximum number of bands with exceptions to the limit line check that are allowed by the standard for the specified limit check in the selected measurement window.

Suffix: |
<k> | 1 | 2 The number of the limit check to query 1: Limit check for wideband noise 2: Limit check for intermodulation at 100 kHz (no exceptions allowed) 3: Limit check for intermodulation at 300 kHz (no exceptions allowed) 5: Exceptions in range A 6: Exceptions in range B
Return values:
<NoExcept> | integer Number of exceptions
Example: | CALCulate2:LIMit1:EXC:COUN:MAX? Queries the maximum number of bands with exceptions to the limit line check allowed for wideband noise in window 2.
Example: | See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only
Manual operation: | See "Spectrum Graph"


FETCh:SPECtrum:MODulation:LIMit:FAIL?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > FETCh:SPECtrum:MODulation:LIMit:FAIL?
FETCh:SPECtrum:MODulation:LIMit:FAIL? <Result>

This command queries the results of the limit check for MCWN measurements.

Parameters:
<Result> | 1 | 0 | ON | OFF Result of the limit check. 1 | ON Pass 0 | OFF Fail
Example: | FETC:SPEC:MOD:LIM:FAIL?
Example: | See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".
Usage: | Query only
Manual operation: | See "Spectrum Graph"


FETCh:WSPectrum:IMPRoducts:INNer[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > FETCh:WSPectrum:IMPRoducts:INNer[:ALL]?
FETCh:WSPectrum:IMPRoducts:INNer[:ALL]?

This command queries the results of the measured intermodulation products (up to the order specified using CONFigure:​SPECtrum:​IMPorder) for the frequencies in the gap between the GSM carrier subblocks for non-contiguous carrier allocation.

For each measured offset frequency, the following values are returned:

Return values:
<FreqAbs>
numeric value

Absolute frequency of intermodulation

Default unit: Hz
<FreqRel>
numeric value

Frequency offsets (from the closest carrier) at which intermodulation power is measured

Default unit: Hz
<IMOrder>
3 | 5 | 3 5

Order of the intermodulation

3

IM order 3

5

IM order 5

3 5

IM orders 3 and 5

<RBW>
numeric value

Resolution bandwidth used for measurement

Default unit: Hz
<Power>
numeric value

Absolute or relative power level (to reference power) measured at IM frequency

Default unit: dBm/dB
<Limit>
numeric value

absolute or relative power level limit (to reference power)

Default unit: dBm/dB
<AbsRelMode>
ABS | REL

Determines whether absolute or relative power values are returned

<LimCheck>

Result of the limit check at this offset frequency

PASSED

power within limits

FAILED

power exceeds limit

Example: FETC:SPEC:MOD:INN:ALL?
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Usage: Query only
Manual operation: See "Inner IM Table"


FETCh:WSPectrum:IMPRoducts:OUTer[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > FETCh:WSPectrum:IMPRoducts:OUTer[:ALL]?
FETCh:WSPectrum:IMPRoducts:OUTer[:ALL]?

This command queries the results of the measured intermodulation products (up to the order specified using CONFigure:​SPECtrum:​IMPorder) for the frequencies outside of the subblocks (but not in the gap) for non-contiguous carrier allocation.

For each measured offset frequency, the following values are returned:

Return values:
<FreqAbs>
numeric value

Absolute frequency of intermodulation

Default unit: Hz
<FreqRel>
numeric value

Frequency offsets (from the closest carrier) at which intermodulation power is measured

Default unit: Hz
<IMOrder>
3 | 5 | 3 5

Order of the intermodulation

3

IM order 3

5

IM order 5

3 5

IM orders 3 and 5

<RBW>
numeric value

Resolution bandwidth used for measurement

Default unit: Hz
<Power>
numeric value

Absolute or relative power level (to reference power) measured at IM frequency

Default unit: dBm/dB
<Limit>
numeric value

absolute or relative power level limit (to reference power)

Default unit: dBm/dB
<AbsRelMode>
ABS | REL

Determines whether absolute or relative power values are returned

<LimCheck>

Result of the limit check at this offset frequency

PASSED

power within limits

FAILED

power exceeds limit

Example: FETC:SPEC:MOD:OUT:ALL?
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Usage: Query only
Manual operation: See "Outer IM Table"


FETCh:WSPectrum:REFerence:POWer[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > MCWN Results > FETCh:WSPectrum:REFerence:POWer[:ALL]?
FETCh:WSPectrum:REFerence:POWer[:ALL]?

This command returns the measured power levels and reference powers of all active carriers.

Return values:
<CarrNo>
integer

Active carrier number

Range: 1..16
<RefType>

Indicates whether carrier is used for reference

REF

carrier selected for reference power

MAX

carrier has the highest power level, is used for reference power

NONE

normal carrier, not used for reference

*RST: RST value
<AbsCarrFreq>
numeric value

Absolute frequency at which power was measured

Default unit: Hz
<AbsPow>
numeric value

Measured power level (absolute)

Default unit: dBm
<AbsRef300>
numeric value

Reference power level (absolute) in a 300 kHz RBW

Default unit: dBm
<AbsRef100>
numeric value

Reference power level (absolute) in a 100 kHz RBW

Default unit: dBm
<AbsRef30>
numeric value

Reference power level (absolute) in a 30 kHz RBW

Default unit: dBm
Example: FETC:WSP:REF:POW?
Example:

See "Programming Example: Measuring the Wideband Noise for Multiple Carriers".

Usage: Query only
Manual operation: See "Carrier Power Table"


Retrieving Marker Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results
Retrieving Marker Results
Useful commands for retrieving marker results described elsewhere:
  • CALCulate<n>:​DELTamarker<m>:​Y?
Remote commands exclusive to retrieving marker results:
List of Commands
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:DELTamarker<m>:X

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4" See "X-value"


CALCulate<n>:DELTamarker<m>:X:RELative?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only


CALCulate<n>:DELTamarker<m>:Y?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only


CALCulate<n>:MARKer<m>:X

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:MARKer<m>:Y?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table"


Importing and Exporting I/Q Data and Results

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Importing and Exporting I/Q Data and Results
Importing and Exporting I/Q Data and Results

The I/Q data to be evaluated in the GSM application can not only be measured by the GSM application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the GSM application can be exported for further analysis in external applications.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

List of Commands
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe


MMEMory:LOAD:IQ:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Importing and Exporting I/Q Data and Results > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe 1,<FileName>

This command restores I/Q data from a file.

The file extension is *.iqw.

Parameters:
<FileName> | String containing the path and name of the source file.
Example: | MMEM:LOAD:IQ:STAT 1, 'C:\R_S\Instr\user\data.iqw' Loads IQ data from the specified file.
Usage: | Setting only


MMEMory:STORe:IQ:COMMent

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:COMMent <Comment>

This command adds a comment to a file that contains I/Q data.

Parameters:
<Comment> | String containing the comment.
Example: | MMEM:STOR:IQ:COMM 'Device test 1b' Creates a description for the export file. MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores I/Q data and the comment to the specified file.


MMEMory:STORe:IQ:STATe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.
Example: | See "Programming Example: Determining the EVM".


Status Reporting System

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System
Status Reporting System

The status reporting system stores all information on the current operating state of the instrument, e.g. information on errors or limit violations which have occurred. This information is stored in the status registers and in the error queue. The status registers and the error queue can be queried via IEC bus.

The GSM application uses the standard status registers of the R&S FSW. However, some registers are used differently. Only those differences are described in the following sections.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Description of the Status Registers

All the status registers are the same as those provided by the base system, with the exception of the following registers, which are provided by the R&S FSW and are not available from the R&S FSW GSM application command tree:

  • STATus:QUESTionable:ACPLimit
  • STATus:QUESTionable:LIMit2
  • STATus:QUESTionable:LMARgin<1|2>

The commands to query the contents of the following status registers are described in "Querying the Status Registers".

Contents
  • STATus:QUEStionable:SYNC Register
  • STATus:QUEStionable:DIQ Register
  • Querying the Status Registers


STATus:QUEStionable:SYNC Register

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:SYNC Register
STATus:QUEStionable:SYNC Register

The STATus:QUEStionable:SYNC register contains application-specific information about synchronization errors or errors during symbol detection. If any errors occur in this register, the status bit #11 in the STATus:QUEStionable register is set to 1.

Each active channel uses a separate STATus:QUEStionable:SYNC register. Thus, if the status bit #11 in the STATus:QUEStionable register indicates an error, the error may have occurred in any of the channel-specific STATus:QUEStionable:SYNC registers. In this case, you must check the register of each channel to determine which channel caused the error. By default, querying the status of a register always returns the result for the currently selected channel. However, you can specify any other channel name as a query parameter.

Meaning of the bits used in the STATus:QUEStionable:SYNC register
Bit No. | Meaning
0 | BURSt not found This bit is set if no burst is found in the measurements/premeasurements for phase/frequency error or carrier power vs time.
1 | SYNC not found This bit is set if the synchronization sequence (or training sequence) of the TSC is not found in the measurements/premeasurements for phase/frequency error or carrier power vs time.
2 to 14 | These bits are not used
15 | This bit is always 0


STATus:QUEStionable:DIQ Register

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register
STATus:QUEStionable:DIQ Register

This register contains information about the state of the digital I/Q input and output. This register is available with option Digital Baseband Interface (R&S FSW-B17)Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:DIQ register is indicated in bit 14 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​DIQ:​CONDition? and STATus:​QUEStionable:​DIQ[:​EVENt]?.

Bit No.

Meaning

0

Digital I/Q Input Device connected

This bit is set if a device is recognized and connected to the Digital Baseband Interface of the analyzer.

1

Digital I/Q Input Connection Protocol in progress

This bit is set while the connection between analyzer and digital baseband data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

2

Digital I/Q Input Connection Protocol error

This bit is set if an error occurred during establishing of the connect between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

3

Digital I/Q Input PLL unlocked

This bit is set if the PLL of the Digital I/Q input is out of lock due to missing or unstable clock provided by the connected Digital I/Q TX device. To solve the problem the Digital I/Q connection has to be newly initialized after the clock has been restored.

4

Digital I/Q Input DATA Error

This bit is set if the data from the Digital I/Q input module is erroneous. Possible reasons:

  • Bit errors in the data transmission. The bit will only be set if an error occurred at the current measurement.
  • Protocol or data header errors. May occurred at data synchronization problems or vast transmission errors. The bit will be set constantly and all data will be erroneous. To solve the problem the Digital I/Q connection has to be newly initialized.

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

5

not used

6

Digital I/Q Input FIFO Overload

This bit is set if the sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW. Possible solution:

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW

7

not used

8

Digital I/Q Output Device connected

This bit is set if a device is recognized and connected to the Digital I/Q Output.

9

Digital I/Q Output Connection Protocol in progress

This bit is set while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

10

Digital I/Q Output Connection Protocol error

This bit is set if an error occurred while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

11

Digital I/Q Output FIFO Overload

This bit is set if an overload of the Digital I/Q Output FIFO occurred. This happens if the output data rate is higher than the maximal data rate of the connected instrument. Reduce the sample rate to solve the problem.

12-14

not used

15

This bit is always set to 0.

List of Commands
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?


STATus:QUEStionable:DIQ:CONDition?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition? <ChannelName>

This command reads out the CONDition section of the STATus:QUEStionable:DIQ:CONDition status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ:COND?
Usage: | Query only


STATus:QUEStionable:DIQ:ENABle

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<SumBit>
Range: 0 to 65535
Usage: SCPI confirmed


STATus:QUEStionable:DIQ:NTRansition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ:PTRansition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>

This command controls the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ[:EVENt]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:DIQ register for IQ measurements.

Readout deletes the contents of the "EVENt" section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ?
Usage: | Query only


Querying the Status Registers

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers
Querying the Status Registers

The following commands are required to query the status of the R&S FSW and the GSM application.

For more information on the contents of the status registers see:

  • "STATus:QUEStionable:SYNC Register"
  • "STATus:QUEStionable:DIQ Register"
Contents
  • General Status Register Commands
  • Reading Out the EVENt Part
  • Reading Out the CONDition Part
  • Controlling the ENABle Part
  • Controlling the Negative Transition Part
  • Controlling the Positive Transition Part


General Status Register Commands

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > General Status Register Commands
General Status Register Commands
List of Commands
STATus:PRESet
STATus:QUEue[:NEXT]?


STATus:PRESet

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > General Status Register Commands > STATus:PRESet
STATus:PRESet

This command resets the edge detectors and ENABle parts of all registers to a defined value. All PTRansition parts are set to FFFFh, i.e. all transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition from 1 to 0 in a CONDition bit is not detected. The ENABle part of the STATus:OPERation and STATus:QUEStionable registers are set to 0, i.e. all events in these registers are not passed on.

Usage: Event


STATus:QUEue[:NEXT]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > General Status Register Commands > STATus:QUEue[:NEXT]?
STATus:QUEue[:NEXT]?

This command queries the most recent error queue entry and deletes it.

Positive error numbers indicate device-specific errors, negative error numbers are error messages defined by SCPI. If the error queue is empty, the error number 0, "No error", is returned.

Usage: Query only


Reading Out the EVENt Part

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Reading Out the EVENt Part
Reading Out the EVENt Part
List of Commands
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]?


STATus:OPERation[:EVENt]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Reading Out the EVENt Part > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]? <ChannelName>
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>
STATus:QUEStionable:LIMit<n>[:EVENt]? <ChannelName>
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Reading Out the CONDition Part

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Reading Out the CONDition Part
Reading Out the CONDition Part
List of Commands
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:SYNC:CONDition?


STATus:OPERation:CONDition?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Reading Out the CONDition Part > STATus:OPERation:CONDition?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition? <ChannelName>
STATus:QUEStionable:DIQ:CONDition? <ChannelName>
STATus:QUEStionable:LIMit<n>:CONDition? <ChannelName>
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Controlling the ENABle Part

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the ENABle Part
Controlling the ENABle Part
List of Commands
STATus:OPERation:ENABle
STATus:QUEStionable:ENABle
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:SYNC:ENABle


STATus:OPERation:ENABle

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the ENABle Part > STATus:OPERation:ENABle
STATus:OPERation:ENABle <SumBit>
STATus:QUEStionable:ENABle <SumBit>
STATus:QUEStionable:ACPLimit:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Negative Transition Part

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the Negative Transition Part
Controlling the Negative Transition Part
List of Commands
STATus:OPERation:NTRansition
STATus:QUEStionable:NTRansition
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:SYNC:NTRansition


STATus:OPERation:NTRansition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the Negative Transition Part > STATus:OPERation:NTRansition
STATus:OPERation:NTRansition <SumBit>
STATus:QUEStionable:NTRansition <SumBit>
STATus:QUEStionable:ACPLimit:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Positive Transition Part

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the Positive Transition Part
Controlling the Positive Transition Part
List of Commands
STATus:OPERation:PTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:OPERation:PTRansition

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Status Reporting System > Querying the Status Registers > Controlling the Positive Transition Part > STATus:OPERation:PTRansition
STATus:OPERation:PTRansition <SumBit>
STATus:QUEStionable:PTRansition <SumBit>
STATus:QUEStionable:ACPLimit:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Troubleshooting

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Troubleshooting
Troubleshooting

If problems occur, the instrument generates error messages which in most cases will be sufficient for you to detect the cause of an error and find a remedy.

In addition, our customer support centers are there to assist you in solving any problems that you may encounter with your R&S FSW. We will find solutions more quickly and efficiently if you provide us with information on the system configuration.

An .xml file with information on the system configuration ("device footprint") can be created automatically.

List of Commands
DIAGnostic:SERVice:SINFo?


DIAGnostic:SERVice:SINFo?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Troubleshooting > DIAGnostic:SERVice:SINFo?
DIAGnostic:SERVice:SINFo? <FileName>

This command creates a *.zip file with important support information. The *.zip file contains the system configuration information ("device footprint"), the current eeprom data and a screenshot of the screen display (if available).

This data is stored to the C:\R_S\Instr\user\ directory on the instrument. As a result of this command, the created file name (including the drive and path) is returned. You can use the resulting file name information as a parameter for the MMEM:COPY command to store the file on the controller PC.

If you contact the Rohde&Schwarz support to get help for a certain problem, send this file to the support in order to identify and solve the problem faster.

Return values:
<FileName>
C:\R_S\Instr\user\<R&S Device ID>_<CurrentDate>_<CurrentTime>

String containing the drive, path and file name of the created support file, where the file name consists of the following elements:

<R&S Device ID>: The unique R&S device ID indicated in the "Versions + Options" information

<CurrentDate>: The date on which the file is created (<YYYYMMDD>)

<CurrentTime>: The time at which the file is created (<HHMMSS>)

Example: DIAG:SERV:SINF?

Result:

"c:\R&S\instr\user\FSW-26_1312.8000K26-100005-xx_20130116_165858.zip"

Copy to controller PC:

MMEM:COPY "c:\R&S\instr\user\FSW-26_
1312.8000K26-100005-xx_20130116_165858.zip",
"S:\Debug\FSW-26_1312.8000K26-100005-xx_
20130116_165858.zip"
Usage: Query only


Deprecated Commands (Commands for Compatibility)

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility)
Deprecated Commands (Commands for Compatibility)

Note that the following commands are maintained for compatibility reasons only. Use the specified alternative commands for new remote control programs.

List of Commands
CONFigure:BURSt:ETIMe[:IMMediate]
CONFigure:BURSt:MACCuracy[:IMMediate]
CONFigure:BURSt:MERRor[:IMMediate]
CONFigure:BURSt:PFERror[:IMMediate]
CONFigure:BURSt:PTEMplate[:IMMediate]
CONFigure:BURSt:PTEMplate:SELect
CONFigure:SPECtrum:MODulation[:IMMediate]
CONFigure:SPECtrum:SELect
CONFigure:SPECtrum:SWITching[:IMMediate]
CONFigure:TRGS[:IMMediate]
CONFigure:WSPectrum:MODulation[:IMMediate]
CONFigure[:MS]:MULTi:BURSt:CONStell
CONFigure[:MS]:MULTi:BURSt:DEModulation
CONFigure[:MS]:MULTi:BURSt:PTEMplate
CONFigure[:MS]:MULTi:SPECtrum:MODulation
CONFigure[:MS]:MULTi:SPECtrum:SWITching
CONFigure[:MS]:MULTi:STATe
CONFigure[:MS]:BSEarch
CONFigure[:MS]:BSTHreshold
CONFigure[:MS]:MCARrier:ACTCarriers
CONFigure[:MS]:MCARrier:BTSClass
CONFigure[:MS]:MCARrier:FILTer
CONFigure[:MS]:MCARrier[:STATe]
CONFigure[:MS]:MCARrier:MCBTs
CONFigure[:MS]:MTYPe
CONFigure[:MS]:POWer:AUTO ONCE
CONFigure[:MS]:SSEarch
CONFigure:WSPectrum:MODulation:LIMIT
FETCh:BURSt[:MACCuracy]:FERRor:AVERage?
FETCh:BURSt[:MACCuracy]:FERRor:CURRent?
FETCh:BURSt[:MACCuracy]:FERRor:MAXimum?
FETCh:BURSt[:MACCuracy]:FERRor:SDEViation?
READ:BURSt[:MACCuracy]:FERRor:AVERage?
READ:BURSt[:MACCuracy]:FERRor:CURRent?
READ:BURSt[:MACCuracy]:FERRor:MAXimum?
READ:BURSt[:MACCuracy]:FERRor:SDEViation?
FETCh:WSPectrum:MODulation[:ALL]?
READ:WSPectrum:MODulation[:ALL]?
FETCh:WSPectrum:MODulation:REFerence?
READ:WSPectrum:MODulation:REFerence[:IMMediate]?
READ:AUTO:LEVTime?
READ:SPECtrum:WMODulation:GATing?


CONFigure:BURSt:ETIMe[:IMMediate]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure:BURSt:ETIMe[:IMMediate]
CONFigure:BURSt:ETIMe[:IMMediate]
CONFigure:BURSt:MACCuracy[:IMMediate]
CONFigure:BURSt:MERRor[:IMMediate]
CONFigure:BURSt:PFERror[:IMMediate]
CONFigure:BURSt:PTEMplate[:IMMediate]
CONFigure:BURSt:PTEMplate:SELect <Value>
CONFigure:SPECtrum:MODulation[:IMMediate]
CONFigure:SPECtrum:SELect <Mode>
CONFigure:SPECtrum:SWITching[:IMMediate]
CONFigure:TRGS[:IMMediate]
CONFigure:WSPectrum:MODulation[:IMMediate]

These commands select a specific result display. They are maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Usage: Setting only


CONFigure[:MS]:MULTi:BURSt:CONStell

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MULTi:BURSt:CONStell
CONFigure[:MS]:MULTi:BURSt:CONStell <State>
CONFigure[:MS]:MULTi:BURSt:DEModulation <State>
CONFigure[:MS]:MULTi:BURSt:PTEMplate <State>
CONFigure[:MS]:MULTi:SPECtrum:MODulation <State>
CONFigure[:MS]:MULTi:SPECtrum:SWITching <State>
CONFigure[:MS]:MULTi:STATe <State>

These commands are maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Note: To be backwards compatible to R&S FSV-K10, activating multi-measurement mode (using CONFigure[:MS]:MULTi:STATe) sets the "Frequency List" parameter to "1.8 MHz" (see "Modulation Spectrum Table: Frequency List"). Deactivating this mode sets the frequency list to "1.8 MHz (sparse)".


CONFigure[:MS]:BSEarch

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:BSEarch
CONFigure[:MS]:BSEarch <State>

This command toggles between active burst search and inactive burst search.

Note

This command is retained for compatibility with R&S FS-K5 only. Use CONFigure:MS:SYNC:MODE BURSt or CONFigure:MS:SYNC:MODE ALL instead (see CONFigure[:​MS]:​SYNC:​MODE).

Parameters for setting and query:
<State>
1 | 0 | ON | OFF
ON

Burst search on

OFF

Burst search off

*RST: 1


CONFigure[:MS]:BSTHreshold

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:BSTHreshold
CONFigure[:MS]:BSTHreshold <Value>

This command changes the burst find threshold.

Note

This command is retained for compatibility with R&S FS-K5 only. Due to the improved measurement capabilities of this GSM analysis software, this remote control command (and the function behind) is not required any more.

Parameters for setting and query:
<Value>
numeric value

Threshold for burst detection

Default unit: dB
Example: CONF:BSTH 10 DB
Mode: GSM


CONFigure[:MS]:MCARrier:ACTCarriers

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MCARrier:ACTCarriers
CONFigure[:MS]:MCARrier:ACTCarriers <NofActCarriers>

This parameter specifies the total number of active carriers of the multicarrier BTS to be measured. Its value affects the calculation of the limits according to the 3GPP standard for the modulation spectrum measurement, see 3GPP2 TS 45.005 (chapter 4.2.1. "Spectrum due to modulation and wide band noise"). The limit is changed by 10*log(N).

Note that this command is maintained for compatibility reasons only. For new remote control programs, the number of active carriers is determined by the CONFigure[:​MS]:​MCARrier:​CARRier<c>[:​STATe]? commands. The multicarrier device type is defined using the CONFigure[:​MS]:​DEVice:​TYPE command.

Parameters for setting and query:
<NofActCarriers>
*RST: | 1
Default unit: | NONE
Example:

New program:

CONFigure:MS:DEVice:TYPE MCBWide
CONFigure:MS:MCARrier:CARRier1:STATe ON
CONFigure:MS:MCARrier:CARRier2:STATe ON
...
CONFigure:MS:MCARrier:CARRier<NofActCarriers>:STATe ON


CONFigure[:MS]:MCARrier:BTSClass

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MCARrier:BTSClass
CONFigure[:MS]:MCARrier:BTSClass <BTSClass>

This command defines the base station class. The specified BTS Class effects the calculation of the limits according to the 3GPP standard for the modulation spectrum measurement, see 3GPP2 TS 45.005 (chapter 4.2.1. "Spectrum due to modulation and wide band noise" and chapter 4.3.2 "Base Transceiver Station", search for "Multicarrier BTS").

Note that this command is maintained for compatibility reasons only.

Parameters for setting and query:
<BTSClass>
Range: | 1 to 2
*RST: | 1
Default unit: | NONE
Example: CONF:MCAR:BTSClass


CONFigure[:MS]:MCARrier:FILTer

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MCARrier:FILTer
CONFigure[:MS]:MCARrier:FILTer <Type>

This command controls the filter used to reduce the measurement bandwidth for multicarrier "Power vs Time" measurements.

Parameters for setting and query:
<Type>
MC400 | MC300
MC400

Recommended for measurements with multi channels of equal power.

MC300

Recommended for measurement scenarios where a total of six channels is active and the channel to be measured has a reduced power (e.g. 30 dB) compared to its adjacent channels.

The PvT filter is optimized to get smooth edges after filtering burst signals and to suppress adjacent, active channels.

*RST: MC400
Example: CONF:MCAR:FILT MC400


CONFigure[:MS]:MCARrier[:STATe]

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MCARrier[:STATe]
CONFigure[:MS]:MCARrier[:STATe] <State>
CONFigure[:MS]:MCARrier:MCBTs <MultiCarrierBTS>

This command informs the R&S FSW-K10 that the measured signal is a multicarrier signal. If active, a special multicarrier filter is switched into the demodulation path and further multicarrier-specific parameters become available.

Note that this command is maintained for compatibility reasons only. For new remote control programs, select a multicarrier device type using CONFigure[:​MS]:​DEVice:​TYPE.

Parameters for setting and query:
<MultiCarrierBTS>
ON | OFF
ON

Sets the device type to "Multicarrier BTS Wide Area"

OFF

Sets the device type to "BTS Normal"

*RST: OFF
Example: CONF:MCAR:MCBT ON

New program (example):

CONFigure:MS:DEVice:TYPE MCBWide
Example: CONF:MCAR:MCBT OFF

New program (example):

:CONFigure:MS:DEVice:TYPE BTSNormal


CONFigure[:MS]:MTYPe

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:MTYPe
CONFigure[:MS]:MTYPe <Value>

This command sets the modulation type of all slots.

Note: This command is retained for compatibility with R&S FS-K5 only.

Parameters for setting and query:
<Value>
GMSK | EDGE

Modulation type

*RST: GMSK
Example:

// Enter the GSM option K10

INSTrument:SELect GSM

// Old FS-K5 commands

CONFigure:MS:MTYPe EDGE

// Please use the following K10 commands instead

// K5: 'GMSK' -> K10: 'GMSK'

// K5: 'EDGE' -> K10: 'PSK8'

CONFigure:MS:CHANnel:SLOT0:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT1:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT2:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT3:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT4:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT5:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT6:MTYPe PSK8
CONFigure:MS:CHANnel:SLOT7:MTYPe PSK8

// Old FS-K5 commands

CONFigure:MS:CHANnel:SLOT1:MTYPe GMSK
CONFigure:MS:CHANnel:SLOT1:MTYPe?

// -> GMSK

// Please use the following K10 commands instead

CONFigure:MS:CHANnel:MSLots:MEASure?

// -> 0 This is the slot number of the 'slot to measure'

// Set and query the modulation of the 'slot to measure'

CONFigure:MS:CHANnel:SLOT0:MTYPe GMSK
CONFigure:MS:CHANnel:SLOT0:MTYPe?

// -> GMSK

Mode: GSM


CONFigure[:MS]:POWer:AUTO ONCE

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:POWer:AUTO ONCE
CONFigure[:MS]:POWer:AUTO ONCE

This command is used to perform an auto level measurement immediately.

Note that this command is maintained for compatibility reasons only. Use CONFigure[:​MS]:​AUTO:​LEVel ONCE for new remote control programs.


CONFigure[:MS]:SSEarch

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure[:MS]:SSEarch
CONFigure[:MS]:SSEarch <State>

This command is retained for compatibility with R&S FSW-K5 only. In new K10 remote scripts use CONFigure:MS:SYNC:MODE TSC or CONFigure:MS:SYNC:MODE ALL instead (see CONFigure[:​MS]:​SYNC:​MODE).

Parameters for setting and query:
<State>
1 | 0 | ON | OFF
ON

TSC search on

OFF

TSC search off

*RST: 1
Example: CONF:SSE ON


CONFigure:WSPectrum:MODulation:LIMIT

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > CONFigure:WSPectrum:MODulation:LIMIT
CONFigure:WSPectrum:MODulation:LIMIT <Mode>

This command selects whether the list results (power and limit values) of the "(Wide) Modulation Spectrum" measurement are returned in a relative (dB) or absolute (dBm) unit. This command is only available when the "Wide Modulation Spectrum" measurement is selected (see CONFigure:​WSPectrum:​MODulation[:​IMMediate]).

Note that this command is maintained for compatibility reasons only. Use the CONFigure:​SPECtrum:​MODulation:​LIMIT command for new remote control programs.

Parameters for setting and query:
<Mode>
ABSolute | RELative
*RST: RELative
Example:

// Select Wide Modulation Spectrum measurement

// (gated zero span measurement)

CONFigure:WSPectrum:MODulation:IMMediate

// Absolute power and limit results in dBm

CONFigure:WSPectrum:MODulation:LIMit ABSolute

// Run one measurement and query absolute list results

READ:WSPectrum:MODulation:ALL?

// -> 0,929200000,929200000,-104.41,-65.00,ABS,PASSED, ...


FETCh:BURSt[:MACCuracy]:FERRor:AVERage?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > FETCh:BURSt[:MACCuracy]:FERRor:AVERage?
FETCh:BURSt[:MACCuracy]:FERRor:AVERage?
FETCh:BURSt[:MACCuracy]:FERRor:CURRent?
FETCh:BURSt[:MACCuracy]:FERRor:MAXimum?
FETCh:BURSt[:MACCuracy]:FERRor:SDEViation?
READ:BURSt[:MACCuracy]:FERRor:AVERage?
READ:BURSt[:MACCuracy]:FERRor:CURRent?
READ:BURSt[:MACCuracy]:FERRor:MAXimum?
READ:BURSt[:MACCuracy]:FERRor:SDEViation?

This command starts the measurement and reads out the result of the Frequency Error.

This command is retained for compatibility with R&S FS-K5 only. Use the READ:BURSt[:MACCuracy]:FREQuency or FETCh:BURSt[:MACCuracy]:FREQuency commands in newer remote control programs.

Return values:
<Result>
numeric value

Frequency error

Default unit: Hz
Example: READ:BURS:FERR:SDEV?
Usage: Query only


FETCh:WSPectrum:MODulation[:ALL]?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > FETCh:WSPectrum:MODulation[:ALL]?
FETCh:WSPectrum:MODulation[:ALL]?
READ:WSPectrum:MODulation[:ALL]?

This command starts the measurement and reads out the result of the measurement of the "Modulation Spectrum" of the mobile or base station.

These commands are retained for compatibility with previous R&S signal and spectrum analyzers only. For newer remote control programs, use the READ:​SPECtrum:​MODulation[:​ALL]? or FETCh:​SPECtrum:​MODulation[:​ALL]? commands instead.

The result is a list of partial result strings separated by commas.

Return values:
<Placeholder> | curently irrelevant
<Freq1> | Absolute offset frequency in Hz
<Freq2> | Absolute offset frequency in Hz
<Level> | Measured level at the offset frequency in dB or dBm.
<Limit> | Limit at the offset frequency in dB or dBm.
<Abs/Rel> | Indicates whether relative (dB) or absolute (dBm) limit and level values are returned.
<Status> | Result of the limit check in character data form PASSED no limit exceeded FAILED limit exceeded
Example: | READ:WSP:MOD? 0,998200000,998200000,-84.61,-56.85,REL,PASSED, 0,998400000,998400000,-85.20,-56.85,REL,PASSED, ...
Usage: | Query only


FETCh:WSPectrum:MODulation:REFerence?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > FETCh:WSPectrum:MODulation:REFerence?
FETCh:WSPectrum:MODulation:REFerence?
READ:WSPectrum:MODulation:REFerence[:IMMediate]?

This command starts the measurement and returns the measured reference power of the "Modulation Spectrum".

These commands are retained for compatibility with previous R&S signal and spectrum analyzers only. For newer remote control programs, use the READ:​SPECtrum:​MODulation:​REFerence[:​IMMediate]? or FETCh:​SPECtrum:​MODulation:​REFerence? commands instead.

The result is a list of partial result strings separated by commas.

Return values:
<Level1> | measured reference power in dBm
<Level2> | measured reference power in dBm
<RBW> | resolution bandwidth used to measure the reference power in Hz
Example: | READ:WSPectrum:MODulation:REFerence:IMMediate?
Usage: | Query only


READ:AUTO:LEVTime?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > READ:AUTO:LEVTime?
READ:AUTO:LEVTime?

This command is used to perform a single measurement to detect the required reference level and the trigger offset automatically.

Note that this command is maintained for compatibility reasons only. Use CONFigure[:​MS]:​AUTO:​LEVel ONCE and CONFigure[:​MS]:​AUTO:​TRIGger ONCE for new remote control programs.

Parameters:
PASSED

Fixed value; irrelevant

<Dummy>

Fixed value (0); irrelevant

Return values:
<ReferenceLevel>

The detected reference level

Default unit: variable
<TriggerOffset>

The detected time offset between the trigger event and the start of the sweep

<TriggerLevel>

The detected trigger level

Range: -50 dBm to 20 dBm
Example: READ:AUTO:LEVT?
// --> PASSED,9.2404,-0.00000007695,1.4,0
Usage: Query only


READ:SPECtrum:WMODulation:GATing?

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Deprecated Commands (Commands for Compatibility) > READ:SPECtrum:WMODulation:GATing?
READ:SPECtrum:WMODulation:GATing?

This command reads out the gating settings for gated Wide Modulation Spectrum measurements. It is identical to READ:​SPECtrum:​WMODulation:​GATing? and is maintained for compatibility reasons only.

Example: | READ:SPEC:WMOD:GAT?
Usage: | Query only
Mode: | GSM


Programming Examples

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples
Programming Examples

The following examples demonstrate how to configure and perform GSM measurements in a remote environment.

Contents
  • Programming Example: Determining the EVM
  • Programming Example: Measuring an AQPSK Signal
  • Programming Example: Measuring the Power for Access Bursts
  • Programming Example: Measuring Statistics
  • Programming Example: Measuring the Wideband Noise for Multiple Carriers


Programming Example: Determining the EVM

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples > Programming Example: Determining the EVM
Programming Example: Determining the EVM

This example demonstrates how to configure an EVM measurement in a remote environment.

//---------- Preparing the application ------------
// Preset the instrument
*RST
// Enter the GSM option K10
INSTrument:SELect GSM
// Switch to single sweep mode and stop sweep
INITiate:CONTinuous OFF;:ABORt

//---------- Frequency and Level ---------------------
// Set center frequency to 935 MHz
SENSe:FREQuency:CENTer 935 MHZ

// Set Ref. Level to 10 dBm
DISPlay:WINDow:TRACe:Y:SCALe:RLEVel:RF 10 DBM

//---------- Trigger settings --------------------
// Use these settings only if an external trigger is connected
// to the TRIGGER INPUT connector on the front panel of the analyzer.
// Otherwise ignore these commands.
// Define the use of an external trigger.
TRIGger:SOURce EXT
// Determine the offset from the trigger event to the frame start
// (start of active part of slot 0).
// Define a trigger offset of 2 µs.
TRIGger:HOLD 2us

//---------- Configuring Data Acquisition ---------------------
// Define a capture time of 1 second (>200 GSM frames)
SENSe:SWEep:TIME 1 s
// Define a statistic count of 200, i.e. 200 GSM frames are evaluated statistically.
SENSe:SWEep:COUNt 200

//---------- Configuring the result display ------------
// Delete result display 3 and 4 and
// activate the following result displays:
// 1: Magnitude Capture (default, upper left)
// 2: PvT Full burst (default, below Mag Capt)
// 3: Modulation Accuracy (next to Mag Capt)
// 4: Modulation Spectrum Table (next to PvT)
// 5: EVM vs Time measurement (full width, bottom)
LAYout:REMove '3'
LAYout:REMove '4'
LAYout:ADD:WINDow? '1',RIGH,MACC
LAYout:ADD:WINDow? '2',RIGH,MST
LAYout:ADD:WINDow? '2',BEL,ETIMe

//---------- Signal Description ------------
// Configure a base station DUT with normal power class 1
CONFigure:MS:DEV:TYPE BTSNormal
CONFigure:MS:NETWORK PGSM
CONFigure:MS:NETWORK:FREQ:BAND 900
CONFigure:MS:POW:CLAS 1

//---------- Frame/slot configuration ------------
CONFigure:MS:CHANnel:FRAM:EQU OFF
// Set slot 1: On, Higher Symbol Rate burst, 16QAM, Wide Pulse, TSC 0
CONFigure:MS:CHANnel:SLOT1:STATe ON
CONFigure:MS:CHANnel:SLOT1:TYPE HB
CONFigure:MS:CHANnel:SLOT1:MTYPe QAM16
CONFigure:MS:CHANnel:SLOT1:FILTer WIDE
CONFigure:MS:CHANnel:SLOT1:TSC 0

// Set slot 2: On, Normal burst, GMSK modulation, TSC 3 (Set 1)
CONFigure:MS:CHANnel:SLOT2:STATe ON
CONFigure:MS:CHANnel:SLOT2:TYPE NB
CONFigure:MS:CHANnel:SLOT2:MTYPe GMSK
CONFigure:MS:CHANnel:SLOT2:TSC 3,1
// Query TSC number
CONFigure:MS:CHANnel:SLOT2:TSC? TSC
// -> 3
// Query Set number
CONFigure:MS:CHANnel:SLOT2:TSC? SET
// -> 1

// Set slot 3: On, Normal burst, GMSK modulation, User-defined TSC
CONFigure:MS:CHANnel:SLOT3:STATe ON
CONFigure:MS:CHANnel:SLOT3:TYPE NB
CONFigure:MS:CHANnel:SLOT3:MTYPe GMSK
CONFigure:MS:CHANnel:SLOT3:TSC USER
CONFigure:MS:CHANnel:SLOT3:TSC?
// -> USER
// Set User TSC bits
CONFigure:MS:CHANnel:SLOT3:TSC:USER '10111101100110010000100001'
// Query User TSC bits
CONFigure:MS:CHANnel:SLOT3:TSC:USER?
// -> 10111101100110010000100001

// Set slot 4: Off
CONFigure:MS:CHANnel:SLOT4:STATe OFF

// Set slot 5: Off
CONFigure:MS:CHANnel:SLOT5:STATe OFF

// Set slot 6: Off
CONFigure:MS:CHANnel:SLOT6:STATe OFF

// Set slot 7: Off
CONFigure:MS:CHANnel:SLOT7:STATe OFF

//---------- Demodulation and Slot Scope------------
// Configure slot 1 (slot to measure) for single-slot measurements,
// (e.g. EVM, modulation spectrum).
CONFigure:MS:CHANnel:MSLots:MEASure 1
// Configure slots 0-3 for multi-slot measurements
// (e.g. PvT, transient spectrum).
// Set First slot to measure = 0
// Set No. of slots to measure = 4
CONFigure:MS:CHANnel:MSLots:NOFSlots 4
CONFigure:MS:CHANnel:MSLots:OFFSet 0
// Use 'sequence estimator' for the symbol decision
CONFigure:MS:DEMod:DECision SEQuence
// Replace detected Tail & TSC bits by the standard bits
CONFigure:MS:DEMod:STDBits STD

//---------- PvT Measurement settings -----------------
// Use Gaussian PvT filter with 500 kHz for single-carrier BTS
CONFigure:BURSt:PTEMplate:FILTer G500
// Align the limit line to mid of TSC for each slot.
CONFigure:BURSt:PTEMplate:TALign PSL

//---------- Spectrum Measurement settings -----------------
// Absolute power and limit (remote) results in dBm
CONFigure:SPECtrum:MODulation:LIMit ABSolute
// Use compact version of narrow frequency list to save time
CONFigure:WSPectrum:MODulation:LIST:SELect NSParse

//---------- Performing the Measurements-----
INITiate:IMMediate;*WAI

//---------- Retrieving Results-------------

// Read trace data in binary format
FORMat:DATA REAL,32

// Query current magnitude capture trace data
TRACe1:DATA? TRACe1
//-> trace data

// Query the current power vs time trace
TRACe2:DATA? TRACe4
//-> trace data

// Query the result of the power vs time limit check for max trace
CALCulate2:LIMit1:FAIL?
// -> 1

// Query max EVM trace data
TRACe5:DATA? TRACe2
//-> trace data

// Query the maximum EVM value for slot 1 (slot to measure) in current measurement
FETCh:BURSt:MACCuracy:EVM:PEAK:CURR?
// -> 0.62063819169998169

// Query the maximum EVM value for slot 1 (slot to measure) in all 200
// measured GSM frames
FETCh:BURSt:MACCuracy:EVM:PEAK:MAX?
// -> 0.76938760280609131

// Query the averaged EVM RMS value for slot 1 (slot to measure) in all 200
// measured GSM frames
FETCh:BURSt:MACCuracy:EVM:RMS:AVERage?
// -> 0.19639170169830322

// Query the absolute mod spectrum table results
FETCH:SPECtrum:MODulation:ALL?
// -> 00,933200000,933200000,-86.36,-70.23,ABS,PASSED, ...
// Query the reference power of the mod spectrum
FETCh:SPECtrum:MODulation:REFerence?
// -> -11.13,-11.13,30000

//---------- Exporting Captured I/Q Data-------------

// Query the sample rate for the captured I/Q data
// Note: The returned value depends on
// - Capture time: SENSe:SWEep:TIME?
// - Mod frequency list: CONFigure:WSPectrum:MODulation:LIST:SELect?
// Therefore only query the sample rate afterwards.
TRACe:IQ:SRATe?
// -> 6500000

// The number of samples can be calculated as follows
// floor((CaptureTime + 577 us) * SampleRate) =
// = floor((1s + 577 us) * 6.5 MHz)
// = floor(6503750.5)
// = 6503750 samples
// Query the captured I/Q data
TRACe1:IQ:DATA:MEMory? 0,6503750

// Alternatively store the captured I/Q data to a file.
MMEMory:STORe:IQ:STATe 1, 'C:\R_S\Instr\user\data.iq.tar'


Programming Example: Measuring an AQPSK Signal

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples > Programming Example: Measuring an AQPSK Signal
Programming Example: Measuring an AQPSK Signal

This example demonstrates how to configure a GSM measurement of an AQPSK modulated signal in a remote environment.

//------------ Preparing the application ------------
// Preset the instrument
*RST
// Enter the GSM option K10
INSTrument:SELect GSM
// Switch to single sweep mode and stop sweep
INITiate:CONTinuous OFF;:ABORt

//---------- Frequency and Level ---------------------
// Set center frequency to 935 MHz
SENSe:FREQuency:CENTer 935 MHZ

// Set Ref. Level to 10 dBm
DISPlay:WINDow:TRACe:Y:SCALe:RLEVel:RF 10 DBM

//----------- Slot 0 configuration ------------
// Setup slot 0 for VAMOS AQPSK modulation
// Activate slot
CONFigure:MS:CHANnel:SLOT0:STATe ON
// Normal burst
CONFigure:MS:CHANnel:SLOT0:TYPE NB
// AQPSK (VAMOS) modulation
CONFigure:MS:CHANnel:SLOT0:MTYPe AQPSk
// Subchannel Power Imbalance Ratio (SCPIR) = 4 dB
CONFigure:MS:CHANnel:SLOT0:SCPir 4
// Subchannel 1: User TSC
CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC USER
CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC?
// -> USER
// Subchannel 1: Set User TSC bits
CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC:USER '10111101100110010000100001'
// Subchannel 1: Query User TSC bits
CONFigure:MS:CHANnel:SLOT0:SUBChannel1:TSC:USER?
// -> 10111101100110010000100001
// Subchannel 2: User TSC
CONFigure:MS:CHANnel:SLOT0:SUBChannel2:TSC USER
CONFigure:MS:CHANnel:SLOT0:SUBChannel2:TSC?
// -> USER
// Subchannel 2: Set User TSC bits
CONFigure:MS:CHANnel:SLOT0:SUBChannel2:TSC:USER '11010111111101011001110100'
// Subchannel 2: Query User TSC bits
CONFigure:MS:CHANnel:SLOT0:SUBChannel2:TSC:USER?
// -> 11010111111101011001110100

//----------- Slot 1 configuration ------------
// Activate slot 1
CONFigure:MS:CHANnel:SLOT1:STATe ON
// Normal Burst
CONFigure:MS:CHANnel:SLOT1:TYPE NB
// AQPSK (VAMOS) modulation
CONFigure:MS:CHANnel:SLOT1:MTYPe AQPSk
// Subchannel 1: TSC 0 (Set 1)
CONFigure:MS:CHANnel:SLOT1:SUBChannel1:TSC 0,1
// Subchannel 1: Query TSC number and Set number
CONFigure:MS:CHANnel:SLOT1:SUBChannel1:TSC?
// -> 0,1
// Subchannel 1: Query TSC number
CONFigure:MS:CHANnel:SLOT1:SUBChannel1:TSC? TSC
// -> 0
// Subchannel 1: Query Set number
CONFigure:MS:CHANnel:SLOT1:SUBChannel1:TSC? SET
// -> 1
// Subchannel 2: TSC 0 (Set 1)
CONFigure:MS:CHANnel:SLOT1:SUBChannel2:TSC 0,2
// Subchannel 2: Query TSC number and Set number
CONFigure:MS:CHANnel:SLOT1:SUBChannel2:TSC?
// -> 0,2
// Subchannel 2: Query TSC number
CONFigure:MS:CHANnel:SLOT1:SUBChannel2:TSC? TSC
// -> 0
// Subchannel 2: Query Set number
CONFigure:MS:CHANnel:SLOT1:SUBChannel2:TSC? SET
// -> 2

//----------- Slot 2-7 configuration ------------
CONFigure:MS:CHANnel:SLOT2:STATe OFF
CONFigure:MS:CHANnel:SLOT3:STATe OFF
CONFigure:MS:CHANnel:SLOT4:STATe OFF
CONFigure:MS:CHANnel:SLOT5:STATe OFF
CONFigure:MS:CHANnel:SLOT6:STATe OFF
CONFigure:MS:CHANnel:SLOT7:STATe OFF

//---------- Demodulation and Slot Scope------------
// Configure slot 0 (slot to measure) for single-slot measurements,
// (e.g. EVM, modulation spectrum).
CONFigure:MS:CHANnel:MSL:MEASure 0
// Configure slots 0-1 for multi-slot measurements
// (e.g. PvT, transient spectrum).
// Set First slot to measure = 0
// Set No. of slots to measure =2
CONFigure:MS:CHANnel:MSL:NOFS 2
CONFigure:MS:CHANnel:MSL:OFFSet 0
// Use 'sequence estimator' for the symbol decision
CONFigure:MS:DEMod:DECision SEQuence

//---------- Configuring Data Acquisition ---------------------
// Define a statistic count of 10, i.e. 10 GSM frames are evaluated statistically.
SENSe:SWEep:COUNt 10

// Define a capture time for 10 (statistic count) + 2 (headroom) GSM frames
// Capture Time = (10+2) frames * 4.615 ms/frame = 0.0554 s
// Thus all 10 (statistic count) frames can be analyzed with a single capture.
SENSe:SWEep:TIME 0.0554 s

//--------------Performing the Measurement-----
// Initiates a new measurement and waits until the sweep has finished.
INITiate:IMMediate;*WAI

//---------------Retrieving Results-------------
// Query the maximum EVM value for slot 0 (slot to measure) in current GSM frame
FETCh:BURSt:MACCuracy:EVM:PEAK:CURR?
// -> 0.62063819169998169
// Query the maximum EVM value for slot 0 (slot to measure) in all 10
//(statistic count) GSM frames
FETCh:BURSt:MACCuracy:EVM:PEAK:MAX?
// -> 0.76938760280609131
// Query the averaged EVM RMS value for slot 1 (slot to measure) in all 10
// (statistic count) GSM frames
FETCh:BURSt:MACCuracy:EVM:RMS:AVERage?
// -> 0.19639170169830322


Programming Example: Measuring the Power for Access Bursts

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples > Programming Example: Measuring the Power for Access Bursts
Programming Example: Measuring the Power for Access Bursts

This example demonstrates how to configure a GSM power measurement of a GMSK modulated signal with access bursts in a remote environment.

//------------ Preparing the application ------------
// Preset the instrument
*RST
// Enter the GSM option K10
INSTrument:SELect GSM
// Switch to single sweep mode and stop sweep
INITiate:CONTinuous OFF;:ABORt

//---------- Frequency and Level ---------------------
// Set center frequency to 935 MHz
SENSe:FREQuency:CENTer 935 MHZ

// Set Ref. Level to 10 dBm
DISPlay:WINDow:TRACe:Y:SCALe:RLEVel:RF 10 DBM

//----------- Slot 0 configuration ------------
// Activate slot 0
CONFigure:MS:CHANnel:SLOT0:STATe ON
// Normal Burst
CONFigure:MS:CHANnel:SLOT0:TYPE NB
// GMSK modulation
CONFigure:MS:CHANnel:SLOT0:MTYPe GMSK
// TSC 0 (Set 1)
CONFigure:MS:CHANnel:SLOT0:TSC 0,1

//----------- Slot 1 configuration ------------
// Activate slot 1
CONFigure:MS:CHANnel:SLOT1:STATe ON
// Access Burst
CONFigure:MS:CHANnel:SLOT1:TYPE AB
// Set TS0
CONFigure:MS:CHANnel:SLOT1:TSC TS0
// Query TS
CONFigure:MS:CHANnel:SLOT1:TSC?
// -> TS0
// Access burst has a timing advance (offset) from slot start of 1 symbol
CONFigure:MS:CHANnel:SLOT1:TADV 1

//----------- Slot 2-7 configuration ------------
CONFigure:MS:CHANnel:SLOT2:STATe OFF
CONFigure:MS:CHANnel:SLOT3:STATe OFF
CONFigure:MS:CHANnel:SLOT4:STATe OFF
CONFigure:MS:CHANnel:SLOT5:STATe OFF
CONFigure:MS:CHANnel:SLOT6:STATe OFF
CONFigure:MS:CHANnel:SLOT7:STATe OFF

//---------- Demodulation and Slot Scope------------
// Configure slot 1 (slot to measure) for single-slot measurements,
// (e.g. phase error, modulation spectrum).
CONF:CHAN:MSL:MEAS 1
// Configure slot 0-1 for multi-slot measurements
// (e.g. PvT, transient spectrum).
// Set First slot to measure = 0
// Set No. of slots to measure = 2
CONF:CHAN:MSL:NOFS 2
CONF:CHAN:MSL:OFFS 0

//---------- PvT Measurement settings -----------------
// Check PvT filter
CONF:BURS:PTEM:FILT?
// -> G1000

// Align the limit line to mid of TSC/TS for each slot.
CONF:BURS:PTEM:TAL PSL

//--------------Performing the Measurement-----
// Initiates a new measurement and waits until the sweep has finished.
INITiate:IMMediate;*WAI

//---------------Retrieving Results-------------

// In PvT limits are checked against the max in min traces.
// Query the max power vs time trace
TRAC2:DATA? TRACe2
// Query the result of the power vs time limit check for max trace
CALCulate2:LIMit1:FAIL?
// -> 0
// Query the min power vs time trace
TRAC2:DATA? TRACe3
// Query the result of the power vs time limit check for min trace
CALCulate2:LIMit2:FAIL?
// -> 0
// Query the result of the power vs time limit check for slot 0
FETCh:BURSt:SPOWer:SLOT0:LIM:FAIL?
// -> 0
// Query the result of the power vs time limit check for slot 1
FETCh:BURSt:SPOWer:SLOT1:LIM:FAIL?
// -> 0

// Query the maximum phase error value for slot 1 (slot to measure) in
// current GSM frame
FETCh:BURSt:MACCuracy:PERRor:PEAK:CURR?
// -> -0.21559642255306244
// Query the maximum phase error value for slot 1 (slot to measure) in
// all 200 GSM frames
FETCh:BURSt:MACCuracy:PERRor:PEAK:MAX?
// -> 0.35961171984672546
// Query the averaged phase error RMS value for slot 1 (slot to measure) in
// all 200 GSM frames
FETCh:BURSt:MACCuracy:PERRor:RMS:AVERage?
// -> 0.082186274230480194


Programming Example: Measuring Statistics

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples > Programming Example: Measuring Statistics
Programming Example: Measuring Statistics

This example demonstrates how to determine statistical values for a measurement in a remote environment.

-----------Configuring the measurement ------------
*RST
//Reset the instrument
CALC:MARK:FUNC:POW:SEL OBW
//Activate occupied bandwidth measurement.

--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

---------------Retrieving Results-------------
CALC:MARK:FUNC:POW:RES? OBW
//Returns the results for the OBW measurement.


Programming Example: Measuring the Wideband Noise for Multiple Carriers

GSM application (R&S FSW-K10) > Remote Commands to Perform GSM Measurements > Programming Examples > Programming Example: Measuring the Wideband Noise for Multiple Carriers
Programming Example: Measuring the Wideband Noise for Multiple Carriers

This example demonstrates how to configure a GSM wideband noise measurement of a GMSK modulated signal with multiple carriers in a remote environment.

//------------ Preparing the application ------------
// Preset the instrument
*RST
// Enter the GSM option K10
INSTrument:SELect GSM
//Select the multicarrier wideband noise measurement
CONF:MEAS MCWN
// Switch to single sweep mode and stop sweep
INITiate:CONTinuous OFF;:ABORt

//---------- Signal Description ------------
// Configure a multicarrier base station wide area DUT without power classes
CONFigure:MS:DEV:TYPE MCBW
CONFigure:MS:NETWORK PGSM
CONFigure:MS:NETWORK:FREQ:BAND 900
CONFigure:MS:POW:CLAS NONE

// Configure 2 subblocks of carriers with 3 carriers each and a gap of 5 MHz
CONF:MS:MCAR:FALL NCON

CONF:MS:MCAR:CARR1:FREQ 935 MHZ
CONF:MS:MCAR:CARR2:FREQ 935.6 MHZ
CONF:MS:MCAR:CARR3:FREQ 936.2 MHZ

CONF:MS:MCAR:CARR4:FREQ 941.2 MHZ
CONF:MS:MCAR:CARR5:FREQ 941.8 MHZ
CONF:MS:MCAR:CARR6:FREQ 942.4 MHZ

CONF:MS:MCAR:FALL:NCON:GSAC 3

// Normal burst 8PSK modulation
CONF:MS:MCAR:CARR1:MTYP N8PS
CONF:MS:MCAR:CARR2:MTYP N8PS
CONF:MS:MCAR:CARR3:MTYP N8PS
CONF:MS:MCAR:CARR4:MTYP N8PS
CONF:MS:MCAR:CARR5:MTYP N8PS
CONF:MS:MCAR:CARR6:MTYP N8PS

//---------- Span and Level ---------------------
// Set Ref. Level to 30 dBm
DISPlay:WINDow:TRACe:Y:SCALe:RLEVel:RF 0 DBM
// Set Ref. Level Offset to 38 dB
DISPlay:WINDow:TRACe:Y:SCALe:RLEVel:OFFSet 38 DB

// Set frequency span to the Tx band +/- 10 MHz automatically
SENS:FREQ:SPAN:MODE TXB
SENS:FREQ:SPAN?
SENS:FREQ:STAR?
SENS:FREQ:STOP?
// Result: span = 45.0 MHz (925 MHZ to 970 MHz)

//---------- Configuring the reference measurement -----------
// Configure the reference levels manually according to table 5-8
// power level is 35 dBm
CONF:SPEC:MOD:REF:MEAS OFF
CONF:SPEC:MOD:REF:PLEV 35
CONF:SPEC:MOD:REF:RPOW 30e3,27.3
CONF:SPEC:MOD:REF:RPOW 100e3,31.2
CONF:SPEC:MOD:REF:RPOW 300e3,33.3

//----------- Configuring the noise measurement --------------
// Define an average count of 200
SENS:SWE:COUN 200

// Determine wideband noise and intermodulation products of orders 3 and 5
CONF:SPEC:NWID ON
CONF:SPEC:IMP 3,5
// Apply exceptions to limit check
CONF:SPEC:LIM:EXC ON

//---------- Configuring the result display ------------

// Activate the following result displays:
// 1: Spectrum graph (default, top)
// 2: Inner IM Table (replaces Carrier Power table)
// 3: Outer IM Table (bottom)
LAYout:REPL:WINDow '2',IIMP
LAYout:ADD:WINDow? '3',BEL,OIMP

//--------------Performing the Measurement-----
// Initiate a new measurement and wait until the sweep has finished.
INITiate:IMMediate;*WAI

//---------------Retrieving Results-------------
// Query trace data for Spectrum graph
TRAC1:DATA? TRACE1
// Query intermodulation results
FETC:WSP:IMPR:INN?
FETC:WSP:IMPR:OUT?

// Query wideband noise limit line (including exceptions)
// x-values:
CALC1:LIM1:CONT:DATA?
// y-values:
CALC1:LIM1:UPP:DATA?

// Query limit line trace values for intermodulation
// measured with 100 kHZ RBW
// x-values:
CALC1:LIM2:CONT:DATA?
// y-values:
CALC1:LIM2:UPP:DATA?

// Query limit line trace values for intermodulation
// measured with 300 kHZ RBW
// x-values:
CALC1:LIM3:CONT:DATA?
// y-values:
CALC1:LIM3:UPP:DATA?

// Query number of exceptions of range A:
// Counted number of exceptions:
CALC1:LIM5:EXC:COUN:CURR?
// Maximum number of exceptions allowed to pass the exception check
CALC1:LIM5:EXC:COUN:MAX?

// Query number of exceptions of range B:
// Counted number of exceptions:
CALC1:LIM6:EXC:COUN:CURR?
// Maximum number of exceptions allowed to pass the exception check
CALC1:LIM6:EXC:COUN:MAX?

// Query limit check results
// Overall:
FETC:SPEC:MOD:LIM:FAIL?
// Wideband noise:
CALC1:LIM1:FAIL?
// Intermodulation (100 kHz RBW):
CALC1:LIM2:FAIL?
// Intermodulation (300 kHz RBW):
CALC1:LIM3:FAIL?
// Exception counting range A:
CALC1:LIM5:FAIL?
// Exception counting range B:
CALC1:LIM6:FAIL?


Annex: Reference

GSM application (R&S FSW-K10) > Annex: Reference
Annex: Reference
Contents
  • List of abbreviations


List of abbreviations

GSM application (R&S FSW-K10) > Annex: Reference > List of abbreviations
List of abbreviations
16QAM | 16-ary Quadrature Amplitude Modulation
32QAM | 32-ary Quadrature Amplitude Modulation
3GPP | 3rd Generation Partnership Project
8PSK | Phase Shift Keying with 8 phase states
AQPSK | Adaptive Quadrature Amplitude Modulation
ARFCN | Absolute Radio Frequency Channel Number
BTS | Base Transceiver Station
DL | Downlink (MS to BTS)
DUT | Device Under Test
EDGE | Enhanced Data Rates for GSM Evolution
EGPRS | Enhanced General Packet Radio, synonym for EDGE.
EGPRS2 | Enhanced General Packet Radio and support of additional modulation/coding schemes and higher symbol rate.
FDMA | Frequency Division Multiplex Access
GMSK | Gaussian Minimum Shift Keying
GPRS | General Packet Radio Service
GSM | Global System for Mobile Communication
HSCSD | High-Speed Circuit-Switch Data
IF | Intermediate Frequency
MS | Mobile Station
NSP | Normal Symbol Period
PCL | Power Control Level
PDF | Probability Density Function
PvT | Power vs Time
QPSK | Quadrature Phase Shift Keying
SCPIR | Subchannel Power Imbalance Ratio
SFH | Slow Frequency Hopping
TDMA | Time Division Multiplex Access
TSC | Training Sequence Code
UL | Uplink (BTS to MS)
VAMOS | Voice services over Adaptive Multi-user Channels on One Slot
YIG | Yttrium Iron Garnet


List of Commands

GSM application (R&S FSW-K10) > List of Commands
List of Commands
[SENSe:]ADJust:FREQuency
[SENSe:]BANDwidth[:RESolution]:TYPE
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]SWAPiq
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:TRGS:CURRent?
[SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME:AUTO
[SENSe]:BURSt:COUNt
ABORt
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:MIVal?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:APEak
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:LIMit<k>:CONTrol:DATA?
CALCulate<n>:LIMit<k>:EXCeption:COUNt:CURR?
CALCulate<n>:LIMit<k>:EXCeption:COUNt:MAX?
CALCulate<n>:LIMit<k>:FAIL?
CALCulate<n>:LIMit<k>:LOWer[:DATA]?
CALCulate<n>:LIMit<k>:UPPer[:DATA]?
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:MAXimum:APEak
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CONFigure:BURSt:ETIMe[:IMMediate]
CONFigure:BURSt:MACCuracy[:IMMediate]
CONFigure:BURSt:MERRor[:IMMediate]
CONFigure:BURSt:PFERror[:IMMediate]
CONFigure:BURSt:PTEMplate:FILTer
CONFigure:BURSt:PTEMplate:SELect
CONFigure:BURSt:PTEMplate:TALign
CONFigure:BURSt:PTEMplate[:IMMediate]
CONFigure:MEASurement
CONFigure:SPECtrum:IMPorder
CONFigure:SPECtrum:LIMit:EXCeption[:STATe]
CONFigure:SPECtrum:LIMit:LEFT
CONFigure:SPECtrum:LIMit:RIGHt
CONFigure:SPECtrum:MODulation:LIMIT
CONFigure:SPECtrum:MODulation:REFerence:AVERage:COUNt
CONFigure:SPECtrum:MODulation:REFerence:CARRier:NUMBer
CONFigure:SPECtrum:MODulation:REFerence:CARRier[:AUTO]
CONFigure:SPECtrum:MODulation:REFerence:MEASure
CONFigure:SPECtrum:MODulation:REFerence:PLEVel
CONFigure:SPECtrum:MODulation:REFerence:RPOWer
CONFigure:SPECtrum:MODulation[:IMMediate]
CONFigure:SPECtrum:NWIDe
CONFigure:SPECtrum:SELect
CONFigure:SPECtrum:SWITching:LIMIT
CONFigure:SPECtrum:SWITching:TYPE
CONFigure:SPECtrum:SWITching[:IMMediate]
CONFigure:TRGS:ADPSize
CONFigure:TRGS:NOFBins
CONFigure:TRGS[:IMMediate]
CONFigure:WSPectrum:MODulation:LIMIT
CONFigure:WSPectrum:MODulation:LIST:SELect
CONFigure:WSPectrum:MODulation[:IMMediate]
CONFigure[:MS]:ARFCn
CONFigure[:MS]:AUTO:FRAMe ONCE
CONFigure[:MS]:AUTO:LEVel ONCE
CONFigure[:MS]:AUTO:TRIGger ONCE
CONFigure[:MS]:BSEarch
CONFigure[:MS]:BSTHreshold
CONFigure[:MS]:CHANnel:FRAMe:EQUal
CONFigure[:MS]:CHANnel:MSLots:MEASure
CONFigure[:MS]:CHANnel:MSLots:NOFSlots
CONFigure[:MS]:CHANnel:MSLots:OFFSet
CONFigure[:MS]:CHANnel:SLOT<Number>:FILTer
CONFigure[:MS]:CHANnel:SLOT<Number>:MTYPe
CONFigure[:MS]:CHANnel:SLOT<Number>:TADVance
CONFigure[:MS]:CHANnel:SLOT<Number>:TYPE
CONFigure[:MS]:CHANnel:SLOT<Number>[:STATe]
CONFigure[:MS]:CHANnel:SLOT<s>:SCPir
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC
CONFigure[:MS]:CHANnel:SLOT<s>:SUBChannel<ch>:TSC:USER
CONFigure[:MS]:CHANnel:SLOT<s>:TSC
CONFigure[:MS]:CHANnel:SLOT<s>:TSC:USER
CONFigure[:MS]:DEMod:DECision
CONFigure[:MS]:DEMod:STDBits
CONFigure[:MS]:DEVice:TYPE
CONFigure[:MS]:MCARrier:ACTCarriers
CONFigure[:MS]:MCARrier:BTSClass
CONFigure[:MS]:MCARrier:CARRier<c>:FREQuency
CONFigure[:MS]:MCARrier:CARRier<c>:MTYPe
CONFigure[:MS]:MCARrier:CARRier<c>[:STATe]?
CONFigure[:MS]:MCARrier:FALLocation
CONFigure[:MS]:MCARrier:FALLocation:NCONtiguous:GSACarrier
CONFigure[:MS]:MCARrier:FILTer
CONFigure[:MS]:MCARrier:MCBTs
CONFigure[:MS]:MCARrier[:STATe]
CONFigure[:MS]:MTYPe
CONFigure[:MS]:MULTi:BURSt:CONStell
CONFigure[:MS]:MULTi:BURSt:DEModulation
CONFigure[:MS]:MULTi:BURSt:PTEMplate
CONFigure[:MS]:MULTi:SPECtrum:MODulation
CONFigure[:MS]:MULTi:SPECtrum:SWITching
CONFigure[:MS]:MULTi:STATe
CONFigure[:MS]:NETWork:FREQuency:BAND
CONFigure[:MS]:NETWork[:TYPE]
CONFigure[:MS]:POWer:AUTO ONCE
CONFigure[:MS]:POWer:AUTO:SWEep:TIME
CONFigure[:MS]:POWer:CLASs
CONFigure[:MS]:POWer:PCARrier:AUTO?
CONFigure[:MS]:POWer:PCARrier?
CONFigure[:MS]:SSEarch
CONFigure[:MS]:SYNC:IQCThreshold
CONFigure[:MS]:SYNC:MODE
CONFigure[:MS]:SYNC:ONLY
DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:SINFo?
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FETCh:BURSt:PTEMplate:TRGS:AVERage?
FETCh:BURSt:PTEMplate:TRGS:CURRent?
FETCh:BURSt:PTEMplate:TRGS:MAXimum?
FETCh:BURSt:PTEMplate:TRGS:MINimum?
FETCh:BURSt:PTEMplate:TRGS:SDEViation?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:ALL:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:AVERage?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:CRESt?
FETCh:BURSt:SPOWer:SLOT<s>:CURRent:MAXimum?
FETCh:BURSt:SPOWer:SLOT<s>:DELTatosync?
FETCh:BURSt:SPOWer:SLOT<s>:LIMit:FAIL?
FETCh:BURSt[:MACCuracy]:ADRoop:AVERage?
FETCh:BURSt[:MACCuracy]:ADRoop:CURRent?
FETCh:BURSt[:MACCuracy]:ADRoop:MAXimum?
FETCh:BURSt[:MACCuracy]:ADRoop:SDEViation?
FETCh:BURSt[:MACCuracy]:ALL?
FETCh:BURSt[:MACCuracy]:BPOWer:AVERage?
FETCh:BURSt[:MACCuracy]:BPOWer:CURRent?
FETCh:BURSt[:MACCuracy]:BPOWer:MAXimum?
FETCh:BURSt[:MACCuracy]:BPOWer:SDEViation?
FETCh:BURSt[:MACCuracy]:FERRor:AVERage?
FETCh:BURSt[:MACCuracy]:FERRor:CURRent?
FETCh:BURSt[:MACCuracy]:FERRor:MAXimum?
FETCh:BURSt[:MACCuracy]:FERRor:SDEViation?
FETCh:BURSt[:MACCuracy]:FREQuency:AVERage?
FETCh:BURSt[:MACCuracy]:FREQuency:CURRent?
FETCh:BURSt[:MACCuracy]:FREQuency:MAXimum?
FETCh:BURSt[:MACCuracy]:FREQuency:SDEViation?
FETCh:BURSt[:MACCuracy]:IQIMbalance:AVERage?
FETCh:BURSt[:MACCuracy]:IQIMbalance:CURRent?
FETCh:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
FETCh:BURSt[:MACCuracy]:IQIMbalance:SDEViation?
FETCh:BURSt[:MACCuracy]:IQOFfset:AVERage?
FETCh:BURSt[:MACCuracy]:IQOFfset:CURRent?
FETCh:BURSt[:MACCuracy]:IQOFfset:MAXimum?
FETCh:BURSt[:MACCuracy]:IQOFfset:SDEViation?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?
FETCh:BURSt[:MACCuracy]:OSUPpress:AVERage?
FETCh:BURSt[:MACCuracy]:OSUPpress:CURRent?
FETCh:BURSt[:MACCuracy]:OSUPpress:MAXimum?
FETCh:BURSt[:MACCuracy]:OSUPpress:SDEViation?
FETCh:BURSt[:MACCuracy]:PERCentile:EVM?
FETCh:BURSt[:MACCuracy]:PERCentile:MERRor?
FETCh:BURSt[:MACCuracy]:PERCentile:PERRor?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
FETCh:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
FETCh:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?
FETCh:MCAPture:SLOTs:MEASure?
FETCh:MCAPture:SLOTs:SCOPe?
FETCh:SPECtrum:MODulation:LIMit:FAIL?
FETCh:SPECtrum:MODulation:REFerence?
FETCh:SPECtrum:MODulation[:ALL]?
FETCh:SPECtrum:SWITching:REFerence?
FETCh:SPECtrum:SWITching[:ALL]?
FETCh:WSPectrum:IMPRoducts:INNer[:ALL]?
FETCh:WSPectrum:IMPRoducts:OUTer[:ALL]?
FETCh:WSPectrum:MODulation:REFerence?
FETCh:WSPectrum:MODulation[:ALL]?
FETCh:WSPectrum:REFerence:POWer[:ALL]?
FORMat:DEXPort:DSEParator
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:DISPlay
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:TYPe?
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
READ:AUTO:LEVTime?
READ:BURSt:PTEMplate:TRGS:AVERage?
READ:BURSt:PTEMplate:TRGS:CURRent?
READ:BURSt:PTEMplate:TRGS:MAXimum?
READ:BURSt:PTEMplate:TRGS:MINimum?
READ:BURSt:PTEMplate:TRGS:SDEViation?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:ALL:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:AVERage?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:CRESt?
READ:BURSt:SPOWer:SLOT<Slot>:CURRent:MAXimum?
READ:BURSt:SPOWer:SLOT<Slot>:DELTatosync?
READ:BURSt:SPOWer:SLOT<Slot>:LIMit:FAIL?
READ:BURSt[:MACCuracy]:ADRoop:AVERage?
READ:BURSt[:MACCuracy]:ADRoop:CURRent?
READ:BURSt[:MACCuracy]:ADRoop:MAXimum?
READ:BURSt[:MACCuracy]:ADRoop:SDEViation?
READ:BURSt[:MACCuracy]:ALL
READ:BURSt[:MACCuracy]:BPOWer:AVERage?
READ:BURSt[:MACCuracy]:BPOWer:CURRent?
READ:BURSt[:MACCuracy]:BPOWer:MAXimum?
READ:BURSt[:MACCuracy]:BPOWer:SDEViation?
READ:BURSt[:MACCuracy]:FERRor:AVERage?
READ:BURSt[:MACCuracy]:FERRor:CURRent?
READ:BURSt[:MACCuracy]:FERRor:MAXimum?
READ:BURSt[:MACCuracy]:FERRor:SDEViation?
READ:BURSt[:MACCuracy]:FREQuency:AVERage?
READ:BURSt[:MACCuracy]:FREQuency:CURRent?
READ:BURSt[:MACCuracy]:FREQuency:MAXimum?
READ:BURSt[:MACCuracy]:FREQuency:SDEViation?
READ:BURSt[:MACCuracy]:IQIMbalance:AVERage?
READ:BURSt[:MACCuracy]:IQIMbalance:CURRent?
READ:BURSt[:MACCuracy]:IQIMbalance:MAXimum?
READ:BURSt[:MACCuracy]:IQIMbalance:SDEViation?
READ:BURSt[:MACCuracy]:IQOFfset:AVERage?
READ:BURSt[:MACCuracy]:IQOFfset:CURRent?
READ:BURSt[:MACCuracy]:IQOFfset:MAXimum?
READ:BURSt[:MACCuracy]:IQOFfset:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:MERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:MERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:MERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:MERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:MERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:MERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy]:OSUPpress:AVERage?
READ:BURSt[:MACCuracy]:OSUPpress:CURRent?
READ:BURSt[:MACCuracy]:OSUPpress:MAXimum?
READ:BURSt[:MACCuracy]:OSUPpress:SDEViation?
READ:BURSt[:MACCuracy]:PERCentile:EVM?
READ:BURSt[:MACCuracy]:PERCentile:MERRor?
READ:BURSt[:MACCuracy]:PERCentile:PERRor?
READ:BURSt[:MACCuracy]:PERRor:PEAK:AVERage?
READ:BURSt[:MACCuracy]:PERRor:PEAK:CURRent?
READ:BURSt[:MACCuracy]:PERRor:PEAK:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:PEAK:SDEViation?
READ:BURSt[:MACCuracy]:PERRor:RMS:AVERage?
READ:BURSt[:MACCuracy]:PERRor:RMS:CURRent?
READ:BURSt[:MACCuracy]:PERRor:RMS:MAXimum?
READ:BURSt[:MACCuracy]:PERRor:RMS:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:PEAK:AVERage?
READ:BURSt[:MACCuracy][:EVM]:PEAK:CURRent?
READ:BURSt[:MACCuracy][:EVM]:PEAK:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:PEAK:SDEViation?
READ:BURSt[:MACCuracy][:EVM]:RMS:AVERage?
READ:BURSt[:MACCuracy][:EVM]:RMS:CURRent?
READ:BURSt[:MACCuracy][:EVM]:RMS:MAXimum?
READ:BURSt[:MACCuracy][:EVM]:RMS:SDEViation?
READ:SPECtrum:MODulation:GATing?
READ:SPECtrum:MODulation:REFerence[:IMMediate]?
READ:SPECtrum:MODulation[:ALL]?
READ:SPECtrum:SWITching:REFerence:GATing?
READ:SPECtrum:SWITching:REFerence[:IMMediate]
READ:SPECtrum:SWITching[:ALL]?
READ:SPECtrum:WMODulation:GATing?
READ:WSPectrum:MODulation:GATing?
READ:WSPectrum:MODulation:GATing?
READ:WSPectrum:MODulation:REFerence[:IMMediate]?
READ:WSPectrum:MODulation[:ALL]?
SENSe:FREQuency:SPAN:MODE
STATus:OPERation:CONDition?
STATus:OPERation:ENABle
STATus:OPERation:NTRansition
STATus:OPERation:PTRansition
STATus:OPERation[:EVENt]?
STATus:PRESet
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:ENABle
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:NTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEue[:NEXT]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe:IQ:BWIDth?
TRACe:IQ:DATA:MEMory?
TRACe:IQ:SRATe?
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


Legal Notice

R&S®FSW-K10
GSM Measurement

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.